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1. Introduction

This version of Cytoscape builds upon
the new 3.x architecture, developer API and set of user controls established. If you’re familiar with former versions of Cytoscape,
this version will feel completely familiar and you’ll be all set to go.
In future releases, we will continue to tweak and improve both the
software and the documentation. This manual will be updated to reflect
all the latest changes.

If you would prefer to learn by doing, consider starting with the Basic Expression Analysis Tutorial [https://cytoscape.org/cytoscape-tutorials/protocols/basic-data-visualization/#/].

This manual describes the installation and use of Cytoscape. For a more
thorough understanding of Cytoscape and its ecosystem, we highly
recommend reading the Welcome Letter accessible on the
http://cytoscape.org website.





          

      

      

    

  

    
      
          
            
   


2. Launching Cytoscape

Cytoscape is a Java application verified to run on the Linux, Windows,
and Mac OS X platforms. Although not officially supported, other UNIX
platforms such as Solaris or FreeBSD may run Cytoscape if Java version 8
is available for the platform.

 


2.1. System Requirements

The system requirements for Cytoscape depend on the size of the networks
you want to load, view and manipulate.

Note that as of Cytoscape v3.2, networks are loaded faster and in less
memory than with previous versions. While this is good news, networks
created on v3.2 on a given memory configuration (e.g., 1GB) may not be
loadable by prior Cytoscape versions on the same memory configuration.


Required Resources
 	                           	Small Network Visualization 	Large Network Analysis/Visualization              

 	Processor     	1GHz               	As fast as possible, with multiple cores 

 	Memory     	512MB           	2GB+                                  

 	Graphics Card 	Integrated video   	High-end graphics card                   

 	Monitor    	XGA (1024X768)  	Wide or Dual Monitor                  



Specific system requirements, limitations, and configuration options
apply to each platform, as described in the Release Notes available
on the http://cytoscape.org website.
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3. Command Line Arguments

Cytoscape recognizes a number of optional command line arguments,
including run-time specification of network files, node and edge data
files, and session files. This is the output generated when Cytoscape is
executed with the “-h” or “–help” flag:

usage: cytoscape.{sh|bat} [OPTIONS]
 -h,--help             Print this message.
 -v,--version          Print the version number.
 -s,--session <file>   Load a cytoscape session (.cys) file.
 -N,--network <file>   Load a network file (any format).
 -P,--props <file>     Load cytoscape properties file (Java properties
                       format) or individual property: -P name=value.
 -V,--vizmap <file>    Load vizmap properties file (Cytoscape VizMap
                       format).
 -S,--script <file>    Execute commands from script file.
 -R,--rest <port>      Start a rest service.





Any file specified for an option may be specified as either a path or as
a URL. For example you can specify a network as a file (assuming that
myNet.sif exists in the current working directory):
cytoscape.sh -N myNet.sif.

Note: if there are spaces in the file path, be sure to put quotes around
it:
cytoscape.bat -N "C:\Program Files\Cytoscape\sampleData\galFiltered.sif".

Or you can specify a network as a URL:
cytoscape.sh -N http://example.com/myNet.sif.


Command Line Arguments
                             
  
    
    4. Quick Tour of Cytoscape
    

    

    

    
 
  

    
      
          
            
   


4. Quick Tour of Cytoscape

This chapter describes the basic layout and mechanics of using Cytoscape. If you would prefer to learn by doing, consider starting with the Basic Expression Analysis Tutorial [https://cytoscape.org/cytoscape-tutorials/protocols/basic-data-visualization/#/].

 


4.1. Starter Panel

When you start Cytoscape, you can access basic functions from the
Starter Panel:

[image: _images/Welcome_38.png]

The Starter Panel is designed to give you quick access to a set of sample session files,
as well as tutorials and Cytoscape news. The sample session files include a broad range of networks
to give a sense of the diversity of interaction types, visualization styles and biological applications (see
Network Table properties for more information about each sample session network).
The Starter Panel will also present your own most recent sessions for quick access.

When you load a session file, the Starter Panel will disappear. You can display it at any
time by choosing View → Show Starter Panel.

For
information on user privacy, see the Cytoscape Privacy
Policy.

 




4.2. Basic Features

When a network is loaded, Cytoscape will look similar to the image
below:

[image: _images/NetworkLoaded38.png]

Most functionalities are self-explanatory, but we’ll go through a
concise explanation for clarity. The main window here has several
components:


	The Menu Bar at the top (see below for more information about
each menu).


	The Tool Bar, which contains icons for commonly used functions.
These functions are also available via the menus. Hover the mouse
pointer over an icon and wait momentarily for a description to
appear as a tooltip. Right-clicking on the tool bar allows the
contents to be customized.


	The Network Panel (Network tab of the Control Panel).
At the top of the Network Panel is a Search bar, with direct access
to multiple external resources. The network panel also
contains an optional network overview pane (shown at the
bottom left).


	The main Network View Window, which displays the network. At the bottom
of the network view are a set of network view tools.


	The Table Panel (bottom right panel), which displays columns of
selected nodes and edges and enables you to modify the values of
column data.




The Network Panel and Table Panel are dockable tabbed Panels. You can
undock any of these panels by clicking on the Float Window control
[image: _images/FloatWindow.png]
in the upper-right corner of the CytoPanel. This is useful when you want
assign the network panel as much screen space as possible. You will now
have two Cytoscape windows, the main window, and a new window labeled
Table Panel, similar to the one shown below. A popup will be displayed
when you put the mouse pointer on a cell.

To dock the window again, click the Dock Window icon
[image: _images/DockWindow.png].

Clicking the Minimize icon [image: _images/Minimize.png]
will minimize the panel; the panel can be shown again by choosing View → Show
and selecting the relevant panel, or by clicking on one of the tabs in the
minimized panel, for example Network or Node Table, and then clicking
the Dock icon.

[image: _images/TablePanel38.png]

For more information on the panels in Cytoscape, see the Panels
section.

 


Network Editing

Cytoscape also has an edit functionality that enables you to build and
modify networks interactively within the network canvas. To edit a
network, just right-click on the open space of network window, select
the menu item Add → Node, a new node will be added to the canvas. To
add an edge, right click on a node, choose the menu item Edit → Add
Edge. Then select the target node, a new edge will be added between
the two nodes. In a similar way annotation objects can be added;
pictures, shapes or textboxes; much like in MS PowerPoint or similar
software. Detailed information on network editing can be found in the
Editing Networks
section.

[image: _images/AddNodeMenu37.png]

 






4.3. The Menus

 


File

The File menu contains most basic file functionality: File → Open
for opening a Cytoscape session file; File → New Network for creating a new
network, either blank for editing, or from an existing network; File →
Save for saving a session file; File → Import for importing data
such as networks and tables; and File → Export for exporting data.
File → Export Network to Image lets you export the
network in either JPEG, PDF, PNG, PostScript or SVG format.
File → Export Network to Web Page lets you export the entire session or
a single network as a Web page using Cytoscape.js.

File → Open Recent will list recently opened session files for
quick access. File → Print… allows printing.

[image: _images/FileMenu37.png]

 




Edit

The Edit menu contains Cut, Copy and Paste functions, as
well as Undo and Redo functions which undo and redo edits made
in the Table Panel, the Network Editor and to layout.

There are also options for creating and destroying views (graphical
representations of a network) and networks (the raw network data - not
yet visualized), as well as an option for deleting selected nodes and
edges from the current network. All deleted nodes and edges can be
restored to the network via Edit → Undo.

Other editing options include; Remove Duplicated Edges will
delete edges that are duplicates (having the same source and target nodes), keeping one edge, Remove
Self-Loops removes edges that have the same source and target node,
and Delete Selected Nodes and Edges… deletes a selected subset of
the network. Rename Network… allows you to rename the currently
selected network.

A set of functions for bringing annotations forward, backward etc, and pushing/pulling
them to the foreground vs background layer are also available in the Edit menu.

Editing preferences for properties and apps are found under Edit →
Preferences → Properties…. More details on how to edit preferences
can be found
here.

[image: _images/EditMenu.png]

 




View

The View menu allows you to display or hide panels, including the Control Panel,
Table Panel, Result Panel, Tool Panel and the Automation Panel. In addition, it
also provides a means for viewing the Starter Panel.
It also provides the control of other view-related functionality.

[image: _images/ViewMenu38.png]

 




Select

The Select menu contains different options for selecting nodes and
edges.

[image: _images/SelectMenu37.png]

 




Layout

The Layout menu has an array of features for visually organizing the
network. The features in the top portion of the network (Bundle
Edges, Clear Edge Bends, Node Layout Tools) are tools for
manipulating the network visualization. The
bottom section of the menu lists a variety of layout algorithms which
automatically lay a network out.

[image: _images/LayoutMenu37.png]

 




Apps

The Apps menu gives you access to the App Manager (Apps → App
Manager) for managing (install/update/delete) your apps and may have
options added by apps that have been installed. Depending on which apps
are loaded, the apps that you see may be different than what appear
here. The below picture shows a Cytoscape installation without installed
apps.

[image: _images/AppsMenu.png]

Note: A list of available Cytoscape apps with descriptions is available online at: http://apps.cytoscape.org

In previous versions of Cytoscape, apps were called plugins and served a
similar function.

 




Tools

The Tools menu contains advanced features like cyCharts, Network Analyzer, Cytoscape Web Browser, Network Merge, Execute Command File…, Job Status Monitor, Run Script File… and Diffuse.

Cytoscape Web Browser allows for viewing any html page directly in Cytoscape. The web browser can be opened in a separate window or can be launched in the Results Panel.

[image: _images/ToolsMenu.png]

 




Help

The Help menu allows you to launch the online help viewer and browse and search this manual.
It also provides direct access to a Tour of Cytoscape, as well as a full listing
of Cytoscape tutorials. Tutorial content opens automatically in the Cytoscape Web Browser.
Video demos are also linked to direclty from the Help menu.

[image: _images/HelpMenu.png]

The Citations option displays the main literature citation for
Cytoscape, as well as a list of literature citations for installed apps.
The list will be different depending on the set of apps you have
installed.

[image: _images/Citations.png]

The Help menu also allows you to connect directly to Cytoscape Help
Desk and the Bug Report interface.

 






4.4. Network Management

Cytoscape allows multiple networks to be loaded at a time, either with
or without a view. A network stores all the nodes and edges that are
loaded by the user and a view displays them.

An example where a number of networks have been loaded is shown below:

[image: _images/MultipleNetworkView.png]

The network manager (in Control Panel) shows the networks that are
loaded. Clicking on a network here will make that view active in the
main window, if the view exists. Each network has a name and size
(number of nodes and edges), which are shown in the network manager. If
a network is loaded from a file, the network name is the name of the
file.

Some networks are very large (thousands of nodes and edges) and can take
a long time to display. For this reason, a network in Cytoscape may not
contain a “view”. Networks that have a view are in normal black font and
networks that don’t have a view are highlighted in red. You can create
or destroy a view for a network by right-clicking the network name in
the network manager or by choosing the appropriate option in the
Edit menu. You can also destroy previously loaded networks this way.

Certain operations in Cytoscape will create new networks. If a new
network is created from an old network, for example by selecting a set
of nodes in one network and copying these nodes to a new network (via
the File → New Network option), it will be shown immediately
follows the network that it was derived from.

Network views can also be detached (undocked) from the main Cytoscape window. When detached, a view window can be dragged to another monitor, resized, maximized and minimized by using the normal window controls for your operating system. Notice, however, that closing a view window does not destroy it, but simply reattaches it to the Cytoscape window.

 


Arrange Network Windows

When you have detached network view windows, you can arrange them by selecting one of these options under View → Arrange Detatched Views:

Grid

[image: _images/MultipleNetworks_Grid.png]

Cascade

[image: _images/MultipleNetworks_Cascade.png]

Vertical Stack

[image: _images/MultipleNetworks_VerticalStack.png]

Side by Side

[image: _images/MultipleNetworks_SidebySide.png]

 






4.5. Network View Tools

At the bottom of the Network View Window is a set of network tools:

[image: _images/NetworkTools.png]


	Show Grid will arrange all loaded networks as a grid.


	Show Network will show the currently selected network.


	Detach View detaches the network view window from the main Cytoscape window.


	Export to File… gives you options to export the network or image.


	Always Show Graphics Detail forces the rendering of graphics details. It is turned off by default.


	Toggle Node Selection allows you to turn off/on node selection. It is turned on by default.


	Toggle Edge Selection allows you to turn off/on edge selection. It is turned on by default.


	Toggle Annotation Selection allows you to turn off/on annotation selection. It is turned off by default.


	Toggle Node Label Selection allows you to turn off/on node label selection. It is turned off by default.


	Hide Navigator lets you hide the Navigator (“bird’s eye view”).




The Navigator (or “bird’s eye view”) shows an overview of the network. It can be used to navigate around a large network view. The blue rectangle indicates the portion of the network currently displayed in the network view window, and it can be dragged with the mouse to view other portions of the network. Zooming in will cause the rectangle to appear smaller and vice versa.

[image: _images/NetworkOverview.png]
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5. Creating Networks

There are 4 different ways of creating networks in Cytoscape:


	Importing pre-existing, fixed-format network files.


	Importing pre-existing, unformatted text or Excel files.


	Importing data from from public databases.


	Creating an empty network and manually adding nodes and edges.




 


5.1. Import Fixed-Format Network Files

Network files can be specified in any of the formats described in the
Supported Network
Formats
section. Networks are imported into Cytoscape via File →
Import. The network file can either be located directly
on the local computer, or found on a remote computer (in which case it
will be referenced with a URL).

 


Load Networks from Local Computer

In order to load a network from a local file you can select File →
Import → Network from File… or click on
[image: _images/Cy3_icon_net_file_import.png]
on the tool bar. Choose the correct file in the file chooser dialog and
press Open. Some sample network files of different types have been
included in the sampleData folder in Cytoscape.

After you choose a network file, another dialog will pop up. Here, you
can choose either to create a new network collection for the new
network, or load the new network into an existing network collection.
When you choose the latter, make sure to choose the right mapping column
to map the new network to the existing network collection.

[image: _images/ImportNetwork.png]

Alternatively, you can simply drag and drop a network file from the desktop into the Network list
(Control Panel), rather than selecting the file from the menu option.

Network files in SIF, GML, and XGMML formats may also be loaded directly
from the command line using the -N option.

 




Load Networks from a Remote Computer (URL import)

To load a network from a remote file, you can select File → Import →
Network from URL…. In the import network dialog, insert the appropriate
URL, either manually or using URL bookmarks. Bookmarked URLs can be
accessed by clicking on the arrow to the right of the text field (see
the Bookmark Manager in
Preferences
for more details on bookmarks). Also, you can drag and drop links from a
web browser to the URL text box. Once a URL has been specified, click on
the OK button to load the network.

[image: _images/ImportNetworkFromURL.png]

Another issue for network import is the presence of firewalls, which can
affect which files are accessible to a computer. To work around this
problem, Cytoscape supports the use of proxy servers. To configure a
proxy server, go to Edit → Preferences → Proxy Settings…. This is
further described in the
Preferences
section.

 






5.2. Import Networks from Unformatted Table Files

Cytoscape supports the import of networks from delimited text files and
Excel workbooks using File → Import → Network from File…. An
interactive GUI allows users to specify parsing options for specified
files. The screen provides a preview that shows how the file will be
parsed given the current configuration. As the configuration changes,
the preview updates automatically. In addition to specifying how the
file will be parsed, the user must also choose the columns that
represent the source and target nodes as well as an optional edge
interaction type. For detailed instructions, see Basic Operations below.

[image: _images/ImportNetworkDialog2.png]

 


Supported Files

The import function supports delimited text files
and Microsoft Excel Workbooks. For Excel Workbooks with multiple sheets,
one sheet can be selected for import at a time. The following is a
sample table file:


Sample Network in Table
 	source     	target     	interaction  	boolean data  	string data   	floating point data 

 	YJR022W    	YNR053C    	pp           	TRUE          	abcd12371     	1.2344543           

 	YER116C 	YDL013W 	pp       	TRUE      	abcd12372 	1.2344543       

 	YNL307C    	YAL038W    	pp           	FALSE         	abcd12373     	1.2344543           

 	YNL216W 	YCR012W 	pd       	TRUE      	abcd12374 	1.2344543       

 	YNL216W    	YGR254W    	pd           	TRUE          	abcd12375     	1.2344543           



The network table files should contain at least two columns for creating
network with edges. If the file has only one column, the created network
will not contain any edges. The interaction type is optional in this
format. Therefore, a minimal network table looks like the following:


Minimal Network Table
 	source     	target     

 	YJR022W    	YNR053C    

 	YER116C 	YDL013W 

 	YNL307C    	YAL038W    

 	YNL216W 	YCR012W 

 	YNL216W    	YGR254W    



One row in a network table file represents an edge and its edge data
columns. This means that a network file is considered a combination of
network data and edge column data. A table may contain columns that
aren’t meant to be edge data. In this case, you can choose not to import
those columns by clicking on the column header in the preview window.
This function is useful when importing a data table like the following
(1):

[image: _images/sampleTableData1.png]

This data file is a tab-delimited text file and contains network data
(interactions), edge data, and node data. To import network and edge
data from this table, choose Unique ID A as source, Unique ID B as
target, and Interactor types as interaction type. Next, turn off columns
used for node data (Alternative ID A, species B, etc.). Other columns
can be imported as edge data.

The network import function cannot import node table columns - only edge
table columns. To import node table columns from this table, please see
the Node and Edge Column
Data
section of this manual.

Note (1): This data is taken from the A merged human interactome
datasets by Andrew Garrow, Yeyejide Adeleye and Guy Warner (Unilever,
Safety and Environmental Assurance Center, 12 October 2006). Actual data
files are available at http://wiki.cytoscape.org/Data_Sets/.
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6. Nested Networks

Cytoscape has the ability to associate a Nested Network with any
node. A nested network is any other network currently defined in
Cytoscape. This capability allows for creation of network hierarchies as
well as circular relationships. For example, various module-finding
plugins make use of nested networks in the overview network that they
generate. There each node representing a module contains a nested
network.

Note that Nested Networks are similar in concept to Groups, but with very different consequences. A Nested Network incorporates an independent network that does not share nodes or attributes with the current network – it can be edited only as a separate network collection or in a separate Cytoscape session. Its nodes cannot be connected to nodes in the current network and cannot be found or filtered using Cytoscape functions or apps. Conversely, nodes in a Group are part of the current network, can have edges to nodes outside of the group, and can be found or filtered using Cytoscape functions or apps.

Most often, Groups are more functional and easier to use.

 


6.1. Creating Nested Networks

There are currently two ways in which a user can create nested networks.


	By importing a Nested Network Format (NNF) file. (See: NNF
Network
Format).


	By manually constructing networks and assigning nested networks to
individual nodes through the right-click node context menu. (See
Nested Network Node Context
Menu).




 




6.2. Visualization of Nested Networks

Nodes containing nested networks that are zoomed in sufficiently display
an image for the nested network. If no current network view exists for
the nested network the image will be a default icon, otherwise it will
be a low-resolution rendering of the nested network’s current layout.

[image: _images/NestedNetwork2.png]
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7. Supported Network File Formats

Cytoscape can read network/pathway files written in the following
formats:


	Simple interaction file (SIF or .sif format)


	Nested network format (NNF or .nnf format)


	Graph Markup Language (GML or .gml format)


	XGMML (extensible graph markup and modelling language).


	SBML


	BioPAX


	GraphML


	Delimited text


	Excel Workbook (.xls, .xlsx)


	Cytoscape.js
JSON [http://cytoscape.github.io/cytoscape.js/#notation/elements-json]


	Cytoscape CX [https://github.com/CyComponent/CyWiki]




The SIF format specifies nodes and interactions only, while other
formats store additional information about network layout and allow
network data exchange with a variety of other network programs and data
sources. Typically, SIF files are used to import interactions when
building a network for the first time, since they are easy to create in
a text editor or spreadsheet. Once the interactions have been loaded and
network layout has been performed, the network may be saved to GML or
XGMML format for interaction with other systems. All file types listed
(except Excel) are text files and you can edit and view them in a
regular text editor.

 


7.1. SIF Format

The simple interaction format is convenient for building a graph from a
list of interactions. It also makes it easy to combine different
interaction sets into a larger network, or add new interactions to an
existing data set. The main disadvantage is that this format does not
include any layout information, forcing Cytoscape to re-compute a new
layout of the network each time it is loaded.

Lines in the SIF file specify a source node, a relationship type (or
edge type), and one or more target nodes:

nodeA <relationship type> nodeB
nodeC <relationship type> nodeA
nodeD <relationship type> nodeE nodeF nodeB
nodeG
...
nodeY <relationship type> nodeZ





A more specific example is:

node1 typeA node2
node2 typeB node3 node4 node5
node0





The first line identifies two nodes, called node1 and node2, and a
single relationship between node1 and node2 of type typeA. The second
line specifies three new nodes, node3, node4, and node5; here “node2”
refers to the same node as in the first line. The second line also
specifies three relationships, all of type typeB and with node2 as the
source, with node3, node4, and node5 as the targets. This second form is
simply shorthand for specifying multiple relationships of the same type
with the same source node. The third line indicates how to specify a
node that has no relationships with other nodes. This form is not needed
for nodes that do have relationships, since the specification of the
relationship implicitly identifies the nodes as well.

Duplicate entries are ignored. Multiple edges between the same nodes
must have different edge types. For example, the following specifies two
edges between the same pair of nodes, one of type xx and one of type yy:

node1 xx node2
node1 xx node2
node1 yy node2





Edges connecting a node to itself (self-edges) are also allowed:

node1 xx node1





Every node and edge in Cytoscape has a name column. For a network
defined in SIF format, node names should be unique, as identically named
nodes will be treated as identical nodes. The name of each node will be
the name in this file by default (unless another string is mapped to
display on the node using styles). This is discussed in the section on
Styles.
The name of each edge will be formed from the name of the source and
target nodes plus the interaction type: for example,
sourceName (edgeType) targetName.

The tag “edgeType” can be any string. Whole words or concatenated
words may be used to define types of relationships, e.g. geneFusion,
cogInference, pullsDown, activates, degrades, inactivates, inhibits,
phosphorylates, upRegulates, etc.

Some common interaction types used in the Systems Biology community are
as follows:

  pp .................. protein - protein interaction
  pd .................. protein -> DNA
  (e.g. transcription factor binding upstream of a regulating gene.)





Some less common interaction types used are:

  pr .................. protein -> reaction
  rc .................. reaction -> compound
  cr .................. compound -> reaction
  gl .................. genetic lethal relationship
  pm .................. protein-metabolite interaction
  mp .................. metabolite-protein interaction





 


Delimiters

Whitespace (space or tab) is used to delimit the names in the simple
interaction file format. However, in some cases spaces are desired in a
node name or edge type. The standard is that, if the file contains any
tab characters, then tabs are used to delimit the fields and spaces are
considered part of the name. If the file contains no tabs, then any
spaces are delimiters that separate names (and names cannot contain
spaces).

If your network unexpectedly contains no edges and node names that look
like edge names, it probably means your file contains a stray tab that’s
fooling the parser. On the other hand, if your network has nodes whose
names are half of a full name, then you probably meant to use tabs to
separate node names with spaces.

Networks in simple interactions format are often stored in files with a
.sif extension, and Cytoscape recognizes this extension when browsing
a directory for files of this type.

 






7.2. NNF

The NNF format is a very simple format that unlike SIF allows the
optional assignment of single nested network per node. No other node
columns can be specified. There are only 2 possible line formats:


	A node “node” contained in a “network:”




network node


	2 nodes linked together contained in a network:




network node1 interaction node2

If a network name (first entry on a line) appeared previously as a node
name (in columns 2 or 4), the network will be nested in the node with
the same name. Also, if a name that has been previously defined as a
network (by being listed in the first column), later appears as a node
name (in columns 2 or 4), the previously defined network will be nested
in the node with the same name. In summary: any time a name is used as
both, a network name , and a node name, this implies that the network
will be nested in the node of the same name. Additionally comments may
be included on all lines. Comments start with a hash mark ‘#’ and
continue to the end of a line. Trailing comments (after data lines) and
entirely blank lines anywhere are also permissible. Please note that
if you load multiple NNF files in Cytoscape they will be treated like a
single, long concatenated NNF file! If you need to embed spaces, tabs or
backslashes in a name, you must escape it by preceding it with a
backslash, so that, e.g. an embedded backslash becomes two backslashes,
an embedded space a backslash followed by a space etc.

 


Examples


Example 1

[image: _images/NNFExample1_2.png]
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Example 2
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Example 3
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Example 4
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7.3. GML Format

In contrast to SIF, GML is a rich graph format language supported by
many other network visualization packages. The GML file format
specification is available at:

https://www.fim.uni-passau.de/fileadmin/files/lehrstuhl/brandenburg/projekte/gml/gml-technical-report.pdf

It is generally not necessary to modify the content of a GML file
directly. Once a network is built in SIF format and then laid out, the
layout is preserved by saving to and loading from GML. Properties
specified in a GML file will result in a new style named
Filename.style when that GML file is loaded.

 




7.4. XGMML Format

XGMML is the XML evolution of GML and is based on the GML definition. In
addition to network data, XGMML contains node/edge/network column data. More
information on Wikipedia:

https://en.wikipedia.org/wiki/XGMML

XGMML is now preferred to GML because it offers the flexibility
associated with all XML document types. If you’re unsure about which to
use, choose XGMML.

There is a java system property “cytoscape.xgmml.repair.bare.ampersands”
that can be set to “true” if you have experience trouble reading older
files.

This should only be used when an XGMML file or session cannot be read
due improperly encoded ampersands, as it slows down the reading process,
but this is still preferable to attempting to fix such files using
manual editing.

 




7.5. SBML (Systems Biology Markup Language) Format

The Systems Biology Markup Language (SBML) is an XML format to describe
biochemical networks. SBML file format specification is available at:

http://sbml.org/documents/

 




7.6. BioPAX (Biological PAthways eXchange) Format

BioPAX is an OWL (Web Ontology Language) document designed to exchange
biological pathways data. The complete set of documents for this format
is available at:

http://www.biopax.org/

 




7.7. GraphML

GraphML is a comprehensive and easy-to-use file format for graphs. It is
based on XML. The complete set of documents for this format is available
at:

http://graphml.graphdrawing.org/

 




7.8. Delimited Text Table and Excel Workbook

Cytoscape has native support for Microsoft Excel files (.xls, .xlsx) and
delimited text files. The tables in these files can have network data
and edge columns. Users can specify columns containg source nodes,
target nodes, interaction types, and edge columns during file import.
Some of the other network analysis tools, such as igraph
(http://cneurocvs.rmki.kfki.hu/igraph/), has feature to export graph
as simple text files. Cytoscape can read these text files and build
networks from them. For more detail, please read the Import Free-Format
Tables section of the Creating
Networks
section.

 




7.9. Cytoscape.js JSON

From Cytoscape 3.1.0 on, Cytoscape supports
Cytoscape.js [http://cytoscape.github.io/cytoscape.js/] JSON files. You
can use this feature to export your network visualizations to web
browsers. Cytoscape.js has two ways to represent network data, and
currently both reader and writer support only the array style graph
notation. For example, this network in Cytoscape:

[image: _images/JSON1.png]

will be exported to this JSON:

{
  "elements" : {
    "nodes" : [ {
      "data" : {
        "id" : "723",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "RPL31A", "RPL34", "S000002233", "ribosomal protein L31A (L34A) (YL28)" ],
        "shared_name" : "YDL075W",
        "SUID" : 723,
        "degree_layout" : 1,
        "name" : "YDL075W"
      },
      "position" : {
        "x" : 693.0518315633137,
        "y" : -49.47506554921466
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "726",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "RP23", "RPL16B", "S000005013", "ribosomal protein L16B (L21B) (rp23) (YL15)" ],
        "shared_name" : "YNL069C",
        "SUID" : 726,
        "degree_layout" : 1,
        "name" : "YNL069C"
      },
      "position" : {
        "x" : 627.3147710164387,
        "y" : -205.99251969655353
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "658",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "RPL11B", "S000003317", "ribosomal protein L11B (L16B) (rp39B) (YL22)" ],
        "shared_name" : "YGR085C",
        "SUID" : 658,
        "degree_layout" : 2,
        "name" : "YGR085C"
      },
      "position" : {
        "x" : 804.3092778523762,
        "y" : -245.6235926946004
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "660",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "KAP108", "S000002803", "SXM1" ],
        "shared_name" : "YDR395W",
        "SUID" : 660,
        "degree_layout" : 8,
        "name" : "YDR395W"
      },
      "position" : {
        "x" : 730.8733342488606,
        "y" : -157.50702317555744
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "579",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "RPL11A", "S000006306", "ribosomal protein L11A (L16A) (rp39A) (YL22)" ],
        "shared_name" : "YPR102C",
        "SUID" : 579,
        "degree_layout" : 2,
        "name" : "YPR102C"
      },
      "position" : {
        "x" : 841.1395696004231,
        "y" : -130.77909119923908
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "578",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "GRC5", "QSR1", "RPL10", "S000004065", "ribosomal protein L10" ],
        "shared_name" : "YLR075W",
        "SUID" : 578,
        "degree_layout" : 2,
        "name" : "YLR075W"
      },
      "position" : {
        "x" : 910.3755162556965,
        "y" : -217.0562556584676
      },
      "selected" : false
    } ],
    "edges" : [ {
      "data" : {
        "id" : "659",
        "source" : "658",
        "target" : "578",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YGR085C (pp) YLR075W",
        "SUID" : 659,
        "name" : "YGR085C (pp) YLR075W"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "661",
        "source" : "658",
        "target" : "660",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YGR085C (pp) YDR395W",
        "SUID" : 661,
        "name" : "YGR085C (pp) YDR395W"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "724",
        "source" : "660",
        "target" : "723",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YDR395W (pp) YDL075W",
        "SUID" : 724,
        "name" : "YDR395W (pp) YDL075W"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "733",
        "source" : "660",
        "target" : "579",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YDR395W (pp) YPR102C",
        "SUID" : 733,
        "name" : "YDR395W (pp) YPR102C"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "727",
        "source" : "660",
        "target" : "726",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YDR395W (pp) YNL069C",
        "SUID" : 727,
        "name" : "YDR395W (pp) YNL069C"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "580",
        "source" : "578",
        "target" : "579",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YLR075W (pp) YPR102C",
        "SUID" : 580,
        "name" : "YLR075W (pp) YPR102C"
      },
      "selected" : false
    } ]
  }
}





And this is a sample visualization in Cytoscape.js:

[image: _images/JSON2.png]

 


Important Note

Export network and table to Cytoscape.js feature in Cytoscape creates a
JSON file WITHOUT style. This means that you need to export the
style in a separate JSON file if you apply style to your network. Please
read the Style section for more details.

 






7.10. Cytoscape CX

CX is a JSON-based transfer format that enables diverse Cytoscape Cyberinfrastructure (CI) services to exchange networks while preserving all network-related information.
It is designed for flexibility, modularity, and extensibility, and as a message payload in common CI REST protocols. It enables applications to standardize on core aspects of networks, coordinate on more specific or unique standards, and to ignore or omit irrelevant aspects. It is not intended as an optimized format for storage or for specific functionality in applications.

CX is an Aspect-Oriented Network Interchange Format, where the base information is a list of nodes. Independent data structures (called aspects) organize and elaborate on nodes and each other. The core of CX defines five aspects, though a more comprehensive CX document [https://github.com/CyComponent/CyWiki] describes many more aspects.
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8. Node and Edge Column Data

Interaction networks are useful as stand-alone models. However, they are
most powerful for answering scientific questions when integrated with
additional information. Cytoscape allows the user to add arbitrary node,
edge and network information to Cytoscape as node/edge/network data
columns. This could include, for example, annotation data on a gene or
confidence values in a protein-protein interaction. These column data
can then be visualized in a user-defined way by setting up a mapping
from columns to network properties (colors, shapes, and so on). The
section on
Styles
discusses this in greater detail.

 


8.1. Import Data Table Files

Cytoscape offers support for importing data from delimited text and MS
Excel data tables.

Sample Data Table 1


Sample Data
 	Object Key  	Alias        	SGD ID  

 	AAC3    	YBR085W|ANC3       	S000000289    
 
 	AAT2 	YLR027C|ASP5    	S000004017 

 	BIK1    	YCL029C|ARM5|PAC14 	S000000534    



The data table file should contain a primary key column and at least one
data column. The maximum number of data columns is unlimited. The
Alias column is an optional feature, as is using the first row of
data as column names. Alternatively, you can specify each column name
from the File → Import → Table from File… user interface.

 


Basic Operation

[image: _images/ImportColumnsFromTable.png]


	Select File → Import → Table from File….


	Select a data file. The file can be either a text or
Excel (.xls/.xlsx) file.
Alternatively, you can simply drag and drop the file from the desktop into the Table Panel.


	In the Target Table Data section, choose where to import the
data to. You can choose an existing network collection, a specific
network only, or you can choose to import the data to an
Unassigned Table (described below).


	Depending on what you choose in the Where to import Table Data
drop-down, you will need to select a network collection or
specific network. You will also need to select Importing Type,
that is whether the data is node, edge or network table columns.


	If the table is not properly delimited in the preview panel, change
the delimiter in the Advanced Options panel. The default
delimiter is tab. This step is not necessary for Excel Workbooks.


	By default, the first column is designated as the primary key, as
designated by the key [image: _images/Key.png]Key.png
icon. To set another column as the key instead, click the arrow at
next to the column title and select the key symbol. Make sure the
column designated as key matches the key in the network.


	Similarly, to change the data type of a column, for example from
integer to string, click the arrow next to the column title, and
select the correct data type.




[image: _images/ChangeDataType.png]


	Click OK to import.





Unassigned Table

As of Cytoscape 3.1. it is possible to import data tables without
assigning them to existing networks, meaning the data doesn’t have to
correspond to any nodes/edges currently loaded. If a data table is
imported as unassigned and a network is later imported that maps to the
data in terms of nodes or edges, the data will link automatically. This
is useful when loading a large dataset (for example expression data),
defining a Style for visualizing the data on networks and later
loading individual networks to view the data, for example from an online
database. This feature allows the data to be automatically linked to any
network that is applicable, without having to load the data for each
network.
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9. Column Data Functions and Equations

 


9.1. Column Formulas

 


Introduction

Column data values may be formulas. A typical example is
=ABS($otherColumn + LOG(10.2)). Formulas are modeled after
Excel(tm) but only support references to other columns at the same node,
edge or network. Since Cytoscape column names may contain embedded
spaces, optional braces around the column name (required if the name is
not simply a letter followed by one or more letters or digits) is
allowed e.g. ${a name with spaces}. Backslashes, opening braces and
dollar signs in column names have to be escaped with a leading
backslash. For example the column name ex$am{p\le would have to be
written as ${ex\$am\{p\\le}. Finally, column names are case
sensitive.

String constants are written with double-quotes “. In order to embed
a double-quote or a backslash in a string they have to be escaped with a
leading backslash, therefore the string “\ must be written as
“\”\\”. Formula results must be compatible with the type of the
column that they have been assigned to. The rules are rather lax though,
for example anything can be interpreted as a string and all numeric
values will be accepted for a boolean (or logical) column data where
non-zero will be interpreted as true and zero as false. For
integer columns, floating point values will be converted using the rules
of the Excel(tm) INT function. Parentheses can be used for grouping
and to change evaluation order. The operator precedence rules follow
those of standard arithmetic.

 




Operators

Currently supported operators are the four basic arithmetic operators
and the ^ exponentiation operator. +, -, *, and
\ are left-associative and ^ is right-associative. The string
concatenation operator is &. Supported boolean or logical operators
are the comparison operators <, >, <=, >=,
=, and <> (not equal).

 




Supported Functions

Currently we support the following functions:


Cytoscape-specific functions


	Degree – the degree of a node, meaning how many edges connect to it.


	InDegree – the indegree of a node.


	OutDegree – the outdegree of a node.


	SourceID – the ID of the source node of an edge.


	TargetID – the ID of the target of an edge.







Numeric Functions


	Abs – Returns the absolute value of a number.


	ACos – Returns the arccosine of a number.


	ASin – Returns the arcsine of a number.


	ATan2 – Returns the arctangent of two numbers x and y.


	Average – Returns the average of a group of numbers.


	Cos – Returns the cosine of an angle given in radians.


	Cosh – Returns the hyperbolic sine of its argument.


	Count – Returns the number of numeric values in a list.


	Degrees – Returns its argument converted from radians to degrees.


	Exp – Returns e raised to a specified number.


	Ln – Returns the natural logarithm of a number.


	Log – Returns the logarithm of a number to a specified base.


	Max – Returns the maximum of a group of numbers.


	Median – Returns the median of a list of numbers.


	Min – Returns the minimum of a group of numbers.


	Mod – Calculates the modulus of a number.


	Pi – Returns an approximation of the value of p.


	Radians – Returns its argument converted from degrees to radians.


	Round – Rounds a number to a specified number of decimal places.


	Sin – Returns the sine of an angle given in radians.


	Sinh – Returns the hyperbolic sine of its argument.


	Sqrt – Calculates the square root of a number.


	Tan – returns the tangent of its argument in radians.


	Tanh – returns the hyperbolic tangent of its argument in radians.


	Trunc – Truncates a number.







String Functions


	Concatenate – Concatenates two or more pieces of text.


	Left – Returns a prefix of s string.


	Len – Returns the length of a string.


	Lower – Converts a string to lowercase.


	Mid – Selects a substring of some text.


	Right – Returns a suffix of a string.


	Substitute – Replaces some text with other text.


	Text – Format a number using the Java DecimalFormat
class’ conventions.


	Upper – Converts a string to uppercase.


	Value – Converts a string to a number.







Logical/Boolean Functions


	And – Returns the logical conjunction of any number of
boolean values.


	Not – Returns the logical negation of a boolean value.


	Or – Returns the logical disjunction of any number of
boolean values.







List Functions


	First – Returns the first entry in a list.


	Last – Returns the last entry in a list.


	Nth – Returns the n-th entry in a list.







Statistical Functions


	Largest – the kth largest value in a list.


	GeoMean – the geometric mean of a set of numbers.


	HarMean – the harmonic mean of a set of numbers.


	Mode – the mode of a set of numbers.


	NormDist – Returns the pdf or CDF of the normal distribution.


	Permut – Returns the number of permutations for a given number
of objects.


	StDev - sample standard deviation.


	Var – sample variance.







Miscellaneous Functions


	Combin - Returns the number of combinations for a given number
of objects.


	If – Returns one of two alternatives based on a boolean value.


	ListToString – Returns a string representation of a list.


	Now – Returns a string representation of the current date and time.


	Today – returns a string representation of the current date.




 






Pitfalls

The possibly biggest problem is the referencing of other columns that
have null values. This is not allowed and leads to errors. In order to
mitigate this problem we support the following optional syntax for
column references: ${columnName:defaultValue}. The interpretation
is that if columnName is null, then the default value will be used,
otherwise the value of the referenced value will be used instead. The
referenced column must still be a defined column and not an arbitrary
name! The other potential problem is when there are circular column
reference dependencies. Circular dependencies will be detected at
formula evaluation time and lead to a run-time error.

 




Useful Tips

When working with formulas it can be very helpful to open the
Developer’s Log Console. Formula evaluation errors will be logged there.

 






9.2. The Formula Builder

In order to ease the creation of formulas as well as to facilitate
discovery of built-in functions we provide a Function Builder in the
Table Panel. After selecting a non-list column cell, you can invoke it
by clicking on
[image: _images/fx-button.png].
This should bring up the Function Builder which looks like this:

[image: _images/FunctionBuilder2.png]

Select a function on the left hand side of the dialog - here, we’ve
selected the ABS function. Next to the list of functions, you can
specify one or more arguments. This can either be a column (selected
from the drop-down list) or a constant specified in the box below. If
you select a column, the value of that column (in the row containing the
formula) will be used, and the function result will be updated
dynamically when that value changes. Click Add to add an argument -
you can add one or more depending on how many arguments the function
accepts. At the bottom of the dialog is a preview of the current
formula. Under Apply to, you can select whether the formula will
apply to the current cell only, the cell selection, or the entire
column. Click OK when you are satisfied with the result, or Cancel to
discard any changes.

The Function Builder is a useful tool for discovery of the list of
built-in functions, which has the return type matching the data type of
the column. Arguments can either be selected from a list of named
columns, or constant values can be entered in a text entry field. A
major shortcoming at this time is that the Formula Builder won’t let you
compose functions with function calls as arguments. If you need the most
general functionality, please type the expression directly into a cell.

 




9.3. A Note for App Writers

It is relatively easy to add your own built-in formula functions. A
simple function can probably be implemented in 15 to 20 minutes. It can
then be registered via the parser and becomes immediately available to
the user. It will of course also show up in the drop-down list in the
Function Builder.
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10. Finding and Filtering Nodes and Edges

 


10.1. Search Bar

You can search for nodes and edges by column value directly through
Cytoscape’s tool bar. For example, to select nodes or edges with a
column value that starts with “STE”, type ste* in the search bar. The
search is case-insensitive. The * is a wildcard character that matches
zero or more characters, while ? matches exactly one character. So
ste? would match “STE2” but would not match “STE12”. Searching for
ste* would match both.

[image: _images/searchbar3.png]

To search a specific column, you can prefix your search term with the
column name followed by a :. For example, to select nodes and edges
that have a “COMMON” column value that starts with “STE”, use
common:ste*. If you don’t specify a particular column, all columns
will be searched.

Columns with names that contain spaces, quotes, or characters other than
letters and numbers currently do not work when searching a specific
column. This will be fixed in a future release.

To search for column values that contain special characters you need to
escape those characters using a “\”. For example, to search for
“GO:1232”, use the query GO\:1232. The complete list of special
characters is:

+ - & | ! ( ) { } [ ] ^ " ~ * ? : \





Note: Escaping characters only works when searching all columns. It
currently does not work for column-specific searching. This will be
fixed in a future release.

 




10.2. CyCharts

CyChart is a charting package available as a core app in Cytoscape. CyCharts provides simple 1D and 2D plots of numerical values from node or edge tables. Selection in the chart will reciprocally select nodes or edges in the network.  This provides another way to visualize and interact with your data in Cytoscape.


Histograms

A histogram shows the distribution of a variable in bins over a range.   It shows the user where the most common values are and whether the values are distributed uniformly (flat line), normally (the bell curve) or have strong modes (hills and valleys).  This can be particularly useful for finding pockets of the data that express similar ranges, such as positively and negatively expressed genes.

To create a histogram using CyCharts, open the right-click on the header of a numeric column in the Node or Edge Table, and select the command Plot Histogram…

[image: _images/plotHistogram.png]

The structure of the CyChart window has a header with common functions and settings, the content of the chart, and a footer with the selections status and the controls to set the axes.

[image: _images/histogram1.png]

To select a range within a histogram, click and drag left or right.  You should see a color change in the background of the data.   To edit an existing selection, drag in the middle of the selection to move the entire selection, or on either edge of the selection to edit just the start or end of the range.  To clear the selection, click outside of the range.

If the chart is in its interactive mode, you can see the main graph view changing its selection as the chart changes.  However, in large networks this will over-stress the computer and become sluggish in the interface.  Therefore, there is a check box in the header of CyChart to control whether selection is recomputed whenever the mouse moves, or occurs only at the end of your drag.

The footer is used to set the axes of the chart, and to show the status of the selection.  Click on the popup choice box to see the list of available dimensions.  The chart will be regenerated whenever you change either dimension.  The current selection is lost when either axis changes.

[image: _images/histogramFooter.png]

[Note:  the first invocation of the axis popups may take several seconds to respond.  Subsequent clicks will be more responsive.]

[Note: Logarithmic axes will be enabled in a future release.]

Regardless of the experiment size, the histogram is divided into 100 bins, smoothed, and plotted such that the Y value on the line is the number of nodes (edges) within that range.   The bins have equal width (as opposed to equal area).    This is a simplification of statistical rules to determine the number of bins in the sampling of the data, but is not unreasonable in the context where you are setting the ranges manually.




Scatter Charts

A scatter chart is a two dimensional plot with a dot drawn for each row in the table.  Per standard, the domain is the horizontal (X) axis and the range is the vertical (Y) axis.  Similar to the histograms, clicking and dragging within the chart will select a rectangle of dots, and change the current selection in your graph.  You can edit the size of the selection by dragging any of the corners, or edit the position by clicking inside the rectangle.

Create the scatter chart by right-clicking on the header of the column you want as your X axis and select the command Plot Scatter…

[image: _images/plotScatter.png]

There is a Regression check box, which will add a regression line through the data.  The regression is calculated with the linear least squares method.  The slope, intercept and measure of the fit are shown with the line.

As with Histograms, the Scatter Chart has a check box to set whether the selection of nodes in your graph will update whenever the mouse moves, or only upon release.  If there is annoying flicker when dragging your selection, your should turn off the Interactive mode.

[image: _images/scatter1.png]




Volcano Plots

Volcano plots are a domain-specific type of scatter chart, where the X axis is an expression level, and the range is the significance of the measurement.  These plots have the interesting characteristic that you are often interested in both positive and negative values, with a high value for the significance.  In this case,  it is useful to be able to select areas of a scatter chart symmetrically around the axis.    This is done by holding the option key, as you drag.  (This feature is only enabled when the X axis spans across 0, so if you don’t see it appear, confirm that your table column has negative and positive values.)

[image: _images/volcanoPlot.png]

 






10.3. Filters

The Filter tab in the Control Panel can be used to create selection
expressions for selecting nodes and edges.

[image: _images/select-panel2.png]

There are two tabs:


	On the Filter tab are narrowing filters, which can be combined into a tree.


	On the Chain tab are chainable transformers, which can be combined in a linear chain.




 


Narrowing Filters

Narrowing filters are applied to all the nodes and edges in the network, and are used to
select a subset of the nodes and edges based on user-specified
constraints. For example, you can find edges with a weight between 0 and
5.5, or nodes with degree less than 3 (connecting to 3 or less edges). A filter can contain an arbitrary
number of sub-filters.

To add a filter click on the “+” button. To delete a filter (and all its
sub-filters) click the “x” button. To move a filter grab the handle
[image: _images/filterhandle.png]
with the mouse and drag and drop the filter on its intended destination.
Dropping a filter on top of another filter will group the filters into a
composite filter.

 


Interactive Filter Application Mode

Due to the nature of narrowing filters, Cytoscape can apply them to a
network efficiently and interactively. Some filters even provide slider
controls to quickly explore different thresholds. This is the default
behavior on smaller networks. For larger networks, Cytoscape
automatically disables this interactivity. You can override this by
manually checking the Apply when filter changes box above the Apply
button:

[image: _images/apply-automatically2.png]

The Apply button will re-apply the active filter. On the opposite side of the progress
bar is the cancel button, which will let you interrupt a long-running filter.

You also have the option to use the filter to show only the selected nodes by checking
the show button. The select button is checked by default and simply selects nodes
that pass the filter.

Cytoscape comes packaged with the following narrowing filters:

 




Column Filter

Column filters will match nodes or edges that have particular column
values. Depending on the column data type a variety of matching options are provided:


	Numeric Columns


	A slider is shown that represents the minimum and maximum values in the column.
Drag the two handles to select a range of values.


	The range values may also be entered manually.


	Options:


	is: Selects values that are inside the range.


	is not: Selects values that are outside the range.




[image: _images/column-numeric.png]







	String Columns


	The text entered in the text box will be matched against the column values
depending on the following options.


	Options:


	contains: Selects values that contain the text.


	doesn’t contain: Selects values that do not contain the text.


	is: Selects values that match the text exactly (case-insensitive).


	is not: Selects values that do not match the text exactly (case-insensitive).


	regex: Selects values that match a regular expression using Java regular expression
syntax [https://docs.oracle.com/javase/8/docs/api/java/util/regex/Pattern.html]. This allows for much more
sophisticated matching than is provided by the above options.






	By default string matching is case insensitive. Case sensitive matching
requires the use of a regular expression that starts with “(?-i)”. For
example to match the text “ABC” in a case sensitive way use the
following regular expression: “(?-i)ABC”.

[image: _images/column-string.png]







	Boolean Columns


	Boolean colums can only contain three values: true, false or blank.


	Options:


	true: Selects values that are true.


	false: Selects values that are false.




[image: _images/column-boolean.png]







	List Columns


	Column filters for list columns are similar to their non-list counterparts, however
there is one additional option…


	any element: Matches if any value in the list matches the filter.


	each element: Matches only if all of the values in the list match the filter.




[image: _images/column-list.png]









 




Degree Filter

The degree filter matches nodes with a degree that falls within the
given minimum and maximum values, inclusive. You can choose whether the
filter operates on the in-degree, out-degree or overall (in + out)
degree.

 




Topology Filter

The topology filter matches nodes having a certain number of neighbors
which are within a fixed distance away, and which match a sub-filter.
The thresholds for the neighborhood size and distance can be set
independently, and the sub-filter is applied to each such neighbor node.

The topology filter will successfully match a node if the sub-filter
matches against the required number of neighbor nodes.

 




Grouping and Organizing Filters

By default, nodes and edges need to satisfy the constraints of all your
filters. You can change this so that instead, only the constraints of at
least one filter needs to be met in order to match a node or edge. This
behavior is controlled by the Match all/any drop-down box. This
appears once your filter has more than one sub-filter. For example,
suppose you wanted to match nodes with column COMMON containing ste
or cdc, but you only want nodes with degree 5 or more, you’d first
construct a filter that looks like this:

[image: _images/group1.png]

This filter will match nodes where COMMON contains ste and
cdc. To change this to a logical or operation, drag either of the
column filters by its handle
[image: _images/filterhandle.png]
onto the other column filter to create a new group. Now change the
group’s matching behavior to Match any:

[image: _images/group2.png]

You can also reorder filters by dropping them in-between existing
filters.

 






Chainable Transformers

The input to a chainable transformer is a set of nodes and edges, either the nodes and edges
that are currently selected in the network, or the output of a narrowing filter. Chainable
transformers can filter out nodes/edges, or include more nodes/edges. For example a chainable
transformer can add nodes that are neighbours of the nodes in the input.

Chainable filters are combined in an ordered list. The nodes and edges
in the output of a transformer become the input of the next transformer in the
chain. The first transformer in the chain gets its input from the current
selection or from a filter on the Filter tab. The output of the last
transformer becomes the new selection.

You can specify the input to the first transformer in the chain by selecting
a Start with, where Current selection refers to the nodes and
edges currently selected. You can also choose a narrowing filter, which
produces a different set of selected nodes and edges.

[image: _images/chain-filter1.png]

Chainable transformer can be reordered by dragging one by the handle and
dropping it between existing transformer.

Cytoscape currently bundles the following chainable transformers:

 


Edge Interaction Transformer

This transformer will go through all the input edges and selectively add
their source nodes, target nodes, or both, to the output. This is useful
for adding nodes that are connected to edges that match a particular
filter.

Output options:


	Add (default): Automatically includes all input nodes and edges in
the output, and adds source or target nodes from input edges to
the output.


	Replace with: Does not automatically include input nodes and edges
in the output. Only outputs nodes that match the filter.




A sub-filter may be added as well. When a sub-filter is present the
source/target nodes must match the filter to be included in the output.

 




Node Adjacency Transformer

This transformer is used to add nodes and edges that are adjacent to the
input nodes. A sub-filter may be specified as well.

Note that pressing the Apply button repeatedly may cause the
selection to continuously expand. This allows adjacent nodes that are at
greater distances to be added.

Output options:


	Add (default): Automatically includes all input nodes and edges in
the output, and adds selected adjacent nodes and edges.


	Replace with: Only outputs the adjacent nodes/edges.




Select options:


	Adjacent nodes: Output nodes that are adjacent to the input nodes.


	Adjacent edges: Output edges that are adjacent (incident) to the
input nodes.


	Adjacent nodes and edges (default): Output both nodes and edges that
are adjacent to the input nodes.




Edge direction options. (Hidden by default, click the small arrow icon
to reveal.):


	Incoming: Only include adjacent nodes/edges when the adjacent edge
is incoming.


	Outgoing: Only include adjacent nodes/edges when the adjacent edge
is outgoing.


	Incoming and Outgoing (default): Ignore the directionality of
adjacent edges.




Sub-filter options. (Available when a sub-filter has been added.):


	Adjacent nodes (default): The sub-filter is only applied to
adjacent nodes. (Edges to the adjacent nodes are still included in
the output.)


	Adjacent edges: The sub-filter is only applied to adjacent edges.
(Nodes connected to the adjacent edges are still included in
the output.)


	Adjacent nodes and edges: Both the adjacent edge and its connected
node must match the filter. Note that for a filter to match an edge
and a node at the same time it should be a compound filter that is
set to “Match any (OR)”.




 






Working with Narrowing and Chainable Filters

The name of active filter appears in the drop-down box at the top of
Select panel. Beside this is the options button which will allow you
to rename, remove or export the active filter. It also lets you create a
new filter, or import filters.

[image: _images/select-panel-options2.png]

 






10.4. Diffusion

Cytoscape’s Diffusion algorithm attempts to use a set of nodes and an entire interaction network to find the nodes most relevant to the original set.
Conceptually, Diffusion applies heat to each node in the set, and lets the heat flow through connecting edges to adjacent nodes.
It then produces a list of nodes ranked by the heat they accumulated. A node with many connections will tend to have a higher
ranking, and an isolated node will tend to have low rank (and thus be excluded from the resulting node set).

By default, Diffusion uses the set of selected nodes as the heat sources, with each node having the same initial heat. At the end of a Diffusion, Cytoscape leaves the top 90th percentile of hot nodes selected. It allows you to use the Results panel to select a higher or
lower percentile dynamically. It also stores the node’s initial heat as a node attribute in the “diffusion_input” column, and returns the heat and ranking values in the “diffusion_output_heat” and “diffusion_output_rank” columns.

An advanced Diffusion option allows you to specify initial heat values for each node via its “diffusion_input” attribute.

This figure shows the result of selecting the PHO4, GCR1 and ICL1 genes (via the search bar) and performing a Diffusion by either selecting Tools → Diffuse → Selected Nodes or right-clicking to Diffuse → Selected Nodes. Diffusion calculated the heat ranking of all 331 nodes in the network, and then selected the top 33.

[image: _images/after_diffusion.png]

To select more than 33 nodes, move the Node Rank slider in the Diffusion Output Results Panel to the right or enter a number greater than 33 in the Current Rank field. You can also select nodes using a heat value cutoff by using the Range Column to select a column containing heat values. Finally, you can use the Visual Style chooser and Create button to extract the selected nodes into a new network.

You can execute Diffusion multiple times on a network, thereby creating multiple heat, output_heat and output_rank columns.

 




10.5. The Select Menu

The Select → Nodes and Select → Edges menus provide several
mechanisms for selecting nodes and edges. Most options are fairly
straightforward; however, some need extra explanation.

Select → Nodes → From ID List File… selects nodes based on node
identifiers found in a specified file. The file format is simply one
node id per line:

Node1
Node2
Node3
...
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11. Navigation and Layout

 


11.1. Basic Network Navigation

Cytoscape uses a Zoomable User
Interface [http://en.wikipedia.org/wiki/Zooming_User_Interface] for
navigating and viewing networks. ZUIs use two mechanisms for navigation:
zooming and panning. Zooming increases or decreases the magnification of
a view based on how much or how little a user wants to see. Panning
allows users to move the focus of a screen to different parts of a view.

 


Zoom

Cytoscape provides four mechanisms for zooming: toolbar buttons, menu options, keyboard shortcuts and the scroll wheel.

Use the zooming buttons located on the toolbar to zoom in
and out of the interaction network shown in the current network display.
Zoom icons are detailed below:

[image: _images/zoomicons.png]

From Left to Right:


	Zoom In


	Menu option: View → Zoom In


	Keyboard shortcut: Ctrl-Plus (Command-Plus on Mac OS X)


	Zoom Out


	Menu option: View → Zoom Out


	Keyboard shortcut: Ctrl-Minus (Command-Minus on Mac OS X)


	Zoom Out to Display all of Current Network


	Menu option: View → Fit Content


	Keyboard shortcut: Ctrl-0 (Command-0 on Mac OS X)


	Zoom Selected Region


	Menu option: View → Fit Selected


	Keyboard shortcut: Ctrl-9 (Command-9 on Mac OS X)




Using the scroll wheel, you can zoom in by scrolling up and zoom out by
scrolling downwards. These directions are reversed on Macs with natural
scrolling enabled (the default for Mac OS X Lion and newer versions).

 




Pan

There are two ways to pan the network:


	Left-Click and Drag - You can pan the network view by holding down the left mouse button and moving the mouse.


	Dragging Box on Network
Overview -
You can also pan the view by left-clicking and dragging the blue box in the overview panel in the lower part of the view.




 






11.2. Other Mouse Behaviors

 


Select


	Click the left mouse button on a node, edge or annotation to select that element.


	Hold down the Shift or Ctrl key (Command on Macs) and left-click a node, edge or annotation to add it to the selection. Doing the same on a selected element unselects it.


	Hold down the left mouse button on the canvas background and drag the mouse while holding down the Shift or Ctrl key (Command on Macs) to select groups of nodes/edges/annotations.


	Remember that the selection action (mouse click or drag-selection) only works if the Selection Mode for that element type (i.e. nodes, edges, annotations) is enabled. In order to enable or disable the selection of an element type, just toggle its corresponding button at the bottom of the network view (see image below) or use the options under the menu Select → Mouse Drag Selects.




[image: _images/SelectionModeButtons.png]


	So if you don’t want any nodes to be selected, toggle the button [image: _images/selection-mode-nodes.png] off.


	And if you don’t want any edges to be selected, toggle the button [image: _images/selection-mode-edges.png] off.


	Likewise, if you don’t want any annotations to be selected, toggle the button [image: _images/selection-mode-annotations.png] off.




 




Context

Click the right mouse button (or Ctrl+left mouse button on Macs) on a
node/edge to launch a context-sensitive menu with additional information
about the node/edge.

 




Node Context Menu

This menu can change based on the current context. For nodes, it
typically shows:


	Add


	Diffuse


	Edit


	Select


	Group


	Nested Networks


	Apps


	External Links


	Preferences




Edges usually have the following menu:


	Diffuse


	Edit


	Select


	Apps


	External Links


	Preferences




Apps can contribute their own items into node and edge context menus.
These additions usually appear in the Apps section of the context
menu.

 


Nested Network Node Context Menu


	Add Nested Network: Lets the user select any network in
Cytoscape as the current node’s nested network. If the current node
already has a nested network it will be replaced.


	Remove Nested Network: Removes the currently associated nested
network from a node. The associated network is not deleted. Only the
association between the node and the network is removed.


	Go to Nested Network: The current node’s nested network will be
the current network view and have the focus. Should a network view
for the nested network not exist, it will be created.




More information about nested networks can be found in the Nested
Networks
section.

 








11.3. Manual Layout

The simplest method to manually organize a network is to click on a node
and drag it. All of the selected nodes are moved together.

In addition to the ability to click on a node and drag it to a new
position, Cytoscape now has the ability to move nodes using the arrow
keys on the keyboard. By selecting one or more nodes using the mouse and
clicking one of the arrow keys (←, ↑, →, ↓) the selected nodes will move
one pixel in the chosen direction. If an arrow key is pressed while
holding the Shift key down, the selected nodes will move 15 pixels in the
chosen direction.

 




11.4. Node Layout Tools

The Tool Panel is available via the menu command View → Show Tool Panel, or via Layout → Node Layout Tools.

It contains several Node Layout Tools that can help to automate or fine tune a layout.

 


Scale

Adjust the Scale slider to change the length of edges.  The position of the nodes will be scaled, not the node sizes.
Node size can be adjusted using
Styles.
The images below show selected (yellow) nodes scaled to 50% of the default value.

Before

[image: _images/NodeTools1.png]

After

[image: _images/NodeToolsScaled.png]
 




Rotate

The Rotate function will change the orientation of the entire
network or a selected portion of the network. The images below show a
network with selected nodes rotated 90 degrees.

Before

[image: _images/NodeTools1.png]

After

[image: _images/NodeToolsRotated.png]

 




Align, Distribute and Stack

The Tool Panel contains buttons to set relative postions of nodes.

Align provides
different options for either vertically or horizontally aligning
selected nodes against a line. The differences are in what part of the
node gets aligned, e.g. the center of the node, the top of the node, the
left side of the node. Distribute evenly distributes selected nodes
between the two most distant nodes along either the vertical or
horizontal axis. The differences are again a function what part of the
node is used as a reference point for the distribution. Stack
vertically or horizontally stacks selected nodes with the full
complement of alignment options. The table below provides a description
of what each button does.


Align Options
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12. Styles

 


12.1. What are Styles?

One of Cytoscape’s strengths in network visualization is the ability to
allow users to encode any table data (name, type, degree, weight,
expression data, etc.) as a property (such as color, size of node,
transparency, or font type) of the network. A set of these encoded or
mapped table data sets is called a Style and can be created or
edited in the Style panel of the Control Panel. In this
interface, the appearance of your network is easily customized. For
example, you can:

Specify a default color and shape for all nodes.

[image: _images/NodeShape.png]

Set node sizes based on the degree of connectivity of the nodes. You
can visually see the hub of a network…

[image: _images/DegreeSize.png]

…or, set the font size of the node labels instead.

[image: _images/DegreeLabelSize.png]

Visualize gene expression data along a color gradient.

[image: _images/ColorGradient.png]

Encode specific physical entities as different node shapes.

[image: _images/NodeShapeMapping.png]

Use specific line types to indicate different types of interactions.

[image: _images/edge_types.png]

Control edge transparency (opacity) using edge weights.

[image: _images/OpacityForEdges.png]

Control multiple edge properties using edge score.

[image: _images/MultipleEdgeMapping.png]

Browse extremely-dense networks by controlling the opacity of nodes.

[image: _images/OpacityForNodesAndEdges.png]

Show highly-connected region by edge bundling and opacity.

[image: _images/Bundling.png]

Add photo/image/graphics on top of nodes.

[image: _images/CustomGraphics1.png]
[image: _images/CustomGraphics4.png]
[image: _images/CustomGraphics5.png]

Cytoscape 3 has several sample styles. Below are a few examples of these
applied to the galFiltered.sif network :

[image: _images/default_style.png]
[image: _images/solid_style.png]
[image: _images/ripple_style.png]
[image: _images/universe_style.png]

 




12.2. Introduction to the Style Interface

The Style interface is located under the Style panel of the
Control Panel.

[image: _images/StylesInterface.png]

This interface allows you to create/delete/view/switch between different
styles using the Current Style options. The panel displays the mapping
details for a given style and is used to edit these details as well.


	At the top of the interface, there is a drop-down list (Current Style) for selecting
a pre-defined style. There is also an Options drop-down with
options to rename, remove, create and copy a Style, and an option to
create a legend for the selected Style.


	The main area of the interface is composed of three tabs, for Node,
Edge and Network properties.


	Each tab contains a list of properties relevant to the
current style. At the top of the list a Properties drop-down
allows you to add additional properties to the list.


	Each property entry in the list has 3 columns:


	The Default Value shows just that, the default value for
the property. Clicking on the Default Value column for any
property allows you to change the default value.


	Mapping displays the type of mapping currently in use for
the property. Clicking on the Mapping column for any
property expands the property entry to show the interface for
editing the mapping. Details on the mapping types provided
here.


	Bypass displays any style bypass for a selected node
or edge. Note that a node/edge or subset of nodes/edges must be
selected to activate the Bypass column. Clicking on the
Bypass column for selected node(s)/edge(s) allows you to
enter a bypass for that property for selected node(s)/edge(s).








The Default Value is used when no mapping is defined for a property,
or for nodes/edges not covered by a mapping for a particular property.
If a Mapping is defined for a property, this defines the style for
all or a subset of nodes/edges, depending on how the mapping is defined.
A Bypass on a specific set of nodes/edges will bypass and override
both the default value and defined mapping.

 




12.3. Introduction to Style

The Cytoscape distribution includes several predefined styles to get you
started. To examine a few styles, try out the following example:

Step 1. Load some sample data


	Load a sample session file: From the main menu, select File
→ Open…, and select the file sampleData/galFiltered.cys.


	The session file includes a network, some annotations, and
sample styles. By default, the style galFiltered Style
is selected. Gene expression values for each node are colored along
a color gradient between blue and yellow (where blue represents a
low expression ratio and yellow represents a high expression ratio,
using thresholds set for the gal1RGexp experiment bundled with
Cytoscape in the sampleData/galExpData.csv file). Also, node size
is mapped to the degree of the node (number of edges connected to
the node) and you can see the hubs of the network as larger nodes.
See the sample screenshot below:




[image: _images/galFilteredSessionDefault.png]

Step 2. Switch between different styles

You can change the style by making a selection from the Current
Style drop-down list, found at the top of the Style panel.

For example, if you select Sample1, a new style will be applied to
your network, and you will see a white background and round blue nodes.
If you zoom in closer, you can see that protein-DNA interactions
(specified with the label “pd”) are drawn with dashed edges, whereas
protein-protein interactions (specified with the label “pp”) are drawn
with solid edges (see sample screenshot below).

[image: _images/VizMapperSample1Style26.png]

Finally, if you select Solid, you can see the graphics below:

[image: _images/VizMapperSolidStyle.png]

This style does not have mappings except node/edge labels, but you can
modify the network graphics by editing the Default Value for any
property.

Additional sample styles are available in the sampleStyles.xml file in
the sampleData directory. You can import the sample file from File →
Import → Styles from File….

 


List of Node, Edge and Network Properties

Cytoscape allows a wide variety of properties to be controlled. These
are summarized in the tables below.


Node Properties
                                
  
    
    13. Network Annotations
    

    

    

    
 
  

    
      
          
            
   


13. Network Annotations

Annotations in the form of shapes, images or text can be added to the network canvas.

The network canvas is made up of three transparent layers:


	Foreground layer


	Network layer


	Background layer




The middle Network layer contains nodes, edges and charts. The Foreground and Background
layers contain Annotations.

[image: _images/layers.png]


13.1. Types of Annotations

There are five types of annotations available:


	Images (loaded from image files)


	Shapes (rectangles, triangles, etc…)

[image: _images/type_shape.png]



	Text

[image: _images/type_text.png]



	Bounded Text (combines text with a surrounding shape)

[image: _images/type_bounded_text.png]



	Arrows (connects other annotations or nodes)

[image: _images/type_arrow.png]








13.2. The Annotation Panel

The Annotation panel shows the annotations that are currently present on the foreground and
background layers. The panel allows you to create and delete annotations, select annotations,
move annotations up and down, move annotations between layers, and group annotations.

[image: _images/annotations_panel.png]




13.3. Creating Annotations

At the top of the a Annotation Panel there are five buttons for creating each type of annotation.
Start by clicking the button for the type of annotation you would like to add.

[image: _images/annotations_panel_buttons.png]

Alternatively, right click on the network canvas and select the annotation type under the Add menu.

[image: _images/add_menu.png]


Shape, Bounded Text, Image


	Click the button for shape, bounded text or image annotation.


	Click the general location on the network canvas where the annotation should be placed.


	A dialog will appear that allows editing of the annotation properties. These properties can be edited
again after the annotation is created.


	Click the Ok button in the dialog.


	The annotation will appear on the canvas.


	The mouse cursor is automatically moved to the canvas and the annotation is in resize mode.


	Move the mouse cursor to resize the annotation. The annotation can be resized again later.


	Click the mouse again to stop resizing.







Text


	Click the button for text annotation.


	Click the general location on the network canvas where the annotation should be placed.


	A dialog will appear that allows editing of the text.


	Click the Ok button in the dialog.


	The annotation will appear on the canvas.







Arrow


	Creating an arrow annotation requires there to be at least one other annotation on the network canvas.


	Click the button for arrow annotation.


	Click on an annotation on the canvas, this will be the source annotation.


	Click on another annotation on the canvas or a node, this will be the destination.


	An arrow annotation appears connecting the source and destination.









13.4. Selecting Annotations

One or more annotations can be selected in the Annotations panel by clicking on them.

To be able to select annotations in the network canvas
Toggle Annotation Selection must be enabled. Toggle the
[image: _images/button_annotation_selection.png]button_annotation_selection.png
button at the bottom of the network view to enable/disable annotation selection mode.

[image: _images/annotation_selection_mode.png]

When an annotation is selected it is surrounded by a yellow selection rectangle and 8 resize
handles are visible. The annotation can be moved by clicking on it with the mouse and dragging.
The annotation can be resized by clicking and dragging one of the handles.

[image: _images/selected.png]

It is possible to select multiple annotations at the same time. Hold Ctrl on Windows,
or Command on Mac, while clicking on each of the annotations you would like to select.
This works both in the Annotations panel and on the network canvas. When multiple annotations
are selected they can be moved and resized at the same time.




13.5. Moving Annotations Backwards and Forwards

[image: _images/annotations_panel_selected.png]

The Annotation panel displays a list of annotations on the foreground layer and a list of
annotations on the background layer.

Annotations that are towards the top of a list are drawn above annotations lower in the list.
To move an annotation within a layer select it and click the
[image: _images/button_up.png] button to move it forward or the
[image: _images/button_down.png] button
to move it backward. To move an annotation between layers select it and click the
[image: _images/button_up_2.png]
to move it to the foreground layer or the
[image: _images/button_down_2.png]
button to move it to the background layer.




13.6. Renaming Annotations

Each annotation has a name that is displayed in the Annotation Panel. These names are primarily
for organizational purposes and do not affect how the annotation is displayed on the canvas. To
rename an annotation double-click the annotation in the Annotation Panel and enter the new name.




13.7. Editing Annotations

To modify the properties of an annotation (eg, color, text) go to the Annotation panel,
right click the annotation, and select Modify Annotation… in the context menu.

[image: _images/modify_menu.png]




13.8. Deleting Annotations

To delete annotations from the Annotation panel select one or more annotations and click the
[image: _images/button_trash.png] button.

To delete annotations from the network view right click an annotation and select Edit > Cut.




13.9. Grouping Annotations

Two or more annotations can be combined into a group. When grouped the annotations move and resize
as if they were a single annotation. Groups may be nested (a group may contain other groups).

[image: _images/legend.png]

To create a group select two or more annotations and click the
[image: _images/button_group.png] button. The group will be given a default
name that can be changed after the group is created. To un-group annotations select the group and click the
[image: _images/button_ungroup.png] button.

A group may contain annotations from the foreground and background canvases. The group will show up in
both the foreground and background layers in the annotations panel.

[image: _images/group_layers.png]

Note: Deleting a group will delete all the annotations contained within the group.
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14. App Manager

 


14.1. What are Apps?

Cytoscape’s capabilities are not fixed. They can be expanded with
apps. They can extend Cytoscape in a variety of ways. One app can
have the ability to import data from an online database. Another app
could provide a new method for analyzing networks. You can install apps
after you have installed Cytoscape. Most apps were made by Cytoscape
users like you.

If you’re familiar with Cytoscape 2.x, you probably know that Cytoscape
apps were called plugins. Starting in Cytoscape 3.0, we are calling
them apps. Cytoscape 2.x plugins cannot be used in Cytoscape 3.x.

 




14.2. Installing Apps

You can install apps through the App Store [http://apps.cytoscape.org]
or within Cytoscape. In this section, we’ll talk about installing apps
through Cytoscape. You can learn how to install apps through the App
Store here [http://apps.cytoscape.org/help/getstarted_app_install].

To install apps within Cytoscape, go to the menu bar and choose Apps →
App Manager…. At the top of the App Manager window, make sure you
have the Install Apps tab selected.

[image: _images/AppManager.png]

There are four ways you can find apps:


	If you know the name of an app you’re looking for, enter it in the
Search field. The App Manager will list the apps whose names or
descriptions match the Search field in the middle panel.


	If you’re not sure what sort of app you need and want to see everything,
click the all apps folder. In the middle pane, you will see a
list of all the apps.


	If you want to install a collection of apps for a specific use case,
click on the collections folder. This will display the available
collections in the middle pane. A collection is simply an app that
installs other apps for a specific use case.


	If you have a general idea of what sort of app you’re looking for,
double-click on the apps by tag folder, then click on one of the
tags that interests you. The apps with that tag are listed in the
middle pane.




When you click on an app (or collection) in the middle panel, the
App Manager shows its short description and icon in the right panel.
If you want more information, click the View on App Store
button on the bottom-right. If you want to go ahead and install,
click the Install button.

If you’ve downloaded an app to your computer, you can install it by
clicking the Install from File button on the bottom-left.

 




14.3. Managing your Installed Apps

You can see a list of all apps you have installed by clicking the
Currently Installed tab at the top. When you click on an app in the
list, you’ll see a description of your app at the bottom. At the bottom,
you’ll see a couple buttons where you can:


	Uninstall an app. This deletes the app from your computer. If
you want to reinstall the app, you will have to find it again in the
Install Apps tab or find it in the App Store site and
reinstall it from there.


	Disable an app. This temporarily disables the app. The app stays
on your computer, but Cytoscape does not load it. You can enable the
app by first selecting the disabled app in the list, then click
Enable.




Note that uninstalling or disabling a collection will not uninstall or disable any apps installed by the collection.
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15. Automation Panel

The Automation Panel provides a simple command-line interface to
Cytoscape using the Commands API. It allows the user to type commands into
Cytoscape and see the results in a Reply Log.

Any app that registers commands will
be available through the Automation Panel. Commands are part of the more general
Cytoscape Automation feature,
which includes multiple ways of scripting Cytoscape execution.

The Automation Panel can be opened from View → Show/Hide Automation Panel.

[image: _images/AutomationPanel.png]

The Automation Panel can also be used to read and execute script files.
Each line in the script file is a command that is sent to a app.
Script files may be entered on the Cytoscape command line using the “-S”
flag to Cytoscape, through the Tools → Run Script File… menu item,
or through Tools → Execute Command File menu item.

[image: _images/RunScriptCommands.png]

Cytoscape commands consist of three parts: a command class, or
namespace; a command within that namespace; and a series of arguments or
options provided as a series of name=value pairs. For example, to
import an XGMML format file from the Command Line Dialog or a
command script, you would use:

network import file filePath="path-to-file"





where network is the namespace, import file is the command, and
there is only one argument: filePath=”path-to-file”. If there were
more arguments they would appear on the same line separated by spaces.

The Command Tool also uses the Command API to provide help. “help” by
itself will list all of the command classes (or namespaces) and “help “
followed by a namespace will list all of the commands supported by that
namespace. Details of a specific command are available by typing “help “
followed by the namespace and command (e.g. “help layout
force-directed”). The Command Tool registers the “command” namespace and
supports a single command: run, which takes a file argument. Here is the
help for the command run command from the command namespace:

help command run
       command run file=<File> 





Similarly, the help for the “network import file” example from above is:

help network import file
 network import file arguments:
 dataTypeList=<String>: List of column data types ordered by column index 
   (e.g. "string,int,long,double,boolean,intlist" or just "s,i,l,d,b,il")
 defaultInteraction=<String>: Default interaction type
 delimiters=<ListMultipleSelection [,,;, ,\t]>: Text Delimiters
 delimitersForDataList=<ListSingleSelection (\||\|/|,)>: 
   Text Delimiters for data list type
 file=<File>: Data Table file
 firstRowAsColumnNames=true|false: First row used for column names
 indexColumnSourceInteraction=<int>: Column for source interaction
 indexColumnTargetInteraction=<int>: Column for target interaction
 indexColumnTypeInteraction=<int>: Column for interaction type
 NetworkViewRendererList=<ListSingleSelection ()>: Network View Renderer
 RootNetworkList=<ListSingleSelection (-- Create new network collection 
   --|Network)>: Network Collection
 startLoadRow=<int>: Start Load Row
 TargetColumnList=<ListSingleSelection ()>: Node Identifier Mapping Column
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16. Cytoscape Web Browser

Cytoscape includes a simple web browser that can be used for viewing
web sites from within Cytoscape.  It is also used by Cytoscape apps,
link outs, displaying the user manual, and displaying interactive
tutorials.  Typically the browser is activated automatically, but you
can bring up a browser window yourself by using
Tools → Cytoscape Web Browser, or clicking on the
[image: _images/WebIcon.png]
icon in the tool bar.

The initial CyBrowser dialog provides a field to type in a web site address
and a checkbox to indicate whether the browser window should be opened in
the Cytoscape Results Panel.

[image: _images/CyBrowserDialog.png]


16.1. CyBrowser Window

[image: _images/CyBrowser.png]

The main CyBrowser window provides a very rudimentary browsing interface, with
forward/back buttons, a text field to enter a new URL, and a Go button to
move to the new page.  In addition, there three context menus:


	Selected text
The selected text menu has just one item: Copy, which copies the selected
text.


	Link
Using the link menu, users can copy the link location, open the link in a new window,
or open the link in a new tab.  They can also use this to download the link target to
a file.




[image: _images/LinkRightClick.png]


	Other
If the cursor is not over a link, and no text is selected, the default menu is shown.
Using the default menu, users can close their browser or reload the page.




[image: _images/RightClick.png]






16.2. CyBrowser in Results Panel

[image: _images/CyBrowserResults.png]

In addition to being able to open web pages as a separate window, a web page may
also be opened in the results panel.  This provides many of the same functions as the browser
window except that the interface to go forward and backwards is gone, and you can’t open
links in different tabs.






16.3. Why CyBrowser?

CyBrowser is not a Chrome or Firefox replacement, but it provides a very quick way to view Cytoscape-specific
web pages and provides a level of integration with Cytoscape that is more difficult to provide in all of
the various browsers provided by all of the platforms Cytoscape runs on.  In particular, CyBrowser supports
special links that are actually just Cytoscape commands.  For javascript implementers, CyBrowser also provides
“hooks” to listen to node and edge selection in Cytoscape.
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17. Merge

Cytoscape allows for merging of both network and table data, through
Tools → Merge.

 


17.1. Merge Networks

The Advanced Network Merge interface is available from Tools →
Merge → Networks… and allows for merging of two or more networks.

[image: _images/AdvancedNetworkMerge.png]

 


Basic Operations


	With the buttons select either “union”, “intersection”
or “difference”.


	Networks available for merge are listed under Networks to merge.
Select a network from the list and click the right arrow to transfer
the network to Selected networks. Click Merge to continue.
The merged network will be displayed as a separate network.




 




Advanced Options

The Advanced Network Merge interface includes an expandable
Advanced Network Merge panel, where you can specify the details of
how to merge the networks. The options available here are:


	Matching columns: This specifies the network columns that should
be used for merging. Typically, the “name” column or some other
column containing identifier information is used here.


	How to merge columns?: A table lets the user specify for each of
the individual network columns, what the corresponding column in the
merged network should be named and its data type.




[image: _images/AdvancedNetworkMergeOptions.png]
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18. Analyzer

Analyzer computes a comprehensive set of topological parameters
for undirected and directed networks, including:


	Number of nodes, edges and connected components.


	Network diameter, radius and clustering coefficient, as well as the
characteristic path length.


	Charts for topological coefficients, betweenness, and closeness.


	Distributions of degrees, neighborhood connectiveness, average
clustering coefficients, shortest path lengths, number of shared
neighbors and stress centrality.




 


18.1. Network Analysis

 


Analyze Network

To run Analyzer, select Tools → Analyze Network.

[image: _images/Analyzer.png]

Analyzer will run different statistics depending on whether the network is directed or undirected.  The app will guess which type of network it is based on the definition of a target arrow style, but since this is not

When results are calculated, they will appear in the Results Panel.

[image: _images/AnalyzerResultsPanel.png]

The results have multiple tabs. Details on the network parameters can be
found
here [http://med.bioinf.mpi-inf.mpg.de/netanalyzer/help/2.7/index.html#complex].


	Simple Parameters


	Node Degree Distribution


	Avg. Clustering Coefficient Distribution


	Topological Coefficients


	Shortest Path Distribution


	Shared Neighbors Distribution


	Neighborhood Connectivity Distribution


	Betweenness Centrality


	Closeness Centrality


	Stress Centrality Distribution







Analyze Subset of Nodes

Prior versions of this tool offered the option of analyzing all nodes or only a selected subset.   This is no longer supported directly in the program.  Instead, if you want to analyze a subnetwork, you must first use the command File → New Network → From Selected Nodes, All Edges to create the desired subnetwork.
 




Plot Parameters

Once the Analyzer is run, several additional columns are added to the Node Table (and an EdgeBetweenness column is added to the Edge Table).  To plot any of these new columns, right-click on the column header and select Plot Histogram… for a single parameter distribution, or Plot Scatter… for a bivariate plot of the data.  Within either of these charts it is possible to select a section of the data, and select the nodes (edges) in the main graph window corresponding to the region selected on the chart.
 

 






18.2. NetworkAnalyzerDemo: Computation and Visualization of Topological Parameters and Centrality Measures for Biological Networks

Yassen Assenov1, Nadezhda Doncheva1, Thomas Lengauer1, and Mario Albrecht1

1 Department of Computational Biology and Applied Algorithmics, Max Planck Institute for Informatics, Campus E1.4, 66123 Saarbrücken, Germany

Comprehensive online documentation and a tutorial for NetworkAnalyzer are available at http://med.bioinf.mpi-inf.mpg.de/networkanalyzer/.
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19. Cytoscape Preferences

 


19.1. Managing Properties

The Cytoscape properties editor, accessed via Edit → Preferences →
Properties…, is used to specify default properties. Any changes made
to these properties will be saved in .props files under the
CytoscapeConfiguration subdirectory of the user’s home directory.

Cytoscape properties are configurable using the Add, Modify and Delete
buttons as seen below.

[image: _images/Preferences_cy3.png]

App properties may also be edited in the same way as editing Cytoscape
properties. For example, to edit the properties of Linkout, select
‘linkout’ from the combobox of the Preferences Editor. Some apps may
store properties inside session files in addition to (or instead of)
storing them in the CytoscapeConfiguration directory.

[image: _images/Preferences_Linkout.png]

 




19.2. Managing Bookmarks

Cytoscape contains a pre-defined list of bookmarks, which point to
sample network files located on the Cytoscape web server. Users may add,
modify, and delete bookmarks through the Bookmark manager, accessed by
going to Edit → Preferences → Bookmarks….

[image: _images/Preferences_bookmarks.png]

There are currently several types of bookmarks (based on data
categories), including network and table. Network bookmarks are URLs
pointing to Cytoscape network files. These are normal networks that can
be loaded into Cytoscape. Table bookmarks are URLs pointing to data
table files.

 




19.3. Managing Proxy Servers

You can define and configure a proxy server for Cytoscape by going to
Edit → Preferences → Proxy Settings….

[image: _images/Preferences_proxy.png]

After the proxy server is set, all network traffic related to loading a
network from URL will pass through the proxy server. Cytoscape apps use
this capability as well. The proxy settings are saved in
cytoscape3.props. Each time you click the OK button after making a
change to the proxy settings, an attempt is made to connect to a well
known site on the Internet (e.g., google.com) using your settings. For
both success and failure you are notified and for failure you are given
an opportunity to change your proxy settings.

If you no longer need to use a proxy to connect to the Internet, simply
set the Proxy type to “direct” and click the OK button.

 




19.4. Managing Group Settings

The configuration of Cytoscape group view may also be edited through
Edit → Preferences → Group Preferences….

[image: _images/Preferences_groups.png]

Note that Group Preferences apply to node groups established after the group preferences are set. They do not apply to groups that already exist.

The Group Preferences dialog provides access to three Group View Settings and all of the Attribute Aggregation Settings.
There are two interacting settings involved in the group view and group interaction:


	how an expanded group appears


	what happens when a node (group member or group node) is double-clicked


	what appears inside of a group node when it is collapsed





Group View Settings

The following node visualization options are available:


	None: No specific visualization – just do expand/contract, but don’t treat the expanded group special in any way


	Compound Node: Show the group node as an area surrounding the member nodes, but position it behind the member nodes to allow direct selection of each of the members.  If you move a node within this area, you may need to resize the area to encompass the newly positioned member node. Moving the group node will cause all member nodes to move with it.  There are visual styles that allow you to change the color, shape and padding for the compound node.


	Show Group Node: When the group is expanded, show the group node as an additional node and add “member edges” between the group node and each of the member nodes.  This is useful, for example, for complexes where it may be important to show a group node (the entire complex) at the same time as group member nodes (each individual protein).


	Single Node:  Show the group node as an area surrounding the member nodes, but put it in front of the member nodes so that the member nodes can not be selected or moved individually.




If you set the Double-Click action to something other than Expand/Contract, the groups won’t collapse on double-click, which may be appropriate for displaying group nodes that contain other nodes (i.e., the Compound Node visualization or Single Node visualization).




Attribute Aggregation Settings

Attribute aggregation provides an automated way for a group to aggregate all of the attributes of its children.  Since the columns in a Cytoscape network must all be of the same type, a group can’t simply create a list of integers to aggregate the integer columns of its members – the right approach to aggregating the attributes of group members will obviously depend on the application.  Cytoscape allows you to set the default aggregation approach for each type of column: Integer, Long, Double, String, Boolean, String List, Integer List, Long List, or Double List in the Default Aggregation Settings section.  In general, the user is provided with a list of some common aggregations.  For example, Integer aggregations include Average,  Minimum Value, Maximum Value, Median Value or Sum.

In addition, users can indicate that a specific column should use an aggregation approach different from the default by looking at Aggregation Overrides.




Grouping Tips

The Show collapsed node as a Nested Network checkbox determines the contents of a grouping node when its member nodes are hidden. If it is checked, the group node contains a graphic of the laid out member nodes. For the Compound Node visualization, this box should remain unchecked so the grouping node can appear as a background to member nodes.

Attribute aggregation only occurs when the group is collapsed or when the group visualization is changed (e.g., from Single Node to Compound Node).






19.5. Managing OpenCL Settings

You can choose between one or more OpenCL drivers installed on your system by going to
Edit → Preferences → OpenCL Settings….

[image: _images/Preferences_opencl.png]

OpenCL is a library that enables Cytoscape to use your system’s graphics processing unit (GPU)
to accelerate certain layouts and other calculations. If no choices are presented, consult
the support web page for your system’s graphics card.
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20. Linkout

Linkout provides a mechanism to link nodes and edges to external web
resources within Cytoscape. Right-clicking on a node or edge in
Cytoscape opens a popup menu with a list of web links.

By default, Cytoscape includes a number of links such as
Entrez, SGD and Google, as well as a number of species-specific
links. In addition to the default links, users can customize the
External Links menu and add (or remove) links by using the Cytoscape
Preferences Editor (found under Edit → Preferences → Properties…
in the linkout group).

External links are listed as ‘key’-‘value’ pairs in the
editor where Property Name specifies the name of the link and
Value is the search URL. Linkout menus are organized in a
hierarchical structure that is specified as part of the key. Linkout key terms
specific to nodes start with the keyword nodelinkouturl; for edges
this is edgelinkouturl.

For example, the following entry:

nodelinkouturl.Model Organism DB.SGD (yeast)=http://www.yeastgenome.org/cgi-bin/locus.fpl?locus=%ID%





places the SGD link under the Model Organism DB submenu. This link will
appear in Cytoscape as:

[image: _images/Figure1_linkout_Cy3.png]

In a similar fashion one can add new submenus.

The %ID% string in the URL is a place-holder for the node label.
When the popup menu is generated this marker is substituted with the
node label. In the above example, the generated SGD link for the YNL050C
protein is:

http://www.yeastgenome.org/cgi-bin/locus.fpl?locus=YNL050C





If you want to query based on a different column, you need to specify a
different node label using Styles.

For edges the mechanism is much the same; however here the placeholders
%ID1% and %ID2% reflect the source and target node label
respectively.

Currently there is no mechanism to check whether the constructed URL
query is correct and if the node label is meaningful. Similarly, there
is no ID mapping between various identifiers. For example, a link to
NCBI Entrez from a network that uses Ensembl gene identifiers as node
labels will produce a link to Entrez using the Ensembl ID, which results
in an incorrect link. It is the user’s responsibility to ensure that the
node label that is used as the search term in the URL link will result
in a meaningful link.

 


20.1. Adding and Removing Links

The default links are defined in the linkout.props file contained in the
CytoscapeConfiguration directory. These links are normal Java properties and can
be edited directly via text editor or by using the Cytoscape Configuration Editor (Edit → Preferences → Properties…) and
selecting linkout (shown below).

[image: _images/Figure2_linkout26.png]

In addition, new links can be defined when starting Cytoscape from
command line by specifying individual properties. The formatting of the
command is cytoscape.sh -P [context_menu_definition]=[link].
context_menu_definition specifies the context menu for showing the
linkout menu item. The structure of this definition is nodelinkouturl or edgelinkouturl followed by
“.” and followed by the “.”-separated menu hierarchy.

For instance this command:

cytoscape.sh -P nodelinkouturl.yeast.SGD=http://db.yeastgenome.org/cgi-bin/locus.pl?locus\=%ID%





will add this menu item:

[image: _images/Figure3_linkout26.png]

To remove a link from the menu, simply delete the property using Edit
→ Preferences → Properties… and selecting commandline. Linkouts
added in the command line will be available for the running instance of
Cytoscape.
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21. Panels

There are five panels that can be visible or hidden:


	Control Panel (left)


	Tool Panel (bottlom left)


	Table Panel (bottom right)


	Results Panel (right)


	Command Panel (bottom)




[image: _images/DockWindow-v3_8_0.png]

Each panel contains multiple tabs. For example the Control Panel contains at a minimum the Network,
Style, Filter and Annotation tabs. The Table Panel contains the Node Table, Edge Table and
Network Table tabs. Analysis results from Analyzer (Tools → Analyze Network)
are shown in Results Panel. Installed Apps may add additional tabs.

 


21.1. Managing Panels

These panels can compete for valuable screen real-estate (e.g. by making the network view too small), so it is important to manage each panel’s state and size properly and acconding to the user’s needs.
You can take advantage of these 5 panel states in order to manage the available screen real-estate:


	Hidden: A panel can be totally removed from the screen if you find it unnecessary. To do that, uncheck the corresponding option under the View menu (e.g. uncheck View → Show Results Panel to hide the Results Panel). When a panel is hidden its tabs no long appear in the sidebar. In order to show the panel again select the same menu option.

Alternatively, you can right-click an empty space on any sidebar to hide/show a panel:

[image: _images/RightClickShowPanel.png]



	Minimized: Use the Minimize icon [image: _images/MinimizeIcon.png] at the top-right corner of a panel to quickly hide it. The tabs from a minimized panel still appear on the sidebar, and by clicking a tab the panel will be shown again as undocked. Some panels (e.g. Tool Panel) may be minimized by default.

In the example below, the Control and Tool panels are minimized (Results and Command are hidden):

[image: _images/ExampleMinimized.png]



	Docked: The most used panels (e.g. Control, Table) are initially docked by default. When docked, a panel takes the space that could be used by its adjacent panels and by resizing it, those adjacent panels are resized as well (e.g. by resizing the “Control” panel horizontally, the “View” panel is also resized). If a panel is undocked or floating, use the Dock icon [image: _images/DockIcon.png] to make it docked.

In the screenshot below, all panels are docked, except Results and Command, which are hidden:

[image: _images/ExampleDocked.png]



	Undocked: A panel is undocked when the Undock icon [image: _images/UndockIcon.png] is clicked or a minimized panel is shown again by clicking one of its tabs on the sidebar. In this state, the panel is displayed over other panels but is still anchored to one of Cytoscape corners. That allows it to be resized more freely (vertically and horizontally) whithout affecting the size of other panels. You can also double-click the undocked panel’s title bar to quickly maximize it. And double-clicking the title bar of a maximized panel again will restore it to its previous size. To temporarily hide an undocked panel click the Minimize icon [image: _images/MinimizeIcon.png]. An undocked panel will be automatically minimized when other panels or components outside the undocked panel are clicked.

In the example below, the Control panel is undocked:

[image: _images/ExampleUndocked.png]



	Floating: Use the Float icon [image: _images/FloatIcon.png] to completely detach a panel from the Cytoscape desktop. A floating panel has its own window that can be resized, maximized and minimized like any other application window. It can also be moved to another monitor in a multi-monitor setup.

When a panel is floating, its tabs are not removed from the corresponding sidebar in the main desktop window, but you can also use the drop-down in the floating panel’s title bar to show another tab’s content:

[image: _images/TabsDropDown.png]

In the image below, the Control, Table and Tool panels are floating:

[image: _images/ExampleFloating.png]





 




21.2. Other Features


	Hide Sidebar Labels:

When you install and use Cytoscape apps, those apps may add their own tabs, which can sometimes lead to very busy sidebars. In order to make the sidebars cleaner and easier to use, Cytoscape allows you to hide the tab labels and show only their icons. Righ-click anywhere on a sidebar and uncheck the context-menu option Show Labels.

In the example below, notice how the left sidebar is crowded with many tabs:

[image: _images/ShowSidebarLabels.png]

In the next example, the tab labels have been hidden:

[image: _images/HideSidebarLabels.png]
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22. Rendering Engine

 


22.1. What is Level of Detail (LOD)?

Cytoscape is able to display large networks (> 10,000 nodes) while
maintaining interactive speed. To accomplish this goal the
level of detail (LOD) used to display the network is
chosen based on the number of nodes and edges currently being displayed.
For example, by default, node labels (if present) are only
rendered when less than 200 nodes are visible because drawing text is a
relatively expensive operation. This can create some unusual behavior.
If the screen currently contains 198 nodes, node labels will be
displayed. If you pan across the network, such that now 201 nodes are
displayed, the node labels will disappear. As another example, if the
sum of rendered edges and rendered nodes is greater than or equal to a
default value of 4000, a very coarse level of detail is chosen, where
edges are always straight lines, nodes are always rectangles, and no
anti-aliasing is done.

Additionally Cytoscape may temporarily lower the level of detail even
more while the network is being interacted with (eg. panning,
zooming, moving a node). For example edges and charts may not be displayed
during interaction. When the network is no longer being interacted
with it will be displayed again in higher detail.

Low LOD vs High LOD


Levels of Detail

 	Network with Low LOD                                                            	Network with High LOD                                                       

 	 	 




With low LOD values, all nodes are displayed as square and anti-aliasing
is turned off. With high LOD values, anti-aliasing is turned on and
nodes are displayed as actual shape user specified in the Style.

 


Force to Display Detail

If you want to display every detail of the network at all times regardless of LOD
values, you can toggle to full details mode by View | Show Graphics
Details (or CTR+SHIFT+D on Windows/Linux, Command+SHIFT+D for Mac).
This option forces the display of all graphics details. If the network
is large, this option slows down rendering speed. To hide details,
select the menu item again (View | Hide Graphics Details).

 




Parameters for Controlling LOD

The default values used to determine level of detail
can be changed by setting properties under Edit | Preferences | Properties….

NOTE: The greater these thresholds become, the slower performance
will become. If you work with small networks (a few hundred nodes),
this shouldn’t be a problem, but for large networks it will produce
noticeable slowing. The various thresholds are described below.

NOTE: Since Cytoscape 3.8 interactivity will always be maintained
even when a high level of detail is chosen. It is generally safe
to increase the level of detail or to force full graphics details even
for very large networks.


LOD Thresholds
 	Parameter                          	Description                                                                                                                                  

 	render.coarseDetailThreshold  	If the sum of rendered nodes and rendered edges equals to or exceeds this number, a very coarse level of detail will be chosen and all other detail parameters will be ignored. If the total number of nodes and edges is below this threshold, anti-alias will be turned on; this value defaults to 4000. 

 	render.nodeBorderThreshold 	If the number of rendered nodes equals to or exceeds this number, node borders will not be rendered; this value defaults to 400.  

 	render.nodeLabelThreshold     	If the number of rendered nodes equals to or exceeds this number, node labels will not be rendered; this value defaults to 200.      

 	render.edgeArrowThreshold  	If the number of rendered edges equals to or exceeds this number, edge arrows will not be rendered; this value defaults to 600.   

 	render.edgeLabelThreshold     	If the number of rendered edges equals to or exceeds this number, edge labels will not be rendered; this value defaults to 200.      



When printing networks or exporting to formats such as PostScript, the
highest level of detail is always chosen, regardless of what is
currently being displayed on the screen.
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23. Export Your Data


23.1. Raw Data Export

[image: _images/export_menu_38.png]

To use data from Cytoscape networks in an external application, the data has to be exported.
As a Cytoscape network consists of a number of different types of data, there are options
in Cytoscape for each exportable data type. These options (Network, Table, Styles) can be found on the
File → Export submenu (shown above).

 


Network Data Exchange (NDEx) Public Database

The Network to NDEx and Collection to NDEx options are used to store a network on the public NDEx server. You can use the NDEx public server to store your networks on the cloud, for sharing networks with collaborators, or to archive networks for publication. To store a network, you must first create a free NDEx account, which you can easily do by visiting the NDEx Public Server [http://ndexbio.org] website.

The Network to NDEx option saves only the currently selected network to your NDEx account. Such networks are suitable for processing by other applications and web services, as they contain only the nodes and edges in the selected network – other views and the nodes and edges unique to them are not written. If you later re-import this network (using the Cytoscape Search bar), only the single network you saved will be loaded.

The Collection to NDEx option saves all networks in the collection containing the currently selected network. If you later re-import this collection (using the Cytoscape Search bar), the entire collection will be loaded. This option is closest to saving an entire Cytoscape session.

When you select either option, the CyNDEx-2 Browser dialog will appear and enable you to provide various metadata to annotate the network and make it findable in subsequent NDEx searches. You can set the name of your network by editing the Network Name attribute. The Update Existing Network option enables you to overwrite the existing copy of the network (if you have permission to do so). We recommend to provide as much metadata as possible, and always provide at least Version and Description attributes.

To export your network, you must first associate your NDEx account credentials with the CyNDEx-2 Browser by filling out the profile form (red oval in screenshot below)

[image: _images/ndex_save1.png]

Once the profile is created, you are allowed to export your network to NDEx

[image: _images/ndex_save2.png]

Export commands have also been added to the network and collection context menus in the Cytoscape Network panel, as another method of accessing the network save dialog.

[image: _images/ndex_context_menus.png]

Finally, the NDEx button in the toolbar provides an additional convenient way to both Import and Export to NDEx

[image: _images/ndex_toolbar_button1.png]

When the export operation is complete, a confirmation dialog will be displayed as shown below. If you want to share your network with external collaborators or for more sharing options, please refer to the guide for Uploading and Sharing Networks [https://home.ndexbio.org/sharing-and-accessing-networks/] in NDEx.

[image: _images/ndex_save_done.png]

Further information on NDEx is available at the NDEx Informational/Doc website [https://home.ndexbio.org/quick-start/].




Network

[image: _images/network_export_dialog.png]

The Network option is used to export
network data. Network data includes the nodes and edges in the network, and also
will include data attributes and visual information if the chosen format supports it
(like XGMML). Network data can be exported in a number of formats, including:


	SIF (Simple Interaction Format)


	NNF (Nested Network Format)


	XGMML


	GraphML


	PSI-MI Level 1 and 2.5


	Cytoscape.js JSON (can be used with Cytoscape.js, a tool described in future sections)


	CX JSON (for Cytoscape Cyberinfrastructure network exchange)




The default format is SIF, which is a simple tab-delimited network format that provides
node names and edge interactions only. You can choose the format using the dialog drop-down box.
A file name is automatically suggested based on the network name and selected format, with the file path
defaulting to the current working directory. You can change the suggested file name/path using the
text box or Browse button. Press OK to export with the selected options.




Table

[image: _images/table_export_dialog.png]

The Table option is used to export any of the data tables that are available
in the current Cytoscape session. This includes the node, edge, and network tables
that can be seen in the Table Browser, as well as any unassigned tables. The only
currently supported file format currently for export is CSV (comma-separated value).

The export dialog for Table has only two selectable options - the table to export
and the file name (file type is always CSV). A file name is suggested based on the
name of the selected table with the path defaulting to the current working directory.
As in Network, the suggested file name can be changed using the Browse button or the
text field. Press OK to export the selected table with the given file name.




Styles

[image: _images/styles_export_dialog.png]

The Styles option is used to export one or more visual styles available in the current Cytoscape session. Supported formats include Style XML (which can be imported by 3.x versions of Cytoscape) or Cytoscape.js JSON (which can be used with Cytoscape.js, described in future sections).

Style export has three options - the export format (as described above), the style(s) to export, and the file name (a suggestion will be made based on the current directory and file type). As in Network → Table, the suggested file name can be changed using the Browse button or the text field. The list of styles is a multiple-selection list - one or more can be selected using Ctrl/Cmd-click (to select multiple discontiguous elements) or Shift-click (to select a contiguous element range). Press OK to export all selected styles with the given file path.

 






23.2. Exporting for Publication

When you finish your data analysis and visualization, you can
publish your data to share the results. Cytoscape has several options to
do this, with most options suitable for Cytoscape users and other options
suitable for programmers wanting to create unusual or complex network
viewers. These are further explained below.


	An NDEx network


	A session file


	A static image


	An interactive web application


	CyNetShare [http://idekerlab.github.io/cy-net-share/]


	Full web application


	Simple network view (for web application developers)








 


As an NDEx Network

The easiest way to share your results with others is to save your network in the NDEx Public Database by using the Network to NDEx or Collection to NDEx options. Then, visit your NDEx account and enable the Sharable URL (similar to a Google Doc shared link) so that your private network can be accessed by whoever you send the link to.

NDEx also has additional options that enable you to:


	request a DOI suitable for use in publications, grant applications or progress reports


	create working groups and specific sharing within NDEx.


	run different types of queries on your networks


	perform enrichment analysis on a variety of datasets, including curated pathways, large interactomes, drug-target           association networks and many more.




For more information on NDEx publishing and sharing features, see the Publishing in NDEx [http://home.ndexbio.org/publishing-in-ndex/] and Sharing Networks in NDEx [http://home.ndexbio.org/obtaining-and-granting-access-to-a-network/] manuals.

 




As a Session File

Another easy way to share your results with others is simply saving
everything as a session file (which is a zipped session archive). You
can save your current session by clicking the Save Session icon. You
can save to a thumb drive, a shared file system, or even a cloud drive
directory such as Dropbox. If you save to a shared drive, beware not
to have two people work on the same session file with Cytoscape at the
same time, as unpredictable results may occur.

 




As a Static Image

[image: _images/image_export_dialog.png]

Cytoscape can generate publication-quality images from network views. By
selecting File → Export as Image…, you can
export the current network view into the following formats:


	JPG


	PNG


	PS (Post Script)


	SVG


	PDF




The image export dialog has a variable number of options based on the file format selected, with file type and file name always being selectable. PNG and JPEG have options for scaling, while other formats only have a single option, Export Text as Font. The file name is suggested based on the name of the selected table with the path defaulting to the current working directory. As in raw data export, the suggested file name can be changed using the Browse button or the text field. Press OK to export an image with the given file name and parameters.

We recommend using PDF for publications because it is a standard
vector graphics format, and it is easy to edit in other applications
such as Adobe Illustrator.

 


Known Issues

For PDF export, there is an option to Export text as font.
This option does not work for two-byte characters such as Chinese or
Japanese. To avoid corrupted texts in the exported images, please
uncheck this option when you publish networks including those
non-English characters.

 






As an Interactive Web Application (New in 3.2.0)

The Web is an excellent platform for data sharing and collaboration, and
Cytoscape provides a number of ways to publish your network on the web,
with each choice representing tradeoffs between ease, simplicity, and
customization options. All solutions leverage the cytoscape.js drawing
library, and so enable not only viewing but also Cytoscape-style
interactive browsing of networks and attributes.

The simplest choice is
CyNetShare,
where you save your network (and optionally a style) on a public file
system, then interactively view the network in a browser. Like Google
Maps, you can generate and publish a URL that allows collaborators to
also view your network.

Alternatively, Cytoscape can generate an entire web site showing a
single page containing the viewer with your network pre-loaded. You can
load this directly onto your own web server to become part of your web
site.

Finally, Cytoscape can generate the skeleton of a web site for further
customization by
JavaScript [https://en.wikipedia.org/wiki/JavaScript]
programmers.

These features are available as Export menu items under the File menu,
and are described in sections below.

For example, here is a network in Cytoscape:

[image: _images/WebExportOriginal_v3_3_3.png]

Here is the same network as an interactive web visualization:

[image: _images/web_export_fullexport.png]

Note that web browsers can render small networks (e.g., 1000 nodes)
quickly and effectively, but attempting to render large ones (e.g., 5000
nodes) will take a very long time.

A word about exporting styles to interactive web
applications: Our web applications are based on the cytoscape.js
display library, which renders a subset of Cytoscape styles. For more
information, see the Export Styles to Cytoscape.js section below.

 


Sharing via CyNetShare

CyNetShare [http://idekerlab.github.io/cy-net-share/]
is a browser-based web application that renders JSON-formatted networks
and attributes saved in public directories. Optionally, you can specify
visual styles that the web application will use to draw your network as
it appears in Cytoscape.
CyNetShare [http://idekerlab.github.io/cy-net-share/]
is similar to Google Maps in that once you have loaded your network and
have tweaked its appearance to suit your needs, you can have
CyNetShare [http://idekerlab.github.io/cy-net-share/]
generate a new URL that you can e-mail or post as a link on your own web
site. That URL will bring up
CyNetShare [http://idekerlab.github.io/cy-net-share/]
preloaded with your network for anyone to see.

To use
CyNetShare [http://idekerlab.github.io/cy-net-share/]:


	Select File → Export → Network to File… to export your
network to a public directory. Choose the Cytoscape.js
JSON (*.cyjs) export file format.


	Optionally, select File → Export → Style… to export your
style settings. Choose the Style for cytoscape.js (*.json) export
file format.


	Use your public directory system to determine direct URLs for the
files you exported.


	Start CyNetShare [http://idekerlab.github.io/cy-net-share/]


	Enter the network’s URL as the Graph URL.


	Optionally, enter the style’s URL.


	Click the Visualize button.




The
CyNetShare [http://idekerlab.github.io/cy-net-share/]
User Guide is provided on the
CyNetShare [http://idekerlab.github.io/cy-net-share/]
web page:


	CyNetShare [http://idekerlab.github.io/cy-net-share/]




Note that if you specify a style URL, the style is added to the list of
styles available in
CyNetShare [http://idekerlab.github.io/cy-net-share/]’s
Visual Style dropdown, and you can apply the style by selecting it in
the list. CyNetShare’s initial display uses the visual style named “default” –
use the Visual Style dropdown to choose the style in effect when Cytoscape
generated the .cyjs and .json files.

Note that the mechanics of generating a URL for a file in a public
directory system is a fast moving topic. Until recently, systems like
Dropbox (and others) allowed users to create a URL that resolved
directly to a file – a “direct” URL would be appropriate for use with
CyNetShare [http://idekerlab.github.io/cy-net-share/].
As of this writing, some public directory systems (e.g., Dropbox)
generate “shareable” URLs instead, which resolve to a web page that
allows file download – a “shareable” URL doesn’t work with
CyNetShare [http://idekerlab.github.io/cy-net-share/]. Systems that offer “shareable” URLs may offer “direct” URLs as
part of their premium (or Pro) package. To tell if your public directory
system generates a “direct” URL, have it generate a URL for a file, then
paste the URL into the address field of a browser and observe whether
the browser displays the file itself (good!) or a download page for the
file (bad!).

Hint: if Dropbox generates a “shareable” link that looks like
https://www.dropbox.com/s/w5e7towcchuvdeu/cynetworm.cyjs?dl=0,
you may be able to create a “direct” link by changing the dl=0 to dl=1: https://www.dropbox.com/s/w5e7towcchuvdeu/cynetworm.cyjs?dl=1.

A simple strategy for always getting a “direct” URL is to store your
file in a public directory served up by a web server, if you have access
to one – a URL served by a web server might appear as:
http://myserver.com/~mypublicdir/netstyle.json [http://myserver.com/%7Emypublicdir/netstyle.json].

Alternately, you can use Gist [http://gist.github.com/] to create a
shareable document having a “direct” URL. To try this:


	Use Cytoscape to generate your network as a .cyjs file on your local
disk


	Use an editor to open the file and copy its contents to the
clipboard


	Use a web browser to surf to Gist [http://gist.github.com/]


	Paste the contents into a Gist document


	Select Create public Gist


	Select Raw to place the “direct” URL into your browser’s
address field


	Use that URL with
CyNetShare [http://idekerlab.github.io/cy-net-share/]




 




Generating a Full Web Application

The full page export option is designed for users who want to publish
their network as a complete single-page
application [http://en.wikipedia.org/wiki/Single-page_application].
Cytoscape creates a zip archive containing a complete
JavaScript [https://en.wikipedia.org/wiki/JavaScript]-based
web application that works as a basic viewer (like
CyNetShare [http://idekerlab.github.io/cy-net-share/])
for Cytoscape-generated network visualizations. You can unzip the
archive onto a web server (or your PC) and view the network via a web
browser on PCs and tablets.

[image: _images/web_export_full.png]

To generate an entire web page for all networks in the session as a zip
archive, select File → Export as Web Page…. The following dialog
will appear:

[image: _images/web_export_full_dialog.png]

This simple dialog has only two options - the file name and the type of
web export (full, simple network view, or JSON). For full web application,
we use the default. The file name is suggested based on the name of the
selected table with the path defaulting to the current working directory.
As in raw data export, the suggested file name can be changed using the
Browse button or the text field. Press OK to export a web archive with
the given file name.

To view the web page, unzip the archive into a folder on your PC or web
server. The folder will contain an index.html file, the network
data, and other files. You can open the index.html file in your
browser (usually from your browser’s File → Open menu item.)

Here is an example exported file from Cytoscape:


	Example full export deployed to web
server [http://chianti.ucsd.edu/%7Ekono/webapp/cytoscape-export-full/]


	Archive file [http://cl.ly/XjMs/cytoscape_full_export.zip]




[image: _images/web_export_full2.png]

Note that because Cytoscape uses the latest HTML5-based web
technologies, it cannot support older or non-conformant web browsers
such as Internet Explorer. We strongly recommend using the latest
version of modern web browsers such as Google Chrome, Mozilla Firefox,
or Apple Safari.

 




Generating a Simple Network View (For Web Application Developers)

The Simple Network View export option is designed for users who want to
publish their data as a complete single-page
application [http://en.wikipedia.org/wiki/Single-page_application], but
are interested in customizing the web viewer application themselves.
Cytoscape creates a zip archive containing a partial
JavaScript [https://en.wikipedia.org/wiki/JavaScript]-based
web application based on the cytoscape.js library and including simple
“boilerplate” code and the current network view. The user can create a
custom viewer by customizing this code.

[image: _images/web_export_simple.png]

To generate a web page for a single network view as a zip archive, select
File → Export as Web Page … as before, but this time choose the
Simple viewer for current network only format as below:

[image: _images/web_export_simple_dialog.png]

Everything else works as before, though this time the viewer will only
include the current network. Press OK to proceed with the export.

For instructions on testing the customized web application, see
Generating a Full Web Application above.

 




Extending the webpage with Cytoscape.JS functionality

As of version 3.6.2 of the JSON Support core app in Cytoscape, the user
may add custom Cytoscape.JS events [http://js.cytoscape.org/#core/events]
to the exported webpage.  In the web_session/scripts directory, a custom.js
file has been added with a designated spot for custom JS code.

For example, to add linkouts to nodes in the webpage (i.e. opening a
URL specified by the “href” node attribute when the user clicks the node),
the custom.js file should look like:

// Notice that the `cy` object may only be referenced 
// after the document has finished loading.

$( document ).ready(function(){  
  cy.on('tap', 'node', function(){
    try { // your browser may block popups
      window.open( this.data('href') );
    } catch(e){ // fall back on url change
      window.location.href = this.data('href');
    }
  });
});





This change has to be made each time you export a web
page. If you want to change the default export template, refer to the next section.

 




Customize Export Template (For Web Application Developers)

The code generated by Cytoscape for the Full Web Application and the
Simple Network View web applications is minimalistic. While you can
directly modify this code yourself to create your own page design or add
new features, the modifications will apply to a single exported network.
If you are a web application developer, you can change the application
code generated for all exports by editing HTML5 template code
resource files in your ~/CytoscapeConfiguration/web directory:

[image: _images/web_folder.png]

In this folder, you can find full and simple sub directories
corresponding to Full Web Application and the Simple Network View
described above.


Requirements

To build these project, you need the following tools installed:


	Node.js


	gulp


	grunt







Full Export Template

This is an AngularJS based web application built with grunt (at least
for now – we have plans to migrate to gulp). Source code and more
documentations are available here:

* https://github.com/idekerlab/cyjs-full-export

To build the project into dist directory, type:

grunt








Simple Export Template

This template is generated by a simple gulp [http://gulpjs.com/]
project. The source code is available here:


	https://github.com/idekerlab/cyjs-export-simple




To build the project into dist directory, type:

gulp








Use Your Custom Templates for Export

Once you have your own builds, you can deploy your templates by
replacing the contents of full and simple with your own builds.
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24. Cytoscape and OpenCL (Computing on the GPU)

 


24.1. What it is for?

Cytoscape has basic support for offloading computationally intesive tasks
for parallel processing on a GPU, multicore CPU or a multiprocessor card
using OpenCL [https://en.wikipedia.org/wiki/OpenCL].
The OpenCL support in Cytoscape is mostly intended
to provide a unifying OpenCL access for third-party Cytoscape Apps,
but  some core functionality (Prefuse layout) also has OpenCL implementation
for increased performance.

As OpenCL can run on almost any device, including desktop computers
without dedicated GPUs,
you should be able to use OpenCL functionality on any platform
where you can run Cytoscape, although you may need to install
additional drivers for your device.

 




24.2. Setup & Configuration

The CyCL core app (should be already part of your Cytoscape distribution)
lets you see the available OpenCL devices and configure your preferred device for OpenCL computation.
To see the device list and configure your preferred device,
select Edit → Preferences → OpenCL Settings…

[image: _images/open_cl_settings.png]

In most cases, you want your preferred device to be your GPU (if you have one).
If you do not see the device you intend to use (or any device at all)
in the configuration window,
you may need to install OpenCL drivers.
For GPUs from major manufacturers, OpenCL drivers are usually installed
with the graphics driver. If you have installed the latest graphics drivers and still do not see your device in the list, check the website of your GPU manfucturer.
To use OpenCL on a CPU (i.e., on any desktop computer) or a Xeon Phi,
you need to install the drivers separately from
the web page of the manufacturer of your CPU.

As of 2017-01-06, drivers for Intel CPUs can be downloaded at
https://software.intel.com/en-us/articles/opencl-drivers#latest_CPU_runtime -
look for “runtime-only”. AMD requires you to find drivers per device [https://community.amd.com/community/support-forums/drivers-software] for older hardware or use ROCm:  https://github.com/RadeonOpenCompute/ROCm/wiki#What-Is-ROCm. .

Warning: After you have just installed drivers for your OpenCL device,
Cytoscape may require restarting to be able to “see” the device.

 




24.3. OpenCL/GPU Troubleshooting

If any OpenCL app is not working, here are some of the common causes:


CyCL core app is not installed or not initialized property

Diagnosis: check if you can see the Edit → Preferences → OpenCL Settings… menu item.
If not, this is a bad sign.

Treatment: Check the CytoscapeConfiguration directory,
if it contains a file called disable-opencl.dummy remove it and start Cytoscape
from the system console (using cytoscape.bat or cytoscape.sh).
Check console output for additional information.




No OpenCL devices are available

Diagnosis and treament: See Setup and configuartion above.




The Cytoscape console says “Could not find OpenCL.dll”

Treatment: Make sure your Windows OS directory containing OpenCL.dll is listed in the
value of the Java system property java.library.path
(OpenCL.dll can usually be found in %windir\SysWOW64% or %windir%\system32).
You can modify java.library.path by adding a line of the form
-Djava.library.path=path1;path2 to the Cytoscape.vmoptions file.
Cytoscape.vmoptions can be found in the Cytoscape installation directory.




The computer is unresponsive for a while and then resets the screen while running OpenCL on the GPU.

Treatment: This problem arises
if you run computations on the GPU that also handles your main display and
the computation occupies the GPU for too long,
preventing the operating system (e.g., Windows) from updating the display.
If the operating system detects this, it terminates the GPU computation.
You can either try to run smaller chunks of the computation or configure
the “Timeout Detection and Recovery” (TDR) to let the computation complete
even if the system becomes unresponsive.
Further info can be found at this NVidia thread [https://devtalk.nvidia.com/default/topic/459869/-quot-display-driver-stopped-responding-and-has-recovered-quot-wddm-timeout-detection-and-recovery-/]
or Microsoft webpage [https://msdn.microsoft.com/en-us/library/windows/hardware/ff570087(v=vs.85).aspx].
Microsoft also has documentation for the registry keys that need to changed [https://msdn.microsoft.com/en-us/library/windows/hardware/ff569918(v=vs.85).aspx].




My problem is not listed here

Try to install drivers for your CPU and run on the CPU platform (see links above). CPU platforms offer lower performance, but are generally more reliable.
If this does not help you, ask for help in a
Cytoscape-tagged StackOverflow post [https://stackoverflow.com/questions/tagged/cytoscape?sort=newest].
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25. Cytoscape.js and Cytoscape

 


25.1. What is Cytoscape.js?

[image: _images/jsWebSite.png]

Cytoscape.js [http://cytoscape.github.io/cytoscape.js/] is a
JavaScript library for interactive network visualization. It is a
building block for web applications and is NOT a complete web
application. If you have network data sets and want to share
visualizations created with Cytoscape, you can build your own website
using Cytoscape.js and this new Export to Cytoscape.js feature.

 


Examples


	A network visualized with Cytoscape 3.1.0

[image: _images/sampleOriginal.png]



	Same network exported to Cytoscape.js (Rendered with Google Chrome
and Cytoscape.js 2.0.3)

[image: _images/sampleExport.png]



	Interactive example (galFiltered.sif rendered with
Cytoscape.js 2.0.3) [http://chianti.ucsd.edu/%7Ekono/dist/]




 




Differences and Shared Concepts

Although Cytoscape and Cytoscape.js are two completely independent
software packages, they are sharing higher level concepts. The following
is the list of similarities and differences between the two:


Cytoscape


	Desktop application for network visualization written in Java
programming language [http://www.java.com/]


	Needs desktop or laptop computers to run


	Users have to install Java runtime


	High performance application for large scale network analysis and
visualization


	Expandable by Apps [http://apps.cytoscape.org/]


	Use Styles to map data to network properties, such as node
color, edge width, node shape, etc.







Cytoscape.js


	A JavaScript library [http://en.wikipedia.org/wiki/JavaScript]
for network visualization, NOT a complete web application nor
mobile app


	Runs on most of modern web browsers, including tablets and smart
phones


	No plugins are required to run. Modern web browser is the only
requirement


	Need to write code to set up your web site or web application


	Expandable by
Extensions [http://cytoscape.github.io/cytoscape.js/#extensions]


	Use CSS-based Styles to map data to network properties




In a long term, Cytoscape and Cytoscape.js will be more integrated, and
as the first step Cytoscape now supports reading and writing
Cytoscape.js network/table JSON files. In addition, Cytoscape can
convert Styles to Cytoscape.js Style object.

 








25.2. Data Exchange between Cytoscape and Cytoscape.js

Since Cytoscape.js is a JavaScript library, its basic data exchange
format is JSON (JavaScript Object Notation) [http://www.json.org/]. All
of these import/export functions are part of standard Cytoscape user
interface, and you can read/write Cytoscape.js JSON files just like
other standard files such as SIF.

 


Export Network and Table to Cytoscape.js

Cytoscape.js stores network data (graph) and its data table in the same
object. Cytoscape writes such data complex as JSON, i.e., both network
and data tables will be exported as a single JSON file. You can select a
network and export it from File | Export | Network.

Cytoscape only supports one of the Cytoscape.js supported JSON formats,
which is:

{
    elements:{
        nodes:[],
        edges:[]
    }
}





SUID will be used as unique identifier for nodes and edges in the
JSON. For more information about this format, please visit Cytoscape.js
web site [http://cytoscape.github.io/cytoscape.js/].


Important Note about Data Compatibility

Cytoscape creates JSON file directly from data table and tries to
extract as much data as possible from the original table. However, since
table column names will be directly converted into
JavaScript [https://en.wikipedia.org/wiki/JavaScript]
variable names, invalid characters will be replaced by underscore (_):


	Original Data Table Column Names:

Gene Name
KEGG.pathway







	The Names above will be replaced to:

Gene_Name
KEGG_pathway









You should be careful when you plan to use this feature for data
roundtrip: from Cytoscape to Cytoscape.js back to Cytoscape. For such
use cases, we strongly recommend to use
JavaScript [https://en.wikipedia.org/wiki/JavaScript]-safe
characters only in your table column names. Naming your columns only
with alphanumeric characters and underscore (_) is the best practice.
(For actual data entries, all characters are allowed. This restriction
is only for table column names.)

 








25.3. Export Styles to Cytoscape.js

Cytoscape and Cytoscape.js are sharing a concept called Style. This
is a collection of mappings from data point to network property.
oCytoscape can export its Styles into CSS-based Cytoscape.js JSON.

You can export all Styles into one JSON file from File | Export |
Styles and select Cytoscape.js JSON as its format.


Limitations

Cytoscape.js does not support all of Cytoscape Network Properties. Those
properties will be ignored or simplified when you export to JSON Style
file.

Currently, the following Visual Properties will not be exported to
Cytoscape.js JSON:


	Custom Graphics and its positions


	Edge Bends


	Tooltips


	Node Label Width


	Node Border Line Type


	Arrow Colors (they are always same as edge color)







Cytoscape.js and Cytoscape Compatibility

Cytoscape’s network rendering system is designed for desktop use, while the browser-based renderer
incorporates web technologies (e.g., cytoscape.js and Cascaded Style Sheets). As a result, most but
not all networks will render the same in the browser as in Cytoscape. Cytoscape visual styles not
supported in the web browser are ignored. A complete compatibility list is available
here [https://docs.google.com/spreadsheets/d/1iTDKGjro1-L7HGz1ftozqDKRxjQVSPF28jQLt7XGrSg/edit#gid=0].

 




Import Cytoscape.js data into Cytoscape

Cytoscape.js network JSON files can be loaded from standard Cytoscape
file menu: File | Import | Network …. Both File and URL are
supported.

 






25.4. Build Your Own Web Application with Cytoscape.js

Although Cytoscape can export networks, tables, and Style as
Cytoscape.js-compatible JSON, users have to write some
JavaScript [https://en.wikipedia.org/wiki/JavaScript]
code to visualize the data files with Cytoscape.js. Details of web
application development with Cytoscape.js is beyond the scope of this
document. If you need examples and tutorials about web application
development with Cytoscape.js, please visit the following web site:


	https://github.com/cytoscape/cyjs-sample/wiki




 


Questions?

If you have questions and comments about web application development
with Cytoscape and Cytoscape.js, please send yours to our mailing
list [https://groups.google.com/forum/#%21forum/cytoscape-discuss].
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26. Cytoscape Automation

Cytoscape’s intuitive graphical user interface is useful for
interactive network data integration, analysis, and visualization. It
provides great features for exploratory data analysis, but what happens
if you have hundreds of data files or need to ask someone to execute
your data analysis workflows? It is virtually impossible to apply the
same operations to hundreds of networks manually using a GUI. More
importantly, although you can save your results as session files,
you cannot save your workflows if you perform your data analysis
with point-and-click GUI operations. Cytoscape has several options that
support automating your workflows, all under the umbrella of Cytoscape Automation. More tutorials and examples are available at the Cytoscape Automation web page (http://automation.cytoscape.org).


26.1. R and Python Packages

If you are already using R or Python, then you’re in luck! There are packages
available in these languages filled with helper functions to make accessing and
controlling Cytoscape quick and intuitive.

The R package is called RCy3 and is available via Bioconductor, see https://www.bioconductor.org/packages/release/bioc/html/RCy3.html. The RCy3 repo offers a nice interface for browsing the documentation
and available vignettes (see Articles menu): http://cytoscape.org/RCy3/index.html. There are also
a collection of video tutorials on the Cytoscape YouTube channel [https://www.youtube.com/playlist?list=PLFQS98nmv__wYlu_XoscNb6DKu_vo6_vH].

The PyCy3 package is coming soon… It’s predescessor is available here [https://github.com/cytoscape/py2cytoscape].

 




26.2. Commands

The Commands feature allows you to script a sequence of Cytoscape commands
and menu items, where commands can have parameter values that would
normally be provided by a user via a Cytoscape dialog box. For example,
session open file=”C:\myfile.cys” loads a session from a file
similarly to the File | Open menu item. Commands may
resolve to Cytoscape core functions or automation-enabled apps installed in
Cytoscape. You can create a command
script file that Cytoscape can execute via the Tools | Execute Command
File menu item or on the Cytoscape command line at startup.
[image: _images/AutomationPanel.png]

Commands is the built-in Cytoscape feature to automate your
workflow as simple script. You can learn more about Commands in the Command Tool
section.

 




26.3. CyREST Interface Layer

In some cases, you may need to leverage the complex control and data structures available in a fully featured programming language,
such as R [http://www.r-project.org/], Python [https://www.python.org/], Ruby [https://www.ruby-lang.org/en/] or
JavaScript [https://en.wikipedia.org/wiki/JavaScript]. Such languages enable complex Cytoscape-centric workflows or the integration of Cytoscape into larger workflows. Cytsocape enables progamatic access to both its Commands and Functions via its CyREST interface.

By default, the CyREST interface is enabled and available on TCP/IP port 1234. To verify this, start a web browser on
your Cytoscape workstation and surf to either http://localhost:1234/v1/ or http://localhost:1234/v1/commands. The first form is a Function that returns basic Cytoscape information as a JSON object:

[image: _images/FunctionAPI.png]

The second form is a Command that returns a list of available Command namespaces:

[image: _images/CommandAPI.png]

Note that the list of namespaces will vary depending on the apps you install – some apps provide Commands in namespaces of their own.

If your workstation has port 1234 already in use, you can specify a different CyREST port in two ways:


	Use the Edit → Preferences menu to alter the rest.port property to select a different port (e.g., 8888)


	Specify the port on the Cytoscape command line via the -R parameter:




     cytoscape.bat -R 8888 (for Windows)
     
     ./cytoscape.sh -R 8888 (for Mac or Linux)





You can test the new port by using your browser to surf to http://localhost:8888/v1/

Note that if you expect to run more than one instance of Cytsocape on a single workstation, the CyREST port must be unique for each Cytoscape instance. You must use either the property or command line parameter technique to execute each instance with a different CyREST port.

 


Exploring CyREST Commands and Functions

Cytoscape makes a list of available Commands and Functions available via the Help → Automation submenus. The CyREST API submenu shows available Functions, and CyREST Command API shows available Commands. Automation Examples leads to a web portal containing the bulk of documentation, samples and tutorials for Cytsocape Automation in general.

[image: _images/automation_menu.png]

Notably, Automation Examples contains a tutorial that explains how to explore CyREST Commands and Functions: https://github.com/cytoscape/cytoscape-automation/wiki/Trying-Automation.

The CyREST API and CyREST Command API submenus document CyREST in a Swagger web application, which allows you to explore CyREST entrypoints by reading about them and invoking them directly (using a Try it out!) button. A sample page matching the http://localhost:1234/v1/ Function is:

[image: _images/swagger.png]

Note that the page contains a description, input parameters, output values, result code and the Try it out! button. Pressing the button executes the Function and shows the actual CyREST call and its results. Making good use of Swagger as a prototyping tool can greatly reduce code writing and debug time!

[image: _images/swagger_result.png]

To find out more about how to use CyREST, visit the Cytoscape Automation tutorial pages (https://github.com/cytoscape/cytoscape-automation/wiki/Trying-Automation).

Note that Swagger pages reflect functionality in Cytoscape at the time it executes, including Commands and Functions contributed by installed apps. To discover CyREST functionality in uninstalled apps, you must first install them, and then use Help → Automation submenus to generate the Swagger pages (or simply reload your Swagger browser page).
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27. Cytoscape Privacy Policy

We respect the privacy of all Cytoscape users, and we do not collect any
information on Cytoscape users except in the situations listed below. In
no case do we attempt to tie any of this information back to a user, nor
do we give, share, sell, or transfer this information to any third party
unless required by law. We use this information only in the aggregate to
generate statistics to assist in securing continued funding for
Cytoscape.


	On the Cytoscape download web page, we log the date, time, browser
signature, and IP address to which we deliver Cytoscape.


	When Cytoscape starts, it fetches news and version information
from a Cytoscape server. We log the date, time, and IP address
of the workstation running Cytoscape.


	During Cytoscape execution, we log usage statistics tagged with the date,
time, and IP address of the workstation running Cytoscape. This
logging can be turned off during Cytoscape installation or by
setting the installoptions.shareStatistics property to false using
the Cytoscape Preferences Editor.




This policy may change from time to time, and if it does, we will notify
you via our normal mass notification media. We will also update this
section of the user manual.

Note that some internal Cytoscape Apps and Apps available through the
Cytoscape App Store connect with third party services via the Internet.
Once an App links to such a service, you are subject to the privacy
policy of that service.
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28. Basic Expression Analysis Tutorial

The Cytoscape Basic Data Visualization tutorial is now available here [https://cytoscape.org/cytoscape-tutorials/protocols/basic-data-visualization/#/].

The complete set of Cytoscape tutorials is available at tutorials.cytoscape.org [http://tutorials.cytoscape.org/].
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‘NODE_FILL_COLOR' #6AACBS',
‘NODE_SIZE" 55,
‘NODE_BORDER WIDTH: 0,
‘NODE_LABEL_COLOR': #355555',

'EDGE_WIDTH: 2,
EDGE_TRANSPARENCT': 100,
/EDGE_STROKE_UNSELECTED_PAINT '#333333',

‘NETWORK_BACKGROUND_PAINT': #FFFFEA"
'

my._yeast_style update_defauits(basic_settings)

# Create some mappings
my._yeast_styiecreate._passthrough_mapping(columnabef, yp='NODE_LABEL',col_type='String’)

dogrees = yeast_netget_node_cotumn( Degree’)
cobr_gradent - StyleUtLreate. 2_ clor_graden(in-degrees.min(), max-Gegrecs.max() colors (Whie', #6AACBS")
degreo. <o_size - StyeUtl create_iope(min-degoes min(), max-cegrees max(), valuese(10, 100))

my-yeast sty creae._continuos mappna(coumn- Doy ¥ veger' points-color_gradient)
my_yeast_sylecreate_contnuous_mapping(column='Degree’, vp-'NODE _SIZE',col_type="nieger, ponts-degree_{o.5ze)
my_yeast_styecreate_continuous_mapping(couumn-'Degree’, vp-'NODE_LABEL FONT.SZE',col_type=nteger, ponts-degree_to_size)

cy.style.appiy(my._yeast_style, yeast_net)

#5tep 7: Optiona) Embod a iteractive Cytoscape.js widget
yeast_net_view = yeast_net get_frst_view()

Style._for_widget = y.style.get(my_yeast_stye.get_name(), ata_format='cytoscapeis)
Fenderer.cender(yeast.net_view, tyle-style_for -widget['style', background-adal radent (4FFFFFF 15%, #DDDDDD 105%)")






_images/HideSidebarLabels.png
ece ‘Session: /Applications/Cytoscape.v3.8.0/Cytoscape.app/../sampleData/sessions/Yeast Perturbation.cys.

> BB L QQQ z a

5T 0% 3B « N A

a A thatara )

o





_images/edge_types.png





_static/images/AppManager/AppManager.png
(EEELENEN Currently Installed  Check for Updates

App Manager

Download

: | http://apps.cytoscape.org/

Manage Sites...

Q

5 all apps (140)
25 collections (3)
5 apps by tag

Adj Exporter
AgilentLiteratureSearch
AllegroLayout

aMatReader

Anatapp

ANIMO

ARACNE

AutoAnnotate

bayelviraApp

BINGO.

BIOGRID Data Source (installed)
Biomart Web Service Client (inst
BioPAX Reader (Installed)
Bisogenet

BridgeDb

Install from F

View on App Store

Install

Close






_images/HelpMenu.png
search ()

User Manual
Video Demos

Tour

Tutorials

Automation >

Citations

Links for Help
Report a Bug

Check for Updates





_images/edbeBend1.png
L] Edge Bend Editor

1. Option-lick he edge to add a new handle
2. rag handles o bend (selct the edge irso.

Remove Bend Cancel oK





_static/images/Annotations/type_text.png
My Text Annotation





_static/images/Navigation_Layout/H_DIST_RIGHT.gif
a9






_images/ImageChart1-DefValue.png
&

Height

Image/Chart 1

Default Value: None 3






_images/ImageChart1-Add.png
| Solid

Properties ~

Border Line Type
Border Transparency
 Border Width
V Label
Label Font Face
V Label Font Size
Label Position
Label Transparency
Label Width
Nested Network Image Visible
Padding (Compound Node)

¥ Shape
Shape (Compound Node)
Size
Tooltip
V Transparency
Visible
X Location
¥ Location
ZLocation

Show All
Hide All

Make Default

Paint

 Border Paint

Custom Paint 2
Custom Paint 3
Custom Paint 4
Custom Paint 5
Custom Paint 6
Custom Paint 7
Custom Paint 8
Custom Paint 9

 Fill Color

V Label Color
Selected Paint

Image/Chart Position 1





_images/export_menu_38.png
Cytoscape

¢ Network

o Style

Y Filter

ation

Edit View Select Layout Apps Tools Help
Open... $0 Lo o :

Open Recent i Session: /Applications/Cytoscape_v3.8.0/Cytos
Save 8S

Save As... Q @ <

Close

New Network YORZEAW
| Q

Import

Collection to NDEXx...

Network to File...
Network to Image...
Network to Web Page...
Table to File...

oIt

Styles to File...





_static/images/Linkout/Figure2_linkout26.png
Properties

Cytoscape Preferences Editor

| linkout

outur|
outur|
outur|
outur|
outur|
outur|
outur|
outur|
outur|

Property Name
edgeli
edgeli
nodeli
nodeli
nodeli
nodeli
nodeli
nodeli
nodeli

.Ontology.Molecular Interaction (PSI...
.Publications.Pubmed (search by Pub...
.Array Experiments.ArrayExpress
\Array Experiments.GEO DataSets
.Global Database Search.EBI

.Global Database Search.NCBI

.Model Organism DB.FlyBase (fly)
.Model Organism DB.HGNC (human)
.Model Organism DB.MGI (mouse)

nodeli

outur|

.Model Organism DB.SGD (yeast)

nodeli

nodeli

outur|
outur|

.Model Organism DB.WormBase (wor ...
.Ontology.Gene Ontology (QuickGO ...

Value

http://www.ebi.ac....
http://www.ncbi.nl...
http://www.ebi.ac....
http://www.ncbi.nl...
http://www.ebi.ac....
http://www.ncbi.nl...
http://flybase.bio.i...
http://www.genen...
http:/ /www.inform...
http://db.yeastgen...
http://www.wormb...

http://www.ebi.ac....

| Add | | Modify | | Delete |






_static/images/Preferences/Preferences_opencl.png
0 OpenCL Settings

Preferred Device: OpenCL 1.2 lIris Pro A

| Cancel | [ oKk |






_static/images/Preferences/Preferences_groups.png
[ BON ] Group Preferences

Group View Settings

Double-Click action: Expand/Contract %

a

Visualization for group: | Show Group Node 7|

Show collapsed node as a Nested Network: [ |

Attribute Aggregation Settings

Enable attribute aggregation: | |

P Default Aggregation Settings
P Aggregation Overrides

Cancel “——.K—\






_images/column-list.png
. Node: attributes

any element contains,





_static/images/Annotations/layers.png





_static/images/Merge/AdvancedNetworkMerge.png
[ ] Advanced Network Merge

_ @) Intersection @) Difference

Available Networks: Networks to Merge:

galFiltered.sif
Principle Pathways of Carbon Metabolism - ¢

P Advanced Options

Cancel





_static/images/ProgrammaticAccess/CommandAPI.png
000 @ localhost:1234/v1/commands X +

& C (@ localhost:1234/v1/commands ﬁ’) +F 80w @ e

Available namespaces:
analyzer
apps
command
cybrowser
cychart
diffusion
edge
filter
group
idmapper
layout
network
node
session
table
view

vizmap






_static/images/Annotations/group_layers.png
& Style  «& Network

Y Filter

[T] Annotation

E.. Layout Tools

Annotation ~ 8

T W & A
Select the Annotation you want to add...
0 of 14 Annotations selected
Foreground Layer
v BB ribonucleoprotein complex organization
T label1
T label 2
v BB ncrnaprocess rna
T label1
v BB mitochondrial trna aminoacylation
T label1
T label 2

Background Layer

v BB mitochondrial trna aminoacylation
7 cluster shape

v BB ribonucleoprotein complex organization
7 cluster shape

v BB ncrnaprocess rna

7 cluster shape

Select All

<

co mplex organization

mitochondrial trna
aminoacylation

N .
ribonuclecprotein

estrogen_treatment_12hr_gsea_enrichment_results(1)





_static/images/Linkout/Figure3_linkout26.png
Add

Diffuse

Edit

Select

Group

Nested Networks

vV VVvVVvVYVYVYVYY

Apps

External Links >

Preferences 4

Array Experiments
Global Database Search
Model Organism DB
Ontology

Pathway Databases
Publications

Sequences and Proteins
Structure Databases
Web Search

yeast

A/ V VVVVYVVYVYYVYY

sgd






_static/images/Preferences/Preferences_proxy.png
[ ] Proxy Settings

Options

Proxy Server:
Port:
User Name:

Password:

OEO0

Cancel E





_images/GradientEditorSample26.png
() Continuous Mapping Editor for Node Fill Color

< v v v

3.0000 100000 16.0000
win Degree v

Edit Handle Positions and Values

Handle Position: 10 © Set Min and Max... Add Delete

Node Fill Color: [__]






_images/column-string.png
. Node: name
yoL19|






_static/images/Annotations/modify_menu.png
& Network

o style

Y Filter

[T Annotation

Annotation ~

Select the Annotaton you wan to 3dd.
=] 2.0f 8 Annotatons selected
Foreground Layer

T Tex

1) Shape 2

1 Shape 1

T My Text Annotation

Boundeg
Modify Annotation.

Bring Annotations to Front
Send Annotations to Back

Push Annotations to Background Layer

v 4





_static/images/Navigation_Layout/H_ALIGN_CENTER.gif





_static/images/ProgrammaticAccess/CytoscapeAutomation_3.png
http://localhost:1234/v1/
networks/{SUID}/nodes

Commands

node list network=current

#{ Cytoscape






_images/FunctionBuilder2.png
@ Create Function For: gal1RGexp
Functions

[ABS Returns the absolute value of a number.
ACOS Call with ABS(number).

AND

ASIN

ATAN2

AVERAGE

COMBIN

CONCATENATE Next Argument:

Eg; AverageShortestPathLength
COUNT

DEGREE

DEGREES

ERROR

(a)

Apply to:  Current cell only

©

Add

©

Cancel





_images/column-numeric.png
. Node: galgORexp
between  1.092 and

3.126 inclusive.

o

o





_static/images/Annotations/legend.png
o Style & Network

Y Filter

[T] Annotation

E.. Layout Tools

Annotation ~ 05 -

T @ ® @ 2

Select the Annotation you want to add...

I;_I'I 2 of 9 Annotations selected @
Foreground Layer
v B> Legend
T Legend ] | |
T Downregulated
T Signature Legend
T Upregulated
gﬁ) Blue - Upregulated
7 Red -
% Yellow Downregulated
v 4
Background Layer - Signature
] u

Select All Select None HH E" ':::'

oo





_static/images/Merge/AdvancedNetworkMergeOptions.png
w Advanced Options

Matching Columns (table columns to match nodes between networks):

galFiltered.sif
name

How to merge columns:

galFiltered.sif

name
AverageShortestPathLength
BetweennessCentrality
COMMON
ClosenessCentrality
ClusteringCoefficient
Degree

Eccentricity

Enable merging nodes/edges in the same network

Merged Network
Matching.Attribute
AverageShortestPathLength
BetweennessCentrality
COMMON
ClosenessCentrality
ClusteringCoefficient
Degree

Eccentricity

Column type
List<String>
Double
Double
String
Double
Double
Integer
Integer

Cancel






_static/images/ProgrammaticAccess/CommandTool.png
0 Command Line Dialog

Reply Log:

Clear

Commant:





_images/GroupCollapsed2.png





_images/cose_layout.png





_static/images/Annotations/type_arrow.png





_static/images/Navigation_Layout/H_ALIGN_RIGHT.gif





_static/images/ProgrammaticAccess/automation_menu.png
Search | | L

User Manual
leo Demos.
Tour
Tutorials
Automa

CYREST AP
CYREST Command API

Citations Automation Examples

Links for Help.
Report a Bug

Check for Updates





_images/GreenWhiteGradient.png
10000 180000
Degree





_images/copycat.png
° Set Parameters

Source network view _ galFiltered.sif

Source network node column  name

Target network view | BINDyeast

Target network node column  name

After Layout

Select unmapped nodes

Layout unmapped nodes in a grid

conce (ORI





_static/images/Annotations/selected.png





_static/images/Navigation_Layout/H_ALIGN_LEFT.gif





_static/images/ProgrammaticAccess/FunctionAPI.png
[ JON ] @ localhost:1234/v1/ X +

& C @ localhost:1234/v1/ * 4 80w @ e :

{"allAppsStarted":true,"apiVersion":"v1l", "numberOfCores":8, "memoryStatus":
{"usedMemory":970, "freeMemory":1077, "totalMemory":2048, "maxMemory":15568}}





_images/cgTutorial4.png
ece Image Manager

Image
Saccharomyces_cerevisiae...

Name: scape_3/UserManual/StylesZactios

AttachFile&do=get&target

ampleimage.png

Tags:  bitmap image

Actual Size View:

Triticum_aestivum_L.png

Triticum_aestivum_NL.png

Width: 60 Height: 60 [ Aspect Ratio nal Search

Close






_static/images/Annotations/button_trash.png





_static/images/Launching_Cytoscape/Welcome_36.png
00 Session: New Session

=R LE RAQQQ 2
- < B =~
Control Panel v Ox Welcome to Cytoscape

'!Em’ Style | Select |

(}f)v Enter search terms for NDEXx... Q = ; :
Y A Fo Eak i/ g2
S

Affinity Purification Ivacaftor Coauthor Styles Demo TCGA Colorectal Can... Yeast Genetic Interac... Yeast Perturbation

Tutorials

Table Panel v Ox

\ee28Ele)l=] Edge Table | Network Table \

& (-] @ Memory






_static/images/Preferences/Preferences_bookmarks.png
o Bookmark Manager
Bookmarks

network

D. rerio

C. elegans

Yeast Protein-Protein: Ideker, T. et al. (362 Interactions, galFiltered.sif)
M. musculus

A. thaliana

Human Protein-Protein: Rual et al. (Subnetwork for tutorial)

D. melanogaster

\/ Add \ Modify Delete





_static/images/Styles/NodeShapeMapping.png





_images/cgTutorial-openCMEditor.png
Column

Mapping Type

Current Mapping

Image/Chart 1

Image/Chart 2

BetweennessCentrality

Continuous Mapping






_static/images/Annotations/button_group.png





_static/images/Launching_Cytoscape/Welcome_33.png
Session: /Users/kristinahanspers/Downloads/cytoscape-unix-3.4.0-SNAPSHOT/sampleData/galFiltered.cys

Y LS QRQAQQ ©

[ style | Select

-]

«
>

B »® T

L) Welcome to Cytoscape

Start New Session

[ i Enpry eowor

L romnenorke

S From Nevork Database..

m BT | (i B
W e A bsapiens
o s || O s caensiae

About Cytoscape.

™ Don't show again

Open Recent Session
- Sample Yeast Network

- galFiltered.cys

- Metscape_expanded metab lst.cys

Open Session Fle...

Latest News

A\ Thisis 2 pre-release version of Cytoscape.

Mar 28: Cytoscape Challenge winners @
http://tinyurl.com/jgmnkt

New Users: See:
tutorials @ htp://bit.ly/1AbyA3n
slides @ http://bit.ly/1Fpst0A

Documentation  Tutorials ox
[PTEREO Edge Table | Network Table
@ Memory.






_static/images/Preferences/Preferences_Linkout.png
[ ] Cytoscape Preferences Editor

Properties
| linkout :
Property Name Value
Linkout.externalLinkName Linkout.ExternalLinks

edgelinkouturl.Interaction Databas... http://www.ebi.ac.uk/intact/intera...
edgelinkouturl.Ontology.Molecular... http://www.ebi.ac.uk/ontology-loo...
edgelinkouturl.Publications.Pubme... http://www.ncbi.nlm.nih.gov/pub...

nodelinkouturl.Array Experiments.... http://www.ebi.ac.uk/arrayexpress...
nodelinkouturl.Array Experiments.... http://www.ncbi.nlm.nih.gov/gds/...
nodelinkouturl.Global Database Se... http://www.ebi.ac.uk/ebisearch/se...
nodelinkouturl.Global Database Se... http://www.ncbi.nim.nih.gov/gque...
nodelinkouturl.Model Organism DB... http://flybase.bio.indiana.edu/.bin...
nodelinkouturl.Model Organism DB... http://www.genenames.org/data/...

nodelinkouturl.Model Organism DB... http://www.informatics.jax.org/jav...
nodelinkouturl.Model Organism DB... http://db.yeastgenome.org/cgi-bi...

nadalinkauturl Madal Oraanicm DR __httn: [ hassasonarmhaca araldh loon

| Add | Modify Delete

| Close |





_static/images/Styles/NodeShape.png
style - -

default - =

Properties ~ v
Def. Map. Byp.

[ ] Border Paint “«

0.0 Border Width “«

[ | Fill Color o o Node Shape

\
300 Height
Image/Chart 1 O i

Label B Parallelogram

Label Color
Rectangle
Label Font Size
Shape Round Rectangle
size
A Triangle
255 Transparency
width \VA'

Lock node width and height Cancel

Edge  Network





_images/cgTutorial6.png
Position

Node Anchor Points:

Object Anchor Points:
Label Justification:
X Offset Value (can be negative):

Y Offset Value (can be negative):

Northwest o
South o

Center Ju:

ied

Cancel






_static/images/Annotations/button_up.png





_static/images/Linkout/Figure1_linkout_Cy3.png
Add

Diffuse

Edit

Select

Group

Nested Networks

Apps

External Links
Preferences

VR V VVVYVYVYVYVYY

Array Experiments
Global Database Search
Model Organism DB
Ontology

Pathway Databases
Publications
Sequences and Proteins
Structure Databases
Web Search

FlyBase (fly)
HGNC (human)
MGI (mouse)
SGD (yeast)
WormBase (worm)

VVVVVYVYRAAVY






_images/cgTutorial5.png
Continuous Mapping Editor for Node Image/Chart 2

Min=0.0

oz

BetweennessCentrality

Edit Handle Positions and Values

Handle Position:

0 Set Min and Max...

Add

Delete

Double-click on icon to change Node Image/Chart 2.

Cancel






_static/images/Annotations/button_ungroup.png





_static/images/Launching_Cytoscape/Welcome_38.png
x
=
S
Z
3
=
v

& Style

Y Filter

=
g
5
o
=
|
<

E.. Layout Tools

(f)v Enter search terms for NDEX...

a

2

Q
£

Session: New Session

Recent Sessions

Sample Sessions

Affinity Purification

Node Table ~

[ql

Welcome to Cytoscape

Yeast Perturbation.cys

ndexbio.org

Yeast Perturbation Styles Demo Yeast Gene Interactio... Import & Save

S

=

TCGA Colorectal Can...

Tutorials News

B§ Node Table 3 Edge Table

Ivacaftor Coauthor

2 Network Table





_static/images/Preferences/Preferences_cy3.png
[ ] Cytoscape Preferences Editor

Properties

| cytoscape 3

Property Name
appStoreDownloadSiteCount
appStoreDownloadSiteNamel
appStoreDownloadSiteUrl1
canonicalizeNames
cytoscape.version.number
defaultVisualStyle
directory.last
exportTextAsShape
hideWelcomeScreen
layout.default

proxy.server

lnraviz carvar nart

Value

1

Cytoscape App Store
http://apps.cytoscape.org/

true

3.4.0-SNAPSHOT

default
/Users/kristinahanspers/Downloa...
true

false
force-directed
maximizeViewOnCreate false
| Add | Modify Delete






_images/column-boolean.png
is

“ Node: isExcludedFromPaths

wue





_images/chain-filter1.png
Default chain

Start with 3
My filter 1

+ My filter 2
Default filter

© select  show
Apply

Filter





_static/images/Annotations/button_up_2.png





_static/images/Command_Tool/RunScriptCommands.png
ece Run Script File

Script File Name:  Please select a script file. [ 2= openFit...|

Select Script Type: | ECMAScript (Oracle Nashorn, Version ECMA - 262 Edition 5.1) & |

[ Cancel | (oK)






_static/images/Navigation_Layout/cose_layout.png





_static/images/Navigation_Layout/copycat.png
° Set Parameters

Source network view _ galFiltered.sif

Source network node column  name

Target network view | BINDyeast

Target network node column  name

After Layout

Select unmapped nodes

Layout unmapped nodes in a grid

conce (ORI





_images/MultipleNetworks_SidebySide.png
& Y Y
®-® galFiltered.sif 000 BINDyeast.sif 000 Statin Pathway View

g aaaa ¢ B aQaaQ g B AQAQAQA € 48 QAaQaQa g «






_images/ndex_save2.png
A - N o Emos I A~~~ _
(@0 @ Export Network to NDEx

a rudipillich@public.ndexbio.org | 4%

Name: My New Network
Author
Organism

Disease .

W Cils,

Tissue

Rights Holder

Version
5 poaw
E Reference
Description
gall
Update Existing Network @
Cancel . Export Network to NDEx_

Too)="

7 Yor277¢C





_static/images/Creating_Networks/AddEdgeMenu.png
—

Edit Edges Connecting Selected Nodes
Select
Group
Nested Networks

Apps

External Links
Preferences

YY VY vvvy





_static/images/Navigation_Layout/force_layout.png





_images/ndex_save1.png
P TR TOPPR

-

[ FOF NP

' Too'

Name:

Author

Organism

Disease

Tissue

Rights Holder

Version

Reference

Description

Cancel

My New Network

Update Existing Network

GW

|2oaw

galFi

" YDR277C
YBRO43C





_static/images/Creating_Networks/AddEdge-2.png





_static/images/Navigation_Layout/edbeBend1.png
L] Edge Bend Editor

1. Option-lick he edge to add a new handle
2. rag handles o bend (selct the edge irso.

Remove Bend Cancel oK





_images/NNFExample1_2.png
network 1 8086 Example_1

network1






_images/ndex_toolbar_button.png
LXK ) Session: /Applications/Cytoscape v3.8.(

> sl Ly @QQo o
& Import Network from NDEx (= .
4 Export Network to NDEx DEx.. Q [
v A 10f 1 Network selected &
v galfiltered.sif 1
= galFiltered:sif 330 359
>

]





_static/images/Creating_Networks/AddNodeMenu.png
Edge (and possibly Nodes) using SIF.

Delete >
Edit » | Arrow Annotation
Select > Image Annotation
Group  » | Shape Annotation
Text Annotation
Apps > | Bounded Text Annotation

I —————
Preferences »





_static/images/Navigation_Layout/group_by_attributes_layout.png





_images/MultipleNetworks_VerticalStack.png
[ X X J galFiltered.sif

_J'" - -

w : - — h -

.y -
s - s
X | galFiltered.sif | 0-0 @ 0-0 | (:)'

2 AQAQAQ ¢ Mo ®

X | BINDyeast.sif

2 AQAQAQ ¢ Mo ®

: X | Statin Pathway View
S AQQQ & s @

X | Apoptosis View | ”0—0|®0-0 |'€)-






_images/ndex_save_done.png
4 Stule  «® Netwnrk

Y Filter

[T] Annatatian

ools

Name: galFiltered.sif
Author

Organism

Disease

Tissue

Rights Holder

Version

Reference

Description  test for RC4

Cancel

Update Existing Network

rudipillich@public.ndexbio.org  asw

Export Complete

Export to NDEx successful.

YURKSLZW

YR 00w

5RP1

PHO1E

PHOBS

SEC9

2

UUID: 0e9b1728-6d8e-11ea-bfdc-0acl35e8bacf

TAH1I

galFiltered.sif I

C

Export Network to NDEx

TULLYSW

YDR277C

4k

name Average.

YDL194W
YDR277C





_static/images/Creating_Networks/AddNetworkAnnotations.png
Edge (and possibly Nodes) using SIF...

Delete » Node
Edit > Arrow Annotation
Select » | Image Annotation
Group > Shape Annotation
Text Annotation
Apps > Bounded Text Annotation

Preferences





_static/images/Navigation_Layout/grid_layout.png





_images/NNFExample3_2.png
M1

M2

Example_3

M3

M3

M1





_images/network_export_dialog.png
LXK ] Export Network

Select the export file format: | SIF (sif) c

Save Network as: /Users/thully/Desktop/galFiltered sif.sif Browse..





_static/images/Creating_Networks/Cy3_network_table_sample2.png
e e Import Network From Table

Network
Network Collection: | -~ Create new network collection -- %
Preview
Click on a column to edit it. Select All Select None
@source  « @target ¢ Pineracton ¢ [Hdirected ¢ [ symbol ¢ Bw
YKRO26C YGL122C PP false abcd12345
YGR218W YGLO97W PP true abcd12346
YGLO97W YOR204W L true abcd12347
YLR249W 'YPROBOW PP true abcd12348
YLR249W YBR118W PP true abcd12349
YLR293C YGLO97W L true abcd12350
YMR146C 'YDR429C L true abcd12351

Advanced Option:

Cancel | [ 0K |





_static/images/Navigation_Layout/layout_settings_dialog.png
Layout Settings

Layout Algorithm:

| Prefuse Force Directed Layout (default)

Edge column that contains the weights:
Edge Weight Settings

How to interpret weight values:
The minimum edge weight to consider:

‘The maximum edge weight to consider:

The default edge weight to consider:

Number of Iterations:
Default Spring Coefficient:
Default Spring Length:
Default Node Mass:

Force deterministic layouts (slowen):

Standard Settings

Don't partition graph before layout:

Layout only selected nodes _Reset Defaults

(none)

Heuristic
OO0
1.79769E308.

05

100
1E-4
50

3

Done





_images/NNFExample2_2.png
M1

8006 M2

Example_2

M1






_images/ndex_toolbar_button1.png
000 Session: /Applications/Cytoscape_v3.8.(

> BRA Wi AQQ c

& Import Network from NDEx 0O -
4 Export Network to NDEx DEX... Q woRze
v A 1 of 1 Network selected o)
Vv galFiltered.sif 1
< galFiltered.sif 330 359
a
\9

Filter





_static/images/Creating_Networks/Cy3_icon_net_file_import.png
AF





_static/images/Navigation_Layout/image049.png
QA





_images/NestedNetwork2.png
Levell.l

Levell.2

Levell.3





_images/plotHistogram.png
88 B n ?

NodeTable +
« BB 5B

sennessCentraly Degree Closenes

o1 ’

013 Delete Column

012 Hide Column

0% Vap column.

008 Plot Histogram.

0.06 Plot Scatter...

0.01 Rename Column...

004 5

004





_static/images/Creating_Networks/GroupExpanded2.png





_static/images/Navigation_Layout/rotate_networkA.png
Align and Distribute | Scale

O
o %0

(¥ Rotate Selected Nodes Only






_images/NNFExample4_2.png
M1





_images/open_cl_settings.png
4 OpenCL Settings

Preferred Device: Openci. 1.2 CUDA GeForce GTX 960.






_static/images/Creating_Networks/GroupCollapsed2.png





_static/images/Navigation_Layout/rotate_dialog.png
ece Tool Panel

[ Align and Distribute

Degrees

%0 180

M Rotate Selected Nodes Only






_images/MultipleNetworkView.png
eoe
4, ¥
o BRA ¢
o Sle -
£ default
z
v
2
z Border Paint
A
4.0 Border Width
: @ Fill Color
¥ a0 Height
g Image/Chart 1
2 B Label
2
E J Label Color
& 12 Label Font
g D Shape
H
g Size
<
8 =5 Transparency
700 th
Lock node width and height
8
5
o (L Edge  Network

Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app]../sampleData/sessions/Affinity Purification.cys

=

e

HIV-human PPI

galFiltered:sif

Node Table ~

« BB
shared name

"kRoZ6C

vauz2

vaRz18w

vaLosrw

voRz0aw

(=)

GraphiD

ab

Xrefld

XrefDatasource

Tot4 Views seleced @
Type sGPMLShape Width Height FillColor
&3 Node Table T Edge Table

Color

& Network Table
E ]





_images/ndex_context_menus.png
> BA LY AQAQ

¢ Network

o Style

Y Filter

m Annotation

Network ~

qé’). Enter search terms for NDEXx...

A 1 of 1 Network selected
Vv galFiltered.sif
galFiltered sif

Destroy 1 View
Destroy Network
Rename Network...

Clear All Edge Bends
Apply Style...

Export Network to NDEX...

Export as Network...
Export as Image...

~
[ =4

0 % -

Q
]

1
330 359

Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app/

¥CRO.
FORZGEAW

502

SMC1
DIt

SNE2

M5H5

VEA2D

01

ACS2





_static/images/Command_Tool/AutomationPanel.png
Command Line ~

Clear

Command:

<





_images/MultipleEdgeMapping.png





_images/modify_menu.png
& Network

o style

Y Filter

[T Annotation

Annotation ~

Select the Annotaton you wan to 3dd.
=] 2.0f 8 Annotatons selected
Foreground Layer

T Tex

1) Shape 2

1 Shape 1

T My Text Annotation

Boundeg
Modify Annotation.

Bring Annotations to Front
Send Annotations to Back

Push Annotations to Background Layer

v 4





_static/images/Columns/table_webservice_final.png
Node Table ~

s« 0B B
shared name
VoL19Aw
Yora77e
varosac
VeR1ssw
VERosac
YaRoasc
VaLo7ow

name
YDL194W
YDR277C
YBRO43C
YPRI4SW
YEROS4C
YBRO45C
YBLO79W
YIR34SW.

4B

Degree

COMMON PDBID.
SNF3

MTHL

YBRO43C

ASNL

a2

a1

NUP170 315p
YIR34SW.

pfam 1D
PFO0083
PF17235

PF13537
PF03370

PFO8801

3 Node Table

 Edge Table

2 Network Table





_static/images/Navigation_Layout/bundle2.png
ece Set Parameters

Number of handles: | B/

Spring constant: 0.003

threshold 03!

Compatabi

Maximum iterations: 500

e | [0






_images/MultipleNetworks_Grid.png
BINDyeast.sif

5 R e @

TN

/

|“ 0-0 @ 0-0 | '(:)' | BINDyeast.sif

p § | Apoptosis View

B0-0 @0-0 €

p § | Statin Pathway View | 0-0 @ 0-0 p § | galFiltered.sif






_images/MultipleNetworks_Cascade.png
,
CXCX ) Apoptosis View

000 BINDyeast.sif

@00 galFiltered.sif

é’ﬁﬁ'?aa@.@.ée;m@@

< -mmme-






_images/ndex_find_networks.png
PP RN VU R U TN W0 WO

o Stvle  «& Network

Y Filter

[T] Annotation

<> NDEx

brcal

Results

YOOOOOOOOO®

name
Extended Network of human ESRRA

Fanconi Anemia Gene Ontology (FangO)

WP4262 - Breast cancer pathway - Homo sapie...
WP138 - Androgen receptor signaling pathway...
WP138 - Androgen receptor signaling pathway...
TCGA-READ [miRNA vs RNA] GO: mitotic cell c...
TCGA-HNSC [miRNA vs RNA] GO: cell cycle [20...
TCGA-LUAD [miRNA vs RNA] GO: mitotic cell c...
TCGA-ACC [miRNA vs RNA] GO: mitotic cell cy...

TCGA-LIHC [miRNA vs RNA] GO: mitotic cell cy...

~

Find Networks

My Networks

owner
cyrilb
mikeyu
wikipathways
wikipathways
wikipathways
ucsdccbb
ucsdccbb
ucsdccbb
ucsdccbb
ucsdccbb

visibility nodes
PUBLIC
PUBLIC
PUBLIC
PUBLIC
PUBLIC
PUBLIC
PUBLIC
PUBLIC
PUBLIC
PUBLIC

347
142
308
302
302

99
133
162
176
226

edges

1156
192
78
122
122
107
190
329
681
646

rudipillich@public.ndexbio.org

Q

modified
11/5/18,4:43 AM
3/24/17,12:31 PM
12/16/19, 1:45 PM
12/16/19,11:48 AM
12/16/19,11:56 AM
7/14/17,1:42 PM
7/14/17,1:33 PM
7/14/17,1:38 PM
7/14/17,1:24 PM
7/14/17,1:38 PM

WARNING: In some cases, not all network information stored in NDEx will be available within Cytoscape after loading.

BRCAL1 (Activation) erl...
BRCA1 (Activation) AP...

Activation
Activation

Close Dialog

1

IVAIT R 111

=TNMNA N

leraction
tion
tion
tion

_tion

BRCA1 (Acti...  Activation
BRCA1 (Acti... Activation





_static/images/Navigation_Layout/V_DIST_BOTTOM.gif





_images/histogramFooter.png
50

a0

30

20

0

Degree

[0 tog v |

AverageShortestPathLength

BetweennessCentralit

ClosenessCentrality
330 359

ClusteringCoefficient
 Degree
Eccentricity
NeighborhoodConnectivity
NumberOfbirectedEdges
NumberOfUndirectedEdges
PartnerOfMultiEdgedNodePairs

Radiality





_static/images/Columns/TablePanel_withData.png
Edge Table ~
« 006 @

shared name

RANBP9 (pp) KRAS
RANBP9 (pp) ATM
RANBP9 (pp) SRC
RANBP9 (pp) STXBP4
RANBP (pp) HRAS
ARHGEF5 (pp) SRC

pp
pp
pp
pp

pp
[o]e]

abk

shared interaction

name

RANBP9 (pp...
RANBP9 (pp...
RANBP9 (pp...
RANBP9 (pp...
RANBP9 (pp...
ARHGEFS5 (p...

pp
pp
pp
pp

pp
[o]e]

interaction

stringd
score

b

0.903
0.633
0.484
0.438
0.905
0.714

stringdb
interspecies

F§ Node Table

®  stringdb ®  stringdb
textmining databases

0.057

0.433

0.169

0.438

0.073

0.54

B3 Edge Table 2 Network Table





_static/images/Navigation_Layout/V_DIST_TOP.gif





_static/images/Columns/TablePanelNamespace.png
Node Table ~ 05 -

- [ A
I N I ) Sl -3
o aid ab & ® stringdb ® stringdb ® stringdb

display name ab
€ compartment narze Y 3B e full name database identifier description @id
9606.1 & stringdb uaRterm ab 9606.ENSP00000356150  Mdm2-like p53-bin... stringdb:
9606.; O target QANRAY yin 9606.ENSP00000424328 Mitochondrial ribo...  stringdb:
9606.1 @ tissue shared name ab 5 9606.ENSP00000336701 DNA repair protein ...  stringdb:
9606.1 SUID 123 9606.ENSP00000358576 DNA cross-link rep...  stringdb:
9606.1 9606.ENSP00000234198 Distal-less homeob...  stringdb:
9606.1 9606.ENSP00000451828 V-akt murine thvm...  strinadb:

|
Fg Node Table 5 Edge Table 2 Network Table

Select All Select None





_static/images/Navigation_Layout/V_DIST_CENTER.gif





_images/LinkRightClick.png
Copy link location
Open in new window
Openin new tab

Download to file





_images/image_export_dialog.png
Export as Image

e e
Select the export file format: |_PNG (*.png) 9

Save Image as: /Users /thully/Desktop/galFiltered.sif.png

Image Size
Zoom 06) v 1008
o s oo
Units | pixels
Width 889
Height: 385
72,

Resolution (DP):

Browse...





_static/images/Columns/attribute_table_import_alias.png
Allas?

Column (Attribute Name)

DataType

O Column 1 A String

Column 2 Ap String
& |Column 3 Ap string
O Columns4 £ Float
[ Columns £ Floa






_static/images/Navigation_Layout/V_STACK_LEFT.gif





_images/LineChartIcon.png





_images/idMapping.png
e o 10 Mapping.

Maprom _ Uniprov TewSL .. p62159 [

To Emembi 0. Enscoooooisses B
a

ance | EKED





_static/images/Columns/attribute_editor26.png
606 Node Attribute Batch Editor

(Toupper-case  [#] [canonicalName  [#) Convert to upper/lower case (GO )






_static/images/Navigation_Layout/V_STACK_CENTER.gif





_images/Minimal.png
= =
- g ;-
Sa R L =
=====:==== ==:i=== ,:H
=‘=| ==:=FE, :==1= =
! N =
=======:==g ¥ 2
=I§|=|=:=|=|==I‘='= &
-]
L el o
et o EN ===== ==
P_OF T CaeAfL o Ange
= = i====' === o
ez ® o °F8 TEe =
=4 ol S EE -
= ES N
== ===§:‘======:==
=" =:=== i=====?=
.= =s L
g S8 a =ca
==





_images/layers.png





_static/images/Columns/idMapping.png
e o 10 Mapping.

Maprom _ Uniprov TewSL .. p62159 [

To Emembi 0. Enscoooooisses B
a

ance | EKED





_static/images/Navigation_Layout/align_distribute_dialog.png
° Tool Panel
T Scale | Rotate

Align

[ S ] [@] [#] [Z
Distribute

w] @] @ F = =
Stack

[ & = P 1 L






_images/MappingValueGenerators.png
)

Column
Mapping Type
1
2
3

Fill Color

Edit »>
Degree Rainbow
Rainb
Discrete Mapping Hide Selected Visual Properties R:'r:'d::gnslcm

Fit label width (only works with 'name’ column to node size or width)

Number Series
Random Numbers





_images/jsWebSite.png
090 /% croscapess <\

€ & C f [ cytoscape.github.io/cytoscape.js/ b B, 8 ¢ =
Table of contents (W top) .
e Cytoscape.js ...
W About
R Cytoscape.js & Cytoscape A JavaScript graph library for analysis and visualisation (compatible with
N Funding CommonJS/Node js, jQuery 1.4+, and plain JavaScript)
M Downloads © GitHub | & Downloads | % Live code examples | ¥ Twitter | ? Previous
R20 questions | ® Ask a question | ¥ File an issue | £ Future version
M Roadmap milestones
W Notation This is how easy it is to get started with Cytoscape.js (this code creates
(Ao the instance you see on the bottom-right:
M Notation
W Position $(loadCy = function(){
W Elements JSON =
options = {
W Selectors showoverlay: false,
W Notes & caveats minZoom: 0.5, @ @
W Group, class, & ID maxZoom: 2,
M Data

style: cytoscape.stylesheet ()

Cor ind nod
[JEmrrinzies .selector ('node')
NS tate) css ({
'content': 'data(name)',
- Style 'font-family': ‘'helvetica',
¥
M Properties 'text-outline-width': 3,
AMappers W Show all the code.

‘stackoverflow.com/questions/askXtags=Cytoscape.js.





_static/images/Columns/attribute_table_import_keyattr.png
Key Attribute for Network

D

3 annotation Taxon
181 annotation.DB_Object_Name
13 canonicaiName






_static/images/Navigation_Layout/V_STACK_RIGHT.gif





_images/MinimizeIcon.png





_images/legend.png
o Style & Network

Y Filter

[T] Annotation

E.. Layout Tools

Annotation ~ 05 -

T @ ® @ 2

Select the Annotation you want to add...

I;_I'I 2 of 9 Annotations selected @
Foreground Layer
v B> Legend
T Legend ] | |
T Downregulated
T Signature Legend
T Upregulated
gﬁ) Blue - Upregulated
7 Red -
% Yellow Downregulated
v 4
Background Layer - Signature
] u

Select All Select None HH E" ':::'

oo





_static/images/Columns/table_webservice.png
[ ] @® Import Table from Public Databases

Data Source:  BioMart Client About
mart
service
Ensembl Genes 99 - Saccharomyces cerevisiae genes (R64-1-1)

Key Column in Cytoscape

Column: COMMON

DataType:  Gene Name(s) [e.g. SCO2]

Import Settings

PANTHER end  (hmmpanther_end)

PANTHER start (hmmpanther_start)
PDBID (pdb)

PHI-base accession ID  (phi)

PIRSF ID  (pirsf)

PIRSF end ~ (pirsf_end)

PIRSF start (pirsf_start)

PROSITE patterns ID ~ (scanprosite)

PROSITE patterns end ~(scanprosite_end)

PROSITE patterns start (scanprosite_start)

PROSITE profiles D (pfscan)

PROSITE profiles end  (pfscan_end)

Select All Select None

Concel (B





_static/images/Navigation_Layout/bundle1.png





_images/Minimize.png





_images/layout_settings_dialog.png
Layout Settings

Layout Algorithm:

| Prefuse Force Directed Layout (default)

Edge column that contains the weights:
Edge Weight Settings

How to interpret weight values:
The minimum edge weight to consider:

‘The maximum edge weight to consider:

The default edge weight to consider:

Number of Iterations:
Default Spring Coefficient:
Default Spring Length:
Default Node Mass:

Force deterministic layouts (slowen):

Standard Settings

Don't partition graph before layout:

Layout only selected nodes _Reset Defaults

(none)

Heuristic
OO0
1.79769E308.

05

100
1E-4
50

3

Done





_static/images/Columns/select_services.png
®  ©® select Services

Ensembl Genes 99
Ensembl Regulation 99
Ensembl Variation 99
Mouse strains 99

Select All





_static/images/Navigation_Layout/attribute_circle_layout.png





_images/JSON1.png
YGR085C

YLRO75W

YNLO69C

YDR395W

YPR102C

YDLO75W





_images/group_by_attributes_layout.png





_static/images/Columns/ShowColumns.png





_static/images/Navigation_Layout/V_ALIGN_TOP.gif





_images/ImportNetworkFromURL.png
[ 3o } Import Network

Import data from URL: Example:Yeast Protein-Protein: Ideker, T. et al. (362 Interactions, galFiltered.sif)

Cancel

<





_images/group2.png
©
n

Default filter

Match all (AND)
x Match all (AND)
x . Node: COMMON contains.
cde
x . Node: COMMON contains.
ste
+

X Degree I+ out s

between 6 and 26 inclusive.

€ Apply when filter changes
© select  show

Apply
Selected 0 nodes and 0 edges n 65ms

Chain





_static/images/Columns/NewColumn.png





_static/images/Navigation_Layout/V_ALIGN_CENTER.gif





_static/images/Quick_Tour/EditMenu.png
Q=GN View Select Layout Apps Tool:

Copy %C
cut %X
Paste vV
Undo %z
Redo ®Y

Create Views
Destroy Views
Destroy Networks:

Remove Duplicate Edges...

Remove Self-Loops...

Delete Selected Nodes and Edges ®»
Rename Network.

Bring Annotations to Front %)
Bring Annotations Forward %]
Send Annotations Backward 80
Send Annotations to Back o3[

Pull Annotations to Foreground Layer
Push Annotations to Background Layer

Preferences »





_images/Key.png





_images/histogram1.png
default network
Interactive || Regression

Degree

Degree < | [ ] Log mn: [ 3] Max B
31/ 330 are between 3.00 and 9.00






_images/JSON2.png
YGRO85C
YLRO76W

'YDR396W
YPR102C

YDLO78W





_images/group_layers.png
& Style  «& Network

Y Filter

[T] Annotation

E.. Layout Tools

Annotation ~ 8

T W & A
Select the Annotation you want to add...
0 of 14 Annotations selected
Foreground Layer
v BB ribonucleoprotein complex organization
T label1
T label 2
v BB ncrnaprocess rna
T label1
v BB mitochondrial trna aminoacylation
T label1
T label 2

Background Layer

v BB mitochondrial trna aminoacylation
7 cluster shape

v BB ribonucleoprotein complex organization
7 cluster shape

v BB ncrnaprocess rna

7 cluster shape

Select All

<

co mplex organization

mitochondrial trna
aminoacylation

N .
ribonuclecprotein

estrogen_treatment_12hr_gsea_enrichment_results(1)





_static/images/Columns/TableMode.png





_images/LayoutMenu37.png
Apps  Tools Help.
Bundle Edges >
Clear All Edge Bends
Node Layout Tools

Settings...
Apply Preferred Layout 3

Grid Layout
Hierarchical Layout
Circular Layout
Stacked Node Layout

Attribute Circle Layout >
Prefuse Force Directed Layout

Prefuse Force Directed OpenCL Layout

Degree Sorted Circle Layout

Group Attributes Layout >

Edge-weighted Force directed (BioLayout)
Edge-weighted Spring Embedded Layout

Compound Spring Embedder (CoSE)
Inverted Self-Organizing Map Layout

Install yFiles Circular Layout

Install yFiles Hierarchic Layout

Install yFiles Hierarchic Layout Selected Nodes
Install yFiles Organic Layout

Install yFiles Orthogonal Layout

Install yFiles Radial Layout

Install yFiles Tree Layout

Install yFiles Orthogonal Edge Router

Install yFiles Organic Edge Router





_static/images/Network_Formats/NNFExample1_2.png
network 1 8086 Example_1

network1






_static/images/Styles/CustomGraphics1.png





_static/images/Styles/ColorPassthrough.png
Border Paint

Border Width

Fill Color

Column color text

Mapping Type Passthrough Mapping

Image/Chart 1

Label
[ ] Label Color
12 it Label Font Size

O Shape

500 > size






_static/down.png





_static/images/Export/web_export_simple_dialog.png
ece Export as Cytoscape.js Web Page

Exportas: | Simple viewer for current network only

Export Networks and Styles as: |/Users /thully/Desktop/galFiltered.sif.zip Browse





_static/images/Network_Formats/NNFExample3_2.png
M1

M2

Example_3

M3

M3

M1





_static/images/Styles/CustomGraphics5.png





_static/images/Export/web_export_simple.png





_static/images/Network_Formats/NNFExample2_2.png
M1

8006 M2

Example_2

M1






_static/images/Styles/CustomGraphics4.png





_static/file.png





_static/images/Filters/after-diffusion.png
==

< Network

8 Legend Panel

o style

Y Filter

[TJ Annotation

D jActiveModules

L. Layout Tools

¥,

Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app/../sampleData/sessions/Yeast Perturbation.cys.

C.PHO4 GDCR1 ICLL a«a

ER L QAQQ © e
Network ~ o - w P
& - -
A 1of 1 Network selected
v calfiteredsit o‘ e~ @ ..
8 saffiteredsit 330 359 ®
GeR1

ccre

RosIC

wo LSM8,

Node Table ~

Res28

D @@
..

PEP12

wast

WL09W

ane

w284 ouc

safredsi

« BB

shared name name
viossc viossc
VaRoo7C VaRoo7C
voRosoc voRosoc
votosec votosec

L

W

ab
Averageshortestpathlenth
728629022
58225808
694354839

694354839

‘caLso GALLL

wsL1
HSP82. o
- STELL
® .
GAL4
oa

>
N Bl

BetweennessCentrality

prea0

ClosenessCentrality

-

diff..

Diffusion Output +
Node Selector

Range Column:

Node Rank:
T
1 83 165 247 329
Current Rank: 3 | Set

Create subnetwork from sel...

Visual Style:  [§ | Create

ClusteringCoefficient

(X} 0.13724405 00
000401593 0.10222589 00
0.0285648 0.14401858 00
0.0285648 0.14401858 00

B Node Table 73 Edge Table % Network Table

andino uoIsnyIa oo





_static/images/Network_Formats/NNFExample4_2.png
M1





_static/images/Styles/CustomGraphicsNodes2.png





_static/images/Export/web_folder.png
v [ web

v 3 full
@ 404.htmi
» [ bower_components.
2 favicon.ico
» [ images
© indexhtml
robots.txt
» [ scripts
> [ styles
> [ views
v [ simple
@ 404.html
4/ favicon.ico
© indexhtmi
| networkjson
robots.txt
» [ scripts
5 stylejson
» [ styles





_static/images/Network_Formats/NNFExample4.png
[ser=

B [ser=

-

(2 root

[ser=

B[ [ser=






_static/images/Styles/CustomGraphicsNodes.png





_static/ajax-loader.gif





_static/images/Export/styles_export_dialog.png
Export Styles

Select the export file format: |_Style XML (“xml) 2

Save Styles as:

Select Styles:

JUsers /thully/Desktop/styles.xml Browse...
Big Labels Select All

BioPAX

BioPAX_SIF Select None

Box

Custom Graphics Style
default
default black






_static/images/Network_Analyzer/NetworkAnalyzer_ConnectedComponents.png
[ ] Connected Components

Connected Components of galFiltered.sif:

Component 1 (249)
Component 2 (7)

Component 3 (5
Component 4 (5
Component 5 (5
Component 6 (5
Component 7 (4
Component 8 (4

| Cancel | Extract





_static/images/Styles/Bundling.png





_images/zoomicons.png
QA QK





_static/images/Export/network_export_dialog.png
LXK ] Export Network

Select the export file format: | SIF (sif) c

Save Network as: /Users/thully/Desktop/galFiltered sif.sif Browse..





_static/images/Network_Analyzer/NetworkAnalyzerResultsPanel.png
Analyzer ~ -
‘Summary statistcs o the network.

Node specificstatistics are found in the node table,
and Edge Betweenness is added to the edge table.

Fil Jedit 1 (undirected)

Number of nodes 419
Number of edges 1089
Connected components 1
Analysis time (sec) 0.162

Show Node Degree s

Show Betweenness by Degree

Show Closeness Graph





_static/images/Styles/BoxChartIcon.png





_static/comment-bright.png





_static/images/Export/web_export_full.png
006 Cytoscape Session Viewer
< > | [D)[2] [ +]6 fie:///users/kono/Desktop/web session¥205findexhtmi#/ ¢

galFiltered sif

Show/hidejtable browser,

—

Show/hide toolbar:
e

2

Minimal 4 . .
i/hide selectors
-
preset = ¢
Set background/color: O
Nods Table Browser- Edge
SuiD id shared_name selected SuiD narr
e s e
P P s P
P P o s P e
P P - s P
e e s e

s s VEROTAW P s Yerd





_static/images/Network_Analyzer/Screen Shot 2020-01-17 at 1.37.00 PM.png
Analyzer ~ -
‘Summary statistcs o the network.

Node specificstatistics are found in the node table,
and Edge Betweenness is added to the edge table.

Fil Jedit 1 (undirected)

Number of nodes 419
Number of edges 1089
Connected components 1
Analysis time (sec) 0.162

Show Node Degree s

Show Betweenness by Degree

Show Closeness Graph





_static/images/Styles/C2DEditor26.png
L) Continuous Mapping Editor for Node Shape

v

v

)

©)

Min=10

i)

Edit Handle Positions and Values

Degree

Handle Position: 8 Set Min and Max...

s o000

Add Delete

Double-click on icon to change Node Shape.






_static/images/Export/table_export_dialog.png
LXK ] Export Table

Select the export file format: SV (.csv) &

Select a table to export default edge 9

Save Table as: /Users/thully/Desktop/galFiltered.sif default edge.csv. Browse.





_static/images/Network_Analyzer/NetworkAnalyzer_VisualizeParameters.png
Map Node Size to:

NetworkAnalyzer - Visualize Parameters

Apply styles to galFiltered.sif

(o) Low values to small sizes

() Low values to large sizes

Map Edge Size to:

(o) Low values to small sizes

() Low values to large sizes

M;

M;

ap Node Color to:

(o) Low values to bright colors

() Low values to dark colors

lap Edge Color to:

(o) Low values to bright colors

() Low values to dark colors

Cancel

Apply





_static/images/Styles/C2CEditor26.png
ece Continuous Mapping Editor for Edge Width

v v v
o
£ 10
H f
Min=2.0 100
N i00oms 7
EdgeBetweenness Max=19180.22220002-
i Handie Posiion and Values
Handle Position: 11,300] Set Min and Max... Add Delete

Edge Width: 102






_static/comment.png





_static/images/Export/web_export_full_dialog.png
ece Export as Cytoscape.js Web Page

Exportas: | Full web application

Export Networks and Styles as: /Users/thully/Desktop/galFiltered.zip Browse





_static/images/Network_Formats/JSON2.png
YGRO85C
YLRO76W

'YDR396W
YPR102C

YDLO78W





_static/comment-close.png





_static/images/Export/web_export_full2.png





_static/images/Network_Formats/JSON1.png
YGR085C

YLRO75W

YNLO69C

YDR395W

YPR102C

YDLO75W





_static/images/Styles/ColorGradient.png





_static/down-pressed.png





_static/cytoscape3-icon-trans-128x128.png





_static/images/Export/web_export_fullexport.png
©® © ® 4 oyNotsharo: an casy way  x

€ = C | [ cynetshare.ucsd.edu/#/https %253A%252F %252F www.dropbox.com%252F s %252Fivicga6383inj59%252F TCA%252520Cycle.cyjs %253F dI%253D 1

Network:

Mitochondrion

TCA Cycle s

Visual Style:

Degradation of Fatty Acid

letabolism of amino acid:

Glucose metabolism|

WikiPathways

xaloacetate

IMDH2] HADH

S)-malatd

FH /ater

fumarate

SDHA

SDHB

SDHC

SDHD

SUCLG{

SUCLG2

citrate

uccinyl-Cok

Fatty Acid Synthesis
=

[ACO2]

water

lis-aconitate

OGDH

DLST

DLD






_static/images/Styles/BarChartsNetwork_6_3.png
©ooooooNE =<

Node Table ~

« 0B @

NumberOfDirectedEdges

fz) B B

NumberOfundirectedEdges

Radiality
046774,
050462,
0.66666.
10
0.66666.
083333,
083333,
083333,
0.66666.

Table Panel

TopologicalCoefficient
00
033333333
00
0o
0o
10
10
10
00

Bet
Bet.
Bet.
Bet.
Bet.
Bet
Bet.
et

Cent.
Cent.
Cent.
Cent.
Cent.
Cent.
Cent.
Cent.

domain_labels

Cent,] lust.
Cent, Clust.
Cent, Clust.
Cent, Clust.
Cent, Clust.
Cent, Clust.
Cent, Clust.
Cent. Clust.

Coeff)
Coeff)
Coeff)
Coeff)
Coeff)
Coeff)
Coeff)
Coeff)





_static/images/Export/ndex_save_done.png
4 Stule  «® Netwnrk

Y Filter

[T] Annatatian

ools

Name: galFiltered.sif
Author

Organism

Disease

Tissue

Rights Holder

Version

Reference

Description  test for RC4

Cancel

Update Existing Network

rudipillich@public.ndexbio.org  asw

Export Complete

Export to NDEx successful.

YURKSLZW

YR 00w

5RP1

PHO1E

PHOBS

SEC9

2

UUID: 0e9b1728-6d8e-11ea-bfdc-0acl35e8bacf

TAH1I

galFiltered.sif I

C

Export Network to NDEx

TULLYSW

YDR277C

4k

name Average.

YDL194W
YDR277C





_static/images/Network_Analyzer/AnalyzerResultsPanel.png
Analyzer ~ -
‘Summary statistcs o the network.

Node specificstatistics are found in the node table,
and Edge Betweenness is added to the edge table.

Fil Jedit 1 (undirected)

Number of nodes 419
Number of edges 1089
Connected components 1
Analysis time (sec) 0.162

Show Node Degree s

Show Betweenness by Degree

Show Closeness Graph





_static/images/Styles/BarChartsNode_6_2.png
BetweennessCentra..ClosenessCentralityClustering CoefficieropologicalCoeficient






_static/images/Network_Analyzer/Analyzer.png
® @ SetParameters

Analyze as

rected Graph?





_static/images/Styles/BarChartsNode_6_1.png
galFiltered.sif






_images/yHir.png
..
..

il

Tl

es
ee
aee





_static/images/Export/ndex_toolbar_button.png
000 Session: /Applications/Cytoscape_v3.8.(

> BRA Wi AQQ c

& Import Network from NDEx 0O -
4 Export Network to NDEx DEX... Q woRze
v A 1 of 1 Network selected o)
Vv galFiltered.sif 1
< galFiltered.sif 330 359
a
\9

Filter





_static/images/Network_Analyzer/NetworkAnalyzerResults.png
Results Panel

X x
| Network Statistics of galFiltered.sif (undirected) | NEaWoideSEigkiles i er i e bna(Te e
Simple Parameters Node Degree Distribution Avg. Clustering Coefficient Distribution > |
Clustering coefficient 0.072 Number of nodes : 331
Connected components : 26 Lo
! . Network density : 0.007
Network diameter : 27 L
A Network heterogeneity : 0.853
Network radius : 1 .
AT Isolated nodes : 0O
Network centralization : 0.048 Numiiler o sal-lemes = ©
Shortest paths : 61982 (56%) . o
Characteristic path length : 9.025 WRiT=GeleyR a2 [pElS ¢ 11
3 Analysis time (sec) : 0.071

Avg. number of neighbors

12,181





_static/images/Styles/BorderLineOptions.png
VAVAVAYS

Backward Slash

Contiguous Arrow

Dash

Dash Dot

Dots

Equal Dash

Forward Slash

Marquee Dash

Marquee Dash Dot

Marquee Equal Dash

Parallel Lines

Separate Arrow

Sinewave

Solid

Vertical Slash

Zigzag





_images/yFilesTree.png





_static/images/Export/ndex_save_toolbar.png
[ BON ]
> Bl Yk QQQQ 2

& Open Network... | v Ox
& save Network... eF Select  Annotation

(f)v Enter search terms for NDEx... Q
A 1 of 1 Network selected Q

w galFiltered.sif

° galFiltered.sif






_static/images/Network_Analyzer/NetworkAnalyzer.png
[ ] @ NetworkAnalyzer - Network Interpretation
The network contains only directed edges and they are not paired.

Interpretation

I:> C@ _ Treat the network as directed.
I:> C@ (o) Treat the network as undirected.

| Cancel | P—GK—%






_static/images/Styles/BarChartsNode_6_3.png





_static/images/Export/export_menu_37.png
FC8 Edit View Select Layout Apps Tools |

Open... #0 Session: /Af
Open Recent > =
Save xs R Q Q (%7
Save As... {4 8S v Ox%
Close \nnotation S5

| -
New Network >

Q HO13

Import =

Network to NDEX...
Collection to NDEXx...

Print... 8P

Network to File...
Network to Image...
Network to Web Page...

Table to File...

Styles to File...






_static/images/Navigation_Layout/yFilesTree.png





_static/images/Styles/BarChartPanel_6_4.png
Graphics

Images [EEEEN Gradients
el F ~ € O

Options

© Grouped ~ Stacked ~ Heat Strips ~ Up-Down

Available Columns: Selected Columns: -
1. AverageShortestPathLength 1. BetweennessCentrality

2. Degree 2. ClosenessCentrality

3. Eccentricity 3. ClusteringCoefficient

4. Neighborhood Connectivity 4. TopologicalCoefficient

5. NumberOfDirectedEdges

6. NumberOfUndirectedEdges

7. PartnerOfMultiEdgedNodePairs

Radiality
Network-Wide Axis Range
Automatic Range  Min: 0.0 Max: 10f 2
Cancel

Remove Graphics






_static/images/Export/export_menu_36.png
Edit View Select Layout Apps Tools Help

>
Open... 20 ~
Open Recent » Ao @ L7
Save %S | T
Save As... %S J
Import a
Network to NDEX...

Export as Image... Collection to NDEx...
Export as Web Page... Network...

Table...

Styles...

Run Script File...
Print Current Network... 5P





_static/images/Navigation_Layout/yFilesOrganic.png





_static/images/Styles/BarChartPanel_6_3.png
Available Columns:

Selected Columns:

1. AverageShortestpathLength
Centrality
ntrality

. ClusteringCoefficient
5. Degree

6. Eccentricity

7. Neighborhood Connectivity
|_8. NumberOfbirectedEda






_static/images/Export/image_export_dialog.png
Export as Image

e e
Select the export file format: |_PNG (*.png) 9

Save Image as: /Users /thully/Desktop/galFiltered.sif.png

Image Size
Zoom 06) v 1008
o s oo
Units | pixels
Width 889
Height: 385
72,

Resolution (DP):

Browse...





_static/images/Navigation_Layout/yOrganic.png





_static/images/Styles/BarChartsNetwork_6_1.png





_static/images/Export/export_menu_38.png
Cytoscape

¢ Network

o Style

Y Filter

ation

Edit View Select Layout Apps Tools Help
Open... $0 Lo o :

Open Recent i Session: /Applications/Cytoscape_v3.8.0/Cytos
Save 8S

Save As... Q @ <

Close

New Network YORZEAW
| Q

Import

Collection to NDEXx...

Network to File...
Network to Image...
Network to Web Page...
Table to File...

oIt

Styles to File...





_static/images/Navigation_Layout/yHir.png
..
..

il

Tl

es
ee
aee





_static/images/Styles/BarChartPanel_6_5.png
() Graphics

images Cradients
el F ~ € O
Color Scheme: | Contrasting &)

Show Value Labels ~ Column:| -~ none -- | FontSize: 1

Domain Labels Column: | -~ none -~ &)
Domain Label Position: | Standard &)

8| (© Vertical Orientation ' Horizontal Orientation

Show Domain Axis ~ AXis Width: __0.25
Show Range Axis Axis Color: [N
Show Zero Baseline  avic Font Size: 1

Border Width:  0.25

Border Color: [

Separation (0.0-0.5: 0.0

Remove Graphics Cancel Apply






_static/images/Export/ndex_save.png
[ JON ] CyNDEx2 Browser
bsettle

& ndexbio.org

AUTHOR

DESCRIPTION

ORGANISM

DISEASE

TISSUE

RIGHTS HOLDER

VERSION

REFERENCE

SAVE AS PUBLIC?

UPDATE EXISTING NETWORK?

Network Name: Cancel





_static/images/Nested_Networks/NestedNetwork.png





_static/images/Styles/BarChartsNetwork_6_2b.png
@Q@ C AR® © @ QYMRO43W
\ =
)ﬁ vl ah paine e\ VM
J‘ 1 - - |

4 =y Ju g \ \\,I
L L\ -1 iy

| ] L ‘ . | =

=0 1 - |
EiR .
// ] | “I —\J J
R
=






_static/images/Export/ndex_context_menus.png
> BA LY AQAQ

¢ Network

o Style

Y Filter

m Annotation

Network ~

qé’). Enter search terms for NDEXx...

A 1 of 1 Network selected
Vv galFiltered.sif
galFiltered sif

Destroy 1 View
Destroy Network
Rename Network...

Clear All Edge Bends
Apply Style...

Export Network to NDEX...

Export as Network...
Export as Image...

~
[ =4

0 % -

Q
]

1
330 359

Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app/

¥CRO.
FORZGEAW

502

SMC1
DIt

SNE2

M5H5

VEA2D

01

ACS2





_static/images/Navigation_Layout/zoomicons.png
QA QK





_static/images/Styles/BarChartsNetwork_6_2.png
galFiltered.sif

(B |
1 (9 jj =
. / ~ Y -J_.J N N
J-'-:L./ 7 =
A .|\ L -1 .
- L ‘ - | =4
M | 1 -
| - | ]
] Lol | =8 -
/ N L]
™ | - |






_static/images/Export/ndex_save2.png
A - N o Emos I A~~~ _
(@0 @ Export Network to NDEx

a rudipillich@public.ndexbio.org | 4%

Name: My New Network
Author
Organism

Disease .

W Cils,

Tissue

Rights Holder

Version
5 poaw
E Reference
Description
gall
Update Existing Network @
Cancel . Export Network to NDEx_

Too)="

7 Yor277¢C





_static/images/Export/ndex_save1.png
P TR TOPPR

-

[ FOF NP

' Too'

Name:

Author

Organism

Disease

Tissue

Rights Holder

Version

Reference

Description

Cancel

My New Network

Update Existing Network

GW

|2oaw

galFi

" YDR277C
YBRO43C





_static/images/Nested_Networks/NestedNetwork2.png
Levell.l

Levell.2

Levell.3





_images/AddEdge-2.png





_images/AddEdgeMenu.png
—

Edit Edges Connecting Selected Nodes
Select
Group
Nested Networks

Apps

External Links
Preferences

YY VY vvvy





_images/AddNodeMenu37.png
Edge (and possibly Nodes) using SIF...

Delete Node
Diffuse
Edit Image Annotation...

Group Text Annotation...

Bounded Text Annotation...
Apps

Preferences

>
>
>

Select > Shape Annotation...
>
>
>

— ~






_images/AdvancedNetworkMerge.png
[ ] Advanced Network Merge

_ @) Intersection @) Difference

Available Networks: Networks to Merge:

galFiltered.sif
Principle Pathways of Carbon Metabolism - ¢

P Advanced Options

Cancel





_images/AddNetworkAnnotations.png
Edge (and possibly Nodes) using SIF...

Delete » Node
Edit > Arrow Annotation
Select » | Image Annotation
Group > Shape Annotation
Text Annotation
Apps > Bounded Text Annotation

Preferences





_images/AddNodeMenu.png
Edge (and possibly Nodes) using SIF.

Delete >
Edit » | Arrow Annotation
Select > Image Annotation
Group  » | Shape Annotation
Text Annotation
Apps > | Bounded Text Annotation

I —————
Preferences »





_images/AnalyzerResultsPanel.png
Analyzer ~ -
‘Summary statistcs o the network.

Node specificstatistics are found in the node table,
and Edge Betweenness is added to the edge table.

Fil Jedit 1 (undirected)

Number of nodes 419
Number of edges 1089
Connected components 1
Analysis time (sec) 0.162

Show Node Degree s

Show Betweenness by Degree

Show Closeness Graph





_static/images/Panels/HideWindow.png





_static/images/Styles/ImageChart1-DefValue.png
&

Height

Image/Chart 1

Default Value: None 3






_images/AppManager.png
(EEELENEN Currently Installed  Check for Updates

App Manager

Download

: | http://apps.cytoscape.org/

Manage Sites...

Q

5 all apps (140)
25 collections (3)
5 apps by tag

Adj Exporter
AgilentLiteratureSearch
AllegroLayout

aMatReader

Anatapp

ANIMO

ARACNE

AutoAnnotate

bayelviraApp

BINGO.

BIOGRID Data Source (installed)
Biomart Web Service Client (inst
BioPAX Reader (Installed)
Bisogenet

BridgeDb

Install from F

View on App Store

Install

Close






_static/images/Styles/ImageChart1-Add.png
| Solid

Properties ~

Border Line Type
Border Transparency
 Border Width
V Label
Label Font Face
V Label Font Size
Label Position
Label Transparency
Label Width
Nested Network Image Visible
Padding (Compound Node)

¥ Shape
Shape (Compound Node)
Size
Tooltip
V Transparency
Visible
X Location
¥ Location
ZLocation

Show All
Hide All

Make Default

Paint

 Border Paint

Custom Paint 2
Custom Paint 3
Custom Paint 4
Custom Paint 5
Custom Paint 6
Custom Paint 7
Custom Paint 8
Custom Paint 9

 Fill Color

V Label Color
Selected Paint

Image/Chart Position 1





_images/AdvancedNetworkMergeOptions.png
w Advanced Options

Matching Columns (table columns to match nodes between networks):

galFiltered.sif
name

How to merge columns:

galFiltered.sif

name
AverageShortestPathLength
BetweennessCentrality
COMMON
ClosenessCentrality
ClusteringCoefficient
Degree

Eccentricity

Enable merging nodes/edges in the same network

Merged Network
Matching.Attribute
AverageShortestPathLength
BetweennessCentrality
COMMON
ClosenessCentrality
ClusteringCoefficient
Degree

Eccentricity

Column type
List<String>
Double
Double
String
Double
Double
Integer
Integer

Cancel






_static/images/Annotations/annotations_panel_buttons.png
T @  © =

Select the Annotation you want to add...





_static/images/Filters/searchbar3.png
(5]

&/ Style @ Network

Y Filter

m Annotation

E.. Layout Tools

Network ~
DISEASE v breast cancer

[sa=9)

A 1 of 1 Network selected
Vv galFiltered.sif
galFiltered.sif
Cytoscape
A

Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app/../sampleData/sessions/Yeast Perturbation.cys

QaaaQ

0 % -

= Q
&

1
330 359

~
C AP
[0
cLe2
PFE2T
PRPZL
5IP4
C Y59
" @
RPS28B -
RPS28A DMC1
2
LEm4
POCS
105¢

Node Table ~

« 006 @

shared name

YLR362W
YHRO84W
YOR212W

YCLO32W
YEI 02AW

[5

PDCL

s MCM 1w

CDC4az

galFiltered.sif

name

YLR362W
YHRO84W
YOR212W

YCLO32W
YEI 02AW

suc2

CINg

AHPL

RFLAZE

MIG1

CAL3

SWIS

MFAL

abk

Degree

FARL

CLN3

SWi4

COMMON

9 STElL1l
4 STE12
2 STE4
4  STE50
2 STF2

[Qste*

CNS1

H5PE2

CALLOD

GaLgo DALLL

GALZ

MuD2

1AP4

GAL4

. .

GALT
Gevl

5LT2

E <

gallRGexp
0.144
-0.109
-0.189

0.126
-0 RS2

PRPA0

BUDE

HSC82

CPAL

YER1ZAC

C¥Cl

HAP3

SPAZ

gal4RGexp
0.037
-0.541
-0.256

0.02
-0 20A

Fs Node Table

B3 Edge Table

35T

gal80Rexp
0.374
0.057
-0.158

0.284
-n74

TOROE2E

SPC24

gal1RGsii
0.02
0.01
4.1¢

0.0C
1 A4

B2 Network Table






_static/images/Panels/RightClickShowPanel.png
c
2
E o GCR2
g s
(=
[~
< YCAZOIW
HMO1 = SNP1
h TAH18
v Show Control Panel
v Show Tool Panel
Show Results Panel feLoasw
v Show Table Panel
PRPY
v Show Command Panel e
0
1
)‘_\/ Show Labels bz
=
o MTH
: VERLLGE
-
wd . galFiltered.sif






_static/images/Styles/MappingValueGenerators.png
)

Column
Mapping Type
1
2
3

Fill Color

Edit »>
Degree Rainbow
Rainb
Discrete Mapping Hide Selected Visual Properties R:'r:'d::gnslcm

Fit label width (only works with 'name’ column to node size or width)

Number Series
Random Numbers





_images/Analyzer.png
® @ SetParameters

Analyze as

rected Graph?





_static/images/Filters/scatter1.png
ClosenessCentrality
oot I

o
8 9 101 121318 15 16 17 18 19

Degree

| Degree

Log wn: [ osss | vax |

ClosenessCentrality
- 82/330 in range

0.46 - 6.56]

Log wn: [ 037 | v |
0.35 - 1.05]





_static/images/Panels/MinimizeIcon.png





_static/images/Styles/LineChartIcon.png





_images/button_up_2.png





_static/images/Annotations/button_annotation_selection.png





_static/images/Filters/select-panel2.png
{8 Legend Panel

D jActiveModules

< Network

o Style

Y Filter

g
8
2
<

Eu Layout Tools

Filter ~
Default filter

X Degree I+ out s
berween 8 ana

18] inclusive

€ Apply when filter changes
© select  show
Apply
Selected 6 nodes and 0 edges in 110ms

Chain





_static/images/Panels/TabsDropDown.png
«2 Network

Style

Network ~

14 <2 Network
o Style
Y Filter
Annotation

galFiltered.sif

ork selected

&

1
330 359





_static/images/Styles/MultipleEdgeMapping.png





_images/button_up.png





_static/images/Annotations/annotations_panel_selected.png
Annotation ~

H T
z
& Select the Annotation you want t add
=] 2.0f 8 Annotatons selected
2 Foreground Layer
N T Tex
1) Shape 2
1 Shape 1

>

T My Text Annotation

Bounded Text Annotation

v 4
Background Layer
A Arrow1
6 Shape s
4 Shape 3
8
z
| Select All Select None





_static/images/Filters/select-panel-options2.png
Default chain

Start with: Current Selection New filter chain
Rename current filter chain
© Copy current filter chain

Export filter chains...
Import filter chains...

© select  show
Apply

Filter





_static/images/Panels/ShowSidebarLabels.png
2
H
]

g
¢
<
3
®

O WordCloud

-

< Network

~

 filier

L Layout Tools

a

Session: /Applications/Cytoscape.v3.8.0/Cytoscape.appl../sampleDatalsessions| Yeast Perturbation.cys

=R L

B Command Line.

QaaQa«

8 8 rnmo

T Node Table

a

LR e N

7 Edge Table

% Nework Table

& WordCloud Display

R

o Heat Map

sz,

ey

ViNvUD @ (1P





_static/images/Styles/Minimal.png
= =
- g ;-
Sa R L =
=====:==== ==:i=== ,:H
=‘=| ==:=FE, :==1= =
! N =
=======:==g ¥ 2
=I§|=|=:=|=|==I‘='= &
-]
L el o
et o EN ===== ==
P_OF T CaeAfL o Ange
= = i====' === o
ez ® o °F8 TEe =
=4 ol S EE -
= ES N
== ===§:‘======:==
=" =:=== i=====?=
.= =s L
g S8 a =ca
==





_images/cgTutorial-defImage.png
Graphics

WEEEN charts  Gradients

Image

Image

Image

Image

Image

Image

Image

Image

- E*Er»@E=E+ 3

Image

Image:

Mus_musculus_L.png

Mus_musculus_NL.png

Oryza_sativa_Lpng

Oryza_sativa_NL.png

Rattus_norvegicus_L.png

Rattus_norvegicus_NL.png

Saccharomyces_cerevisiae_L.png

Saccharomyces_cerevisiae_NL.png

Triticum_aestivum_L.png

Triticum_aestivum_NL.png

Open Image Manager.

Remove Graphics

Cancel

Apply






_static/images/Annotations/button_down_2.png





_static/images/Filters/volcanoPlot.png
galsoRsig
T

05 10 15 20 25 a0
gat80Rexp

[ qolaoRexp <] toa m [ oase] wax [ 1]

[oorig | logwn [ oow wex | o)

109 / 329 in range X: [ 0.25 - 1.36] Y: [ -0.01 - 0.25]

1
35





_static/images/Panels/cytopanel-menu-items.png
\UCUN Select Layout Apps Toc
Hide Control Panel
Hide Table Panel
Hide Results Panel
Hide Tool Panel
Show Automation Panel





_static/images/Styles/NodeLabelFit.png
s s

T T T
o e an | i
7
rsosomal proten S24A :
=
T ey jW"‘“’""'A
Cr :
=
il

e ==

II

e AU






_images/cgManager1.png
ece Image Manager

image
Sy, Name: Arabidopsis_thaliana_NL.png

Tags:  bitmap image

Actual Size View:

Arabidopsis_thaliana_Lp...

y g
Arabidopsis_thaliana_NL.
y g
Caenorhabitis_elegans_L...
Width: 120 Height: 90 [ AspectRatio | Original Search

+ @

Close






_static/images/Annotations/button_down.png





_static/images/Filters/string-column.png
X (Nodemame 3

alpha





_static/images/Panels/UndockIcon.png





_static/images/Styles/NewStyle.png
XX ) Control Panel

Style ~
galFiltered Style .
Create New Style.
Properties ~ Copy Stie.
B [ DR Rename Style...
O Border Paint Remove Style
20 Border Width Make Current Styles Default
D Fill Color Create Legend...
Height LXeK ) Create New Style

Image/Chart 1 | Name of new Style: Tuts

H

Label

| Cancel
[ ] Label Color TP
12 Label Font Size <
O Shape “«
50.0 Size <
255 Transparency <
Width L]

Lock node width and height

Edge  Network






_images/button_annotation_selection.png





_static/images/Annotation/ontology_import_annotation.png
Import Ontology and Annotation

Data Sources

Data Type: (+) Node () Edge

Annotation: | @ Gene Association file for Saccharomyces cerevi: +| | Browse.. |

Please select an annotation data source.

Ontology: | [ Browse.
@ Gene Association file for Drosophila melanogaster
@ Gene Association file for Mus musculus
Preview @ Gene Association file for Arabidopsis thaliana
@ Gene Association file for Caenorhabditis elegans. I
Clickonacolurt @ Gene Association file for Rattus norvegicus | | [ selectNone

@ Gene Association fle for Oryza sativa
[ @ coumn 1 < arcolumnz ¢ @ Column3 ¢ T & Calumnd 4T3 Columns <
sco So00007287 155 RRNA 010005763

sep. 5000007287 155_RRNA Co:0032543






_static/images/Filters/plotHistogram.png
88 B n ?

NodeTable +
« BB 5B

sennessCentraly Degree Closenes

o1 ’

013 Delete Column

012 Hide Column

0% Vap column.

008 Plot Histogram.

0.06 Plot Scatter...

0.01 Rename Column...

004 5

004





_static/images/Panels/FloatPanels-v3_7_0.png
%4 Session: C:\Program Files\Cytoscape_v3.6.0\sampleData\sessions\Yeast Perturbation.cys .

File Edit View Select Layout Apps Tools Help

» B A

¥

<

aqaq

@ @

|£ | Control Panel

ietwork] style | Select | Annotation

I =

CE>~ Enter search terms for NDEx...

v A 10f 1 Network selected

v galfiteredsif
* [ galfilteredssif

328 355

Table Panel

peeiz

STEN

MCM1 - an

RAP1

GeR

s -

one

st

[

Frequency

4600

a4

200

000

3800

3600

3400

3200

3000

2800

2600

2400

2200

2000

1800

1800

1400

1200

1000

a00

600

00

0

Path length

e D+ 0 =/






_static/images/Styles/GreenWhiteGradient.png
10000 180000
Degree





_images/bundle2.png
ece Set Parameters

Number of handles: | B/

Spring constant: 0.003

threshold 03!

Compatabi

Maximum iterations: 500

e | [0






_static/images/Annotation/ontology_dag1.png
| ST

?mihlnnul process.
metabotsm

primary metabolism
biosynthesis protein metabolism

' orotaln blosythasls





_static/images/Filters/histogramFooter.png
50

a0

30

20

0

Degree

[0 tog v |

AverageShortestPathLength

BetweennessCentralit

ClosenessCentrality
330 359

ClusteringCoefficient
 Degree
Eccentricity
NeighborhoodConnectivity
NumberOfbirectedEdges
NumberOfUndirectedEdges
PartnerOfMultiEdgedNodePairs

Radiality





_static/images/Panels/FloatPanels-v3_3_3.png
- TR0

Control Panel
v Ex

m Style  Select

v a 1 of 1 Network selected -
Tool Panel . v Ox
Scale: M width Height Selected Only
! ! ! % ! | el
(m (B (2] [0 (9] (=] (]
][99 [ = =
s EIEIEEEE
Rotate:  Selected Only.

-180 30 0 %0 180

galFikered sif

Session: /Applications/Cytoscape_v3.6.0-SNAPSHOT/sampleData/galFiltered.cys

B s ®» @

(2]

Results Panel

- ix
BN Network Statistics of galFiltered.sif (undirected)
[«] Shortest Path Length Distribution

5500

5000

< - 4500
- E a0
2 L o (i 2 1500
= - g5
—— e o e -l ® - 2500
X o y 200
a0 & o =
& P a3 1500
e L P - - c
=) - - - = 1000
™ —t -
& 500
- X o @ = @ 0
& - p CA = R
e _ [ o < Path ength
s B B ‘ =
> - = ® L oo e Clot
. p. Y
P [ ] -
LXK ) Table Panel
v ix
e D+ @ =/
& shared name name AverageShortestPathLength BetweennessCentrality ClosenessCentrality ClusteringCoefficient Degree Eccentricity IsSingleNode NeighborhoodCor
VkRo26C VkRoz6C 15.37096774 0o 008505771 o0 % o
Va2 Va2 14375 002406295 008956522 0o 2 o
Vo2 18w Vo2 18w Lesesses? 0o o5 0o H o

(ISR fge Table | Network Table






_static/images/Styles/GradientEditorSample26.png
() Continuous Mapping Editor for Node Fill Color

< v v v

3.0000 100000 16.0000
win Degree v

Edit Handle Positions and Values

Handle Position: 10 © Set Min and Max... Add Delete

Node Fill Color: [__]






_images/button_down_2.png





_static/images/Annotations/add_menu.png
Add » Edge (and possibly Nodes) using SIF...
Delete Node

Diffuse
Edit

>
>
> Image Annotation...
Select > Shape Annotation...
>
>
>

Text Annotation...
Bounded Text Annotation...

Group

Apps

Preferences





_static/images/Filters/sample-group1.png
Network | Style

| Default filter

[ Matchall (aND) +

x

% | fade CoMON 3) (o

ste

% | fade CoMON 3) (o

cde

+

% Degree (0w 3] [

between 5 and 26 inclusive.

™ Apply when filter changes

Apply | [

Selected 1 node and 0 edges in 37ms






_static/images/Panels/HideSidebarLabels.png
ece ‘Session: /Applications/Cytoscape.v3.8.0/Cytoscape.app/../sampleData/sessions/Yeast Perturbation.cys.

> BB L QQQ z a

5T 0% 3B « N A

a A thatara )

o





_images/button_down.png





_static/images/Annotation/ontology_import_obo.png
Import Ontology and Annotation
Data sources

Data Type: (+) Node () Edge () Network

Annotation: [ @ Gene Association file for Saccharomyces cerevisiae +| [ Browse.. |

Ontology: [ Browse.
@ Generic GO slim

@ Yeast GO slim
Preview @ Protein-protein interaction

| @ Pathway Ontology
Click on a columm o ealeie:

posereerAll | | SelectNone





_static/images/Filters/plotScatter.png
- oz
ane nax

MIG1
(2 ST

o’ . CALA' :
y ¥ N

i) 8 B

Degree ClosenessCentralty Clusteringe
Delete Column
Format Column...
Hide Column
Map column.
Plot Histogram. E
Rename Column.
v
015
013
013
014






_static/images/Panels/FloatWindow-v31.png





_static/images/Styles/HeatMapChartIcon.png





_images/button_trash.png





_static/images/Annotations/annotations_panel.png
o Style <@ Network

Y Filter

<
=
8
5
2
£
<

E.. Layout Tools

Annotation ~

Foreground Layer

Background Layer

>





_images/button_group.png





_static/images/Annotations/annotation_selection_mode.png
. Network






_static/images/Filters/sample-group2.png
Network | Style

| Default filter

[Watchall AND)_ ]

% [ iode CoMNON %) (oomams :
e

% [ iode CoMNON %) (oomams :
e

% pegree [ mwou 3] [
between Sland b6 inclusive.

+

™ Apply when filter changes

Apply | [

Selected 0 nades and 0 edges in 7ms






_images/button_ungroup.png





_images/AutomationPanel.png
Command Line ~

Clear

Command:

<





_images/BarChartEditor.png
() Graphics

images [MEEEG Gradients
ki F ~» & 0O

© Grouped ~ Stacked ~ Heat Strips  Up-Down

Available Columns: Selected Columns: .~
1. AverageShortestPathLength > [1. BetweennessCentrality

2. Degree 2. ClosenessCentrality

3. Eccentricity » |13, ClusteringCoefficient

4. Neighborhood Connectivity 4. Radiality

5. NumberOfDirectedEdges 5. TopologicalCoefficient

6. NumberOfundirectedEdges <

7. PartnerOfMultiEdgedNodePairs

[

Automatic Range  Min: 0.0 Max: 10

Options

Remove Graphics Cancel Apply
B ————————al






_images/AppsMenu.png
Tools  Helj

App Manager... |






_images/BarChartPanel_6_2.png
Available Columns: Selected Columns:

1. BetweennessCentrality > | [1. AverageshortestPathLength
2. ClosenessCentrality

3. ClusteringCoefficient >

4. Degree

5. Eccentricity
6. Neighborhood Connectivity

7. NumberOfDirectedEdges W
| 8. NumberOfundirectedEdag






_images/BarChartPanel_6_3.png
Available Columns:

Selected Columns:

1. AverageShortestpathLength
Centrality
ntrality

. ClusteringCoefficient
5. Degree

6. Eccentricity

7. Neighborhood Connectivity
|_8. NumberOfbirectedEda






_images/BarChartIcon.png





_images/BarChartPanel_6_1.png
() Graphics

images [MEEGEN Gradients
" A B¢

© Grouped ~ Stacked = Heat Strips  Up-Down

Available Columns: Selected Columns: A~
1. BetweennessCentrality > | [1. AverageshortestpathLength
2. ClosenessCentrality
3. ClusteringCoefficient >
4. Degree

5. Eccentricity
6. Neighborhood Connectivity
7. NumberOfDirectedEdges

| 8. NumberOfundirectedda

Network-Wide Axis Range
Automatic Range  Min: 1.0 Max: 16.35887097| &

Options

Remove Graphics Cancel  ([ABBIVAY






_images/BarChartsNetwork_6_1.png





_static/images/Styles/DefaultContinous.png
Fill Color -

Column Degree

Mapping Type Continuous Mapping

Current Mapping






_images/BarChartPanel_6_4.png
Graphics

Images [EEEEN Gradients
el F ~ € O

Options

© Grouped ~ Stacked ~ Heat Strips ~ Up-Down

Available Columns: Selected Columns: -
1. AverageShortestPathLength 1. BetweennessCentrality

2. Degree 2. ClosenessCentrality

3. Eccentricity 3. ClusteringCoefficient

4. Neighborhood Connectivity 4. TopologicalCoefficient

5. NumberOfDirectedEdges

6. NumberOfUndirectedEdges

7. PartnerOfMultiEdgedNodePairs

Radiality
Network-Wide Axis Range
Automatic Range  Min: 0.0 Max: 10f 2
Cancel

Remove Graphics






_static/images/Filters/column-string.png
. Node: name
yoL19|






_static/images/Panels/ExampleDocked.png
> A Lk

¥ Network ~ 05 -
g
v breast cancer =
g DISEASE Q
v A 1 of 1 Network selected o)
Vv galFiltered.sif 1
< galFiltered.sif 330 359
a
"
.
171
=
i
[
c
i)
=
[
i
o
=
=
<
Layout Tools ~ O 2% -

Scale: Width Height Selected Only
~
A\ / L4
| | | I | | I
1/8 1/4 1/2 1 2 4 8
Align: = ||
Distribute: Be || 9 || W | | =] ==
2 Stack: EIENENEEEEE
o
'_
5 Rotate: Selected Only
o
=
=8 P g
“j -180 -90 0 90 180

QA Q

Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app/../sampleData/sessions/Yeast Perturbation.cys

~
RJ
g RPS1TA
FCY1 PGEL HIS3
SRP1
PHOS e . FEF7
PHOLI
o w — RAP1
YPTL
ADML YOLI61C
FHOE4 FOR100W
GCR1 RPsZAN
coc1s ko1
ENO1
ek PR s PEP12 YHLIEAC
= SECL? - BASL
SEC3 YNLOS1W
Ly
GCR2
GO51 sucz | AHFL
cLez
Pik27
PDC1
SNP1 [ CINg RPLAZE
TAH18
mLoses
5IP4
YNROS3C St . MIG1
YELO1SW.
HEXS FRPI LSMm8 . GALY
RPS28B Dl
GDH. -

2
galFiltered.sif

Node Table ~

& [0

© @

shared name name
YDL194W YDL194W
YDR277C YDR277C
YBR043C YBR043C
YPR145W YPR145W

5B
AverageShortestPathLength
13.11693548

12.12096774

15
Qa 7083871

Q

ss5L2

MSL1

ATC1

H3P82Z st

MUDZ2

GAL1D

14P4

GAL4

caLag GALLL

E <

BetweennessCentrality

0.0
0.00806452

0.0
nn

ClosenessCentrality
0.07623732
0.08250166

0.66666667
N 102057A1

F§ Node Table

TORL

MSLS

YaF

SINg
PRPAD
BUDS
HS
P
STE:
CYC
0 @ 0
0 o &
0O 53 -
ClusteringCoefficient Degre
0.0
0.0
0.0
nn

B> Edge Table & Network Table






_static/images/Styles/DegreeSize.png





_images/BarChartPanel_6_5.png
() Graphics

images Cradients
el F ~ € O
Color Scheme: | Contrasting &)

Show Value Labels ~ Column:| -~ none -- | FontSize: 1

Domain Labels Column: | -~ none -~ &)
Domain Label Position: | Standard &)

8| (© Vertical Orientation ' Horizontal Orientation

Show Domain Axis ~ AXis Width: __0.25
Show Range Axis Axis Color: [N
Show Zero Baseline  avic Font Size: 1

Border Width:  0.25

Border Color: [

Separation (0.0-0.5: 0.0

Remove Graphics Cancel Apply






_static/images/Panels/DockWindow.png





_static/images/Styles/DegreeLabelSize.png
048W

YPL248C

YOLb w 3
YBRO20W »
vvvvvvv

YNLZ LQW@M% c

YDR395W





_images/attribute_circle_layout.png





_static/images/NodeToolsScaled.png
Tool Panel

Node Layout Tools

Selected Only

Reset Scale -

cupta
1

| [=

= [ ¢

a|[=][P

Selected Only
HSF1

Rotate

(00000 00000Yi0000000000]
0 %0 180

180 30





_static/images/Filters/group1.png
Default filter

Match al ()

X Node: ComMON contains
cdc.
x . Node: COMMON contains.

ste

X Degree n+ 0wt B
berween Gland| 26/ inclusive,

€ Apply when filter changes
© select  show
Apply
Selected 0 nodes and 0 edges in 9ms

Chain





_static/images/Panels/ExampleMinimized.png
Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app/../sampleData/sessions/Yeast Perturbation.cys

QQ@ < . Qste* %) /ﬁ‘e

0
) 4
®
&4-
@4‘

RPS1TA
= fov PGK1 HIs:
o
s SRP1
g PHOS ENOZ . FEP7 . .
PHOLI =
PHO4
v RAP1 |
Aot YGLIG1E TORL
PHOE4 YOR100W

AU GCR1
2 ss02 o1 iy sKO1
2 ENO1 MSL1
\’ SNEL MCK1 RRLIEA L PEPL2 i MSLS

Do

COFS SECLT ; BAST ATC1 VORI
-
9 SNCZ SECS YHLODIW -
= icLL
'S
PRPAD
>
GCR2
c e GOs1 suCz | AHPL [ [0
i) cLe2 BUDS
4{; YGR2OZW
= Far MuD2
2 PDCL 4 s
é HMO1 e SNP1 FRPZ1 cina ) Gral
TAH18 >
THLOSOC G
s51P4 -
YNROS3C b MIG1 TERIZIE T
MR GALLD STE11
b TEML YELO1SW STESO
’ CAL4
YHRLIAC RPS2EB o CYC1
GOH2 . caLgp GALLL
" ; n - 0 @ 0
galFiltered.sif b -:-:- 0 0 -(:)
Node Table ~ 05 -
- Y A

Lol B B 5B
o
|2 shared name name AverageShortestPathLength BetweennessCentrality ClosenessCentrality ClusteringCoefficient Degree Eccentricity IsSingleNode Neigh
S YDL194W YDL194W 13.11693548 0.0 0.07623732 0.0 1 26 ]
2 YDR277C YDR277C 12.12096774 0.00806452 0.08250166 0.0 2 25 m}
S vero43c YBR043C 1.5 0.0 0.66666667 0.0 1 2 m}
Wl yPR14SW YPR145W a 7083871 nn N 102057R1 nn 1 18 n

Command Line Bg Node Table B> Edge Table F2 Network Table

& A





_static/images/Styles/EdgeColorTut2.png
Column
Mapping Type
pd
op

Stroke Color (Unselected) -
interaction
Discrete Mapping
IR0 G204 B51 - #00CC33
B R0 G:0 8204 - #0000CC

W





_static/images/NodeToolsRotated.png
Tool Panel =

Node Lay

Scale Selected Only

| \ Y | |

s 4 12 1 2 4 8
Width [ Height Reset Scale
Align 4[5
Distribute b (98 ] [ ] [=] =] [=]
Stack &|[al[=a][F][F][k
Rotate Selected O

180 30 0 %0 180

cup2

cupta

HSF1





_static/images/Filters/filterhandle.png





_static/images/Panels/ExampleFloating.png
< R Q ¢ Mo® a @«
Network = L. aa T L.
B> e searchtems ornoEx.. | Q| @ V()
2 10f 1 Network selected. Ll ) ™
B B o s
o @ sirmesis ww o DI B B O BB
a Th mme Aestorevanman | ® =
~ wouisan o
i Dt P
x eoe Toolpanel w
£ e e wa -
e | Sl @wdh @ Heigh @ selectedOnly 10
P 2
5 e N R——"r -
F] = ‘ us ue 2 1 2 4 8 00 oo
g | (o “
H A o0 @ oo
& 00 &)
E &= = 20 =
o | =1 (= =] [F [E & e Y SN
Roe: @ Selcted Ony o
; G i sten
P 1 o
E : —a b — S=oa
a surtredsit Yore 2oz e e o

Edge Table T Network Table
alla ]






_static/images/Styles/DiscreteMapper.png
Properties ~
Def._Map.

Byp.

«
>

10

None

Column
Mapping Type
pd
op

None

Color (Unselected)
Label

Label Color

Label Font Size

Line Type

Source Arrow Shape

Source Arrow Unselected Paint

Stroke Color (Unselected)

interaction

Discrete Mapping

Target Arrow Shape

Node Network






_images/bundle1.png





_static/images/Annotation/AnnotationImport.png
Import Ontology and Annotation
Data Sources

Data Type: (+) Node () Edge () Network

Annotation: |_Please select an annotation data source... 4 [ Browse..
Ontology: [ @ Gene Ontology +] [ Browse.. |
Preview

Click on a column to edit it.

SelectAll | | Select None

Advanced Options.

(Cancel | i)






_static/images/Filters/histogram1.png
default network
Interactive || Regression

Degree

Degree < | [ ] Log mn: [ 3] Max B
31/ 330 are between 3.00 and 9.00






_static/images/Panels/FloatIcon.png





_static/images/Styles/ExportStylesDialog.png
ece Export Styles

Select the export file format: | Style XML (*.xml)

Save Styles as: /Users /thully/Desktop/styles.xml Browse...

Select Styles: [Big Labels Select All

Select None

Custom Graphics Style

default black






_images/automation_menu.png
Search | | L

User Manual
leo Demos.
Tour
Tutorials
Automa

CYREST AP
CYREST Command API

Citations Automation Examples

Links for Help.
Report a Bug

Check for Updates





_static/images/cytoscape3-icon-trans-128x128.png





_static/images/Filters/group2.png
©
n

Default filter

Match all (AND)
x Match all (AND)
x . Node: COMMON contains.
cde
x . Node: COMMON contains.
ste
+

X Degree I+ out s

between 6 and 26 inclusive.

€ Apply when filter changes
© select  show

Apply
Selected 0 nodes and 0 edges n 65ms

Chain





_static/images/Panels/ExampleUndocked.png
[ NON ] Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app/../sampleData/sessions/Yeast Perturbation.cys

> A LWL QAQQ = Q a0

RIS1TA

¥ Network ~ 00X o ek s

(<]

2 v breast cancer =

g D%E - Q PHOS ENOZ . FEF7 -

. 5
A
v A 1 of 1 Network selected £ rros i RAP 1 .
Vv galFiltered.sif 1 e YGLIG1C ToRL

o YOR100W

s galFiltered.sif 330 359 GCRL o A or

3 ENOL MsL1 MsL5

- L

\’ MCK1 RRLIEA L PEPL2 i

. SEC17 . BASL ATC1 NORIMEY

) YNLODIW

= 5ING

= icLL

'S

| o4 FRP40

c GOs1 suCz | AHPL [ [0

i) cLe2 BUDS

=]

E mar MuD2

2 PDCL 4 s

é ) i CING RPLAZE e

I8 osat Re” P
s51P4 -
YNROSIC b MIG1 TERIZIE T
— STE11
STESD
LSM8 s . 8P4 sres
’ CAL4
RPS28B
pcrl CYCl
\o GALgD GALLL =
3 - 0 @ 0
B < 0 o | @
0O 53 -

@ >

o

|E ShortestPathLength BetweennessCentrality ClosenessCentrality ClusteringCoefficient Degree Eccentricity IsSingleNode Neigh
5 13.11693548 0.0 0.07623732 0.0 1 26 m}

S 12.12096774 0.00806452 0.08250166 0.0 2 25 m}

3 15 0.0 0.66666667 0.0 1 2 O
wd a 7083871 nn N 102057R1 nn 1 18 n

B3 Node Table B3 Edge Table B2 Network Table






_static/images/Styles/EditSelectedMappingValues.png
20 [

Column
Mapping Type
YALOOSW.
YaLosOW
YaLO3EW
YaLoaoc
YAR007C
YBLOOSW
YeLo21c
YeLoz6W
YeLosow
YeLOGOW

Border Width -

Discrete Mapping

Mapping Value Generators  »  Remove Selected Discrete Mapping Values

Hide Selected Visual Properties Remove Mappings from Selected Visual Properties






_static/plus.png





_static/images/Filters/apply-automatically2.png
Apply when filter changes
© select show
Apply
Selected 6 nodes and 0 edges in 135ms





_static/images/Panels/DockIcon.png





_static/images/Styles/CustomGraphicsSelector.png
Graphics

WG chars Gradients

Image: Arabidopsis_thaliana_L.png

Image: Arabidop:

thaliana_NL.png

Image: Caenorhabitis_elegans_L.png

Image: Caenorhabitis_elegans_NL.png

Image: Danio_rerio_L.png

Image: Dar

rerio_NL.png

Image: Drosophila_melanogaster_L.png

Image: Drosophila_melanogaster_NL.png

Image: Escherichia_coli_L.png

Image: Escherichia_coli_NL.png

/1
=
o
|
-
1]
v

Open Image Manage:

Remove Graphics

Cancel

Apply






_static/minus.png





_static/images/Filters/after_diffusion.png
[ BON ] Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app/../sampleData/sessions/Yeast Perturbation.cys

@ =R t:fﬁ RQAAQAQ T A @. QPHO4 GCR1 ICL1 o A
b

Network ~ 05 - w

¥ (1 Diffusion Output ~ 0O 53 - 2
© Node Selector o
2 7> Enter search terms for NDEX... Q . N |3
2 i . w12 Range Column:  diffus... c
A 1 of 1 Network selected Q . °
v - b Node Rank: =
v galFiltered.sif 1 . pii ) - o
M YR 100w c
= galFiltered.sif 330 359 . . I I I I |
g . Tk MSL1 1 83 165 247 329 | £
X @ —_
J gERLe TS Current Rank: 33 Set
D sECL? BASL ATC1
S . YNLOGIW Create subnetwork from select...
- ' PRP40 Visual Style: . Create
- cos1 sucz | [anm Hepas sl
o CLB2
9] PDCL
g CINg RPLAZE
< FRFZ1
o~ g
YNROSIC et . MIC1
v GAL1D
9
: @
3
% i LSMS . GaL3 G;
= RPS28B
1%} XP1
< Y N
B sss galFiltered.sif E’ 3(3) @ g -(:)
Node Table ~ 05 -
s 1B ® - 3
% shared name name AverageShortestPathLength BetweennessCentrality ClosenessCentrality ClusteringCoefficient
lg YPLO75W YPLO75W 7.49193548 0.18002254 0.13347686 0.0
5 YILO69C YILO69C 7.28629032 0.0 0.13724405 0.0
% YOL086C YOL086C 6.94354839 0.0285648 0.14401858 0.0
— YDRO50C YDRO50C 6.94354839 0.0285648 0.14401858 0.0
us VAL 17w VAL 17w 799177410 NnN2121397 n1204701> nn

B3 Node Table B3 Edge Table F& Network Table

& A 4.9% used of 15.20 Gb | Free Unused Memory





_static/images/Network_Formats/cx_example.png
Example Graph 5

Aspect Relationships

Organizes

oo cartesianLayout Aspect

CX Encoding

cartesiantayout Aspect ~

i [ID

D=4






_static/images/Styles/CustomGraphicsPassthrough.png
@ Border Paint

2.0 Border Width
] Fill Color

Image/Chart 1

Column Image URL

Mapping Type Passthrough Mapping
Label

[ ] Label Color

12 Label Font Size

O Shape

500 > size






_static/up-pressed.png





_static/images/Filters/column-boolean.png
is

“ Node: isExcludedFromPaths

wue





_static/images/Panels/DockWindow-v3_7_0.png
[File] Edit View Select Layout Apps Tools Help

» B A

Control Panel

., ¥

Network [ Style [ Select

Lt @QQQ

CE>~ Enter search terms for NDEx...

Q

va 10f 1 Wetwork selected o
v galiteredsit 1
o @ galfiteredsif 328 355

c Mmoo [

- - & : . PEP1Z =
oo a & - a w - T st
o N ~a Tsten | b
@ oo S 2 MCM1 = an
= > (R @ =
g o e e ® e
s ez MIG1 suce N
aier ) am @ oA e S
€ e P o ® o
e . - e
o 9 v’ aw - RAP1 g ] o
& oo
SXM1 T (o) ©
e v 4B

& e &
T e s

a

entersearch term.. [
Results Panel - ox
| Network statistics of galFittered.sif (undir... | | |
sSimple Parameters | _Node Degree Distributia
Closeness Centrality
Topological Coefficients 4 Shortest Path

800

0

a0

a0

3800

3600

300

3200

3000

2800

2600

Frequency
B

2000

1800

1800

1400

1200

1000

a00

600

00

0

0 o2t
Path length

g

Table Panel =
e D+ 0 =/
Node Table | Edge Table | Network Table|

~ ox






_static/images/Styles/DefaultColorGradient.png
ece Continuous Mapping Editor for Node Fill Color

P\

1.0000
Min=10 Degree

Edit Handle Positions and Values

Handle Position: 0

Node Fill Color:

Add

Cancel

180000

Max=18.0

Delete





_static/images/Filters/chain-filter1.png
Default chain

Start with 3
My filter 1

+ My filter 2
Default filter

© select  show
Apply

Filter





_static/images/Panels/DockWindow-v3_3_3.png
[ XX )
=R L h

QQq Q¢

Control Panel v ox
Style | Select
-
&) e vour auery her Q
v A 10f 1 Network selected &
v galFikered sif
. galFikered.sif 62
ool Panel i v ox

Scale. M width ¥ Height Selected Only.
—_— T
1 | | Y I | |
s 4 12 1 2 4 8
Align &[&][=l [ [#=] [0
Distribute: o] (6] (4] =] [E =
Stack: &][a][E][F][E] [k
Rotate  Selected Only
—_—
D O
-180 -9 0 90 180
-

Session: /Applications/Cytoscape._v3.6.0-SNAPSHOT/sampleData/galFiltered.cys

AR @

galfiltered.sif

Table Panel

@

MM

Results Panel

Frequency

6400 [

6200
6000
sa00
s600
sa00
s200
5000
500
4500
100
a200
000
3800
3600
3400
3200
3000
2800
2600
2400
2200
2000
1500
1600
1400
1200
1000

00

600

a0

200

0 2 4 6 & 1 12 14 1 18 2 2

Save Statistics

Path length

c

« 0+ @

Edge Table

Network Table

@ Memory.





_static/images/Styles/CustomGraphicsVizMapper.png
Properties ~

»

Det._Map. Byp.
O Border Paint ‘«
00 Border Width «
O Fill Color «
Height «

3 Image/Chart 1 ‘
H Label «

[ ] Label Color «
8 Label Font Size ‘«
O Shape «
s00 size «
255 Transparency «
Width «

Lock node width and height

Edge Network






_static/images/Filters/column-numeric.png
. Node: galgORexp
between  1.092 and

3.126 inclusive.

o

o





_static/up.png





_static/images/Filters/column-list.png
. Node: attributes

any element contains,





_static/images/Panels/DockWindow-v3_8_0.png
Analyzer -

Summary Statistics of the Network
R galFiltered.sif (directed)
Number of nodes 330
) Number of edges 350
(oo el $ 4 |Avg. number of neighbors 2170
Network diameter 10
Network radius 1
Characteristic path length  3.493

galfltered:sif

Control

Clustering coeffici 0.035

¢
Network density Hesults 0003

Connected components 26
Multi-edge node pairs 1
Number of self-loops 0

~Node specific statistics are found in the Node Table
~ Edge Betweenness is added to the Edge Table

[ Annotation

Show Node Degree Distribution

Layout Tools ~ a2 -
Show Betweenness by Degree

Scale @ Width € Height € Selected Only
Show Closeness

Node Table -

Dittrbuts shared name name AverageShortestpathLength BetweennessCentrality ClosenessCentrality ClusteringCoefficient
stac YDL19AW YDL19AW o 00 00
Torre Torre —L [ R———

Rotate: @ selected Only || YBRO43C YBRO43C 00 00 00
YPRL4SW YPRLASW 3.6923076923076925 00 02708333333333333
YEROS4C YEROS4C 4925 00 0.20304568527918782
YBRO4SC YBRO4SC 10 0.006048188012244494 10

Command Line ~

3 Edge Table & Network Table






_static/images/NodeTools1.png
Tool Panel
Node Lay
Scale.
' | Y
8 uy4 12 1

Width [ Height

Tool

Selected Only.

Reset Scale

Align 2 T [2=
Distribute bk | a8 ][04 ][] [=]
Stack &|[a|[=a][P][F
Rotate Selected Only
T !
150 50 0 £ 180






_static/images/Tutorials/600px-ChartDialog.png





_static/images/Navigation_Layout/small.align_horizontal_right.png





_static/images/Quick_Tour/TablePanel38.png
Node Table ~

« 0B
shared name
vwozsc
vot12sC
voro1ew
votoomw
voRsoaw
ViRosow
veRosow
ViRI18W

YKRO26C
YaL122c
YCR218W
YoLos7w
YOR204W
YLR249W
YPROSOW
YBRLLEW

ab





_static/images/Tutorials/600px-LoadGalExp3.png
Wher 9 impon bl D
[ e —
P —— B
[e——
A o Bowor o B « Gwecs « Geemes + Guics o Geen « Geow o






_static/images/Quick_Tour/TablePanel37.png
& [0 +

Table Panel

xx

shared name

YKR026C
YGL122C
YGR218W
YGLO97W
YOR204W
YLR249W
YPROSOW

name

YKR026C
YGL122C
YGR218W
YGLO97W
YOR204W
YLR249W
YPROSOW

\eleizala . Edge Table

Network Table





_static/images/Tutorials/600px-Galbrowse3.png
om+ 8=






_static/images/Navigation_Layout/scale_dialog.png
o Tool Panel
Ex
[ Align and Distribute [ISEI3 Rotate
i | | v i | |
us 14 12 1 2 4 8

(M Scale Selected Nodes Only

() along x-axis only

() along y-axis only.

(%) along both axes

Reset Scale Bar |





_static/images/Quick_Tour/NetworkOverview.png
B - ENEA T T e





_static/images/Tutorials/1400px-GalFilteredLoaded3.png
‘Session: New Session
=R LE fFfS AQAQAQ 2 B o @
Control Panel ox :/-
-
va 10f 1 Nework selected & 3
- garitereasi 1
o @ sureredsi 31 e

. ==IlIIIIIII

galFikered sif

Table Panel

¢ D+ @ = f)

@00 @woo | &

ox
i shared name. name
YKRO26C YKRO26C [
YaLi22c YaLi22c
YCR218W, YCR218W,
YeLos7W YeLos7W
[PTEREO Edge Table | Network Table
a] (=

@ Memory.






_static/images/Navigation_Layout/rotate_networkB.png





_static/images/Quick_Tour/NetworkLoaded38.png
LX) Session: New Session

> el b QAQa g wo«

o Nework - oo
§ CE>- Enter search terms for NDEx... Q
Sl v~ 10f 1 Network selected o
v galfieredsit 1
4; (3 alfilteredsif 331 362
A
. |
: |
H
<
=]
~-rrrrrrrr T lellW Tl I
- e o e e - = LIIIIT
0w 0 ‘
0 0
Node Table + s
H L 4B
5 shared name name
3 YKRO26C YKRO26C
7 vaiz2 vaLiz2
a YR218W YR218W
YaLoorw YaLoorw
e Node Table 73 Edge Table % Network Table
Cytoscape
-

=]





_static/images/Styles/universe_style.png
' seligon s
o RN wa oL127wW
’/ 'YOR089C

YNL3OTC |
veruran vazAw

\YoReo2W

ywmnmn -

SAL2iew
ST, YFLses

\\ VERuuw

" yLieid
V\/vknusgm
YLOSTW






_static/images/Navigation_Layout/scale_networkB.png
v
ece Tool Panel

[ Albgn and Distibute |

=

vs  ws 12 1

¥ Scale Selected Nodes Only.
vitousw
O along x-axis only \
voosow
) along y-axis only > N
@ along both axes \

VoL a67c

N





_static/images/Quick_Tour/SelectMenu.png
(GELEN Layout  Apps  Tools Help

Mouse Drag Selects
Nodes >
Edges >

Hide unselected nodes and edges

Select all nodes and edges T®A
Deselect all nodes and edges X *38A





_static/images/Tutorials/1600px-Final_network3.png
/m

ALPHA2  cpce —

%

ususn e

s

Mis1





_static/images/Navigation_Layout/scale_networkA.png
(Align and Distribure [T Rotate )

s 14 12 1
¥ Scale Selected Nodes Only

O along x-axis only
O along y-axis only
) slong both axes

1x
2 4 s
Reset Scale Bar .
vaoisw
\ YOLO3OW
YOR277C /
\ v wssc\
/“ Sy a0
/ huosoc
VRiOO———WWRISEY
voue 167
saw \
viRieic

Ve





_static/images/Quick_Tour/NetworkTools.png
‘loggle Node

Show Grid Export to File... Selecti Toggle Annotation
Show Network Al elestion Selection i i
ways Show Toggle Edge Hide Navigator
l Detach View Graphics Ditail Selection Iggg:esf‘:;i‘;on

HH galFiltered.sif E.’ -:::- ‘f'A g@ g <&






_static/images/Tutorials/1599px-GalWithCharts.png





_static/images/Navigation_Layout/selection-mode-edges.png





_static/images/Quick_Tour/ShowGraphicsDetail.png





_static/images/Tutorials/1600px-Galfiltered-visualization3.png
IR A S
b u /ﬁ- -:7." S
e IITITTIII





_static/images/Navigation_Layout/selection-mode-annotations.png





_static/images/Quick_Tour/SelectMenu37.png
LY Layout Apps  Tools Help.

Mouse Drag Selects >
Edges >
Nodes >

Hide Unselected Nodes and Edges

Select All Nodes and Edges %A
Deselect All Nodes and Edges . -32A





_static/images/Tutorials/1600px-Final_subnetwork3.png





_static/images/Navigation_Layout/small.align_begin.png





_static/images/Quick_Tour/ShowNetwork.png





_static/images/Tutorials/500px-Node_color_gradient3_v2.png
L] Continuous Mapping Editor for Node Fil Color

P v

\\ 12028 =3 B
Min=-1373 gal8ORexp. JP——
ouble-cick hindes to e bounds

i HandiePositions and Vales

Handle Position: 2502 % Set Min and Max. dd Delete

Node Fill Color: | (0]

concel (ORI





_static/images/Navigation_Layout/selection-mode-nodes.png





_static/images/Quick_Tour/ShowGrid.png





_static/images/Tutorials/500px-Node_color_gradient3.png
o Continuous Mapping Editor for Node Fill Color

< v

\ a0z o
Mne-1372 gals0Rexp

Doubie-clck nandic 10 4t bounds

Handle Positon: 25025 SetMinand Max Add Detete

Node Fill Color: | [

Cncel | (D





_static/images/Navigation_Layout/small.align_horizontal_left.png





_static/images/Navigation_Layout/small.align_horizontal_center.png





_static/images/Quick_Tour/TablePanel.png
) Table Panel
& @ oo 4 @ =0 fz)
suID selected & shared name name
62 O vKkRozeC YKRO26C
63 o YGL122C YGL122C
65 o YOL123W YoL123w
67 o YGR218W YGR218W
68 o YGLO97W YGLO97W.
70 o 'YOR204W YOR204W
72 o YLR249W YLR249W
73 o 'YPROBOW YPROBOW

NEEEERE Edge Table

Network Table





_static/images/Quick_Tour/NetworkLoaded37.png
Session: New Session

> ea Ll
e
Style  Select

€D+~ Enter search terms for NDEx.

A 1 0f 1 Network selected

P
o @ sureredsi

o ® [

galFikered sif

e EN® -

© Portalready in use

eD+ 0 -2
= TS
Vel Vel

(LEEEETEN Edge Table  Network Table

@ Memory.






_static/images/Styles/tutorial4_sample.png
O “ Fill Color -

Column Degree
Mapping Type Discrete Mapping

1 [EIR255 G128 B0 - #5780,
2 [IR255 G255 B0 - #FFFF.
3 [SIR128 G255 B0 - #80FF.
4 IR0 G:255 B0 - #00FF00
5 IR0 G255 B128 - #00FF.
6 IR0 G255 8255 - #00FF.
7 IR0 G:128 8255 - #008.
s IR0 G:0 8255 - #0000FF
9 I R127 G0 8255 - #7F00.
1 EIR255 G0 8255 - #FF00.
17 I R255 G0 8128 - #FF00.

18 I R255 G:0 B0 - #FF0000





_static/images/Styles/solid_style.png





_static/images/Quick_Tour/Minimize.png





_static/images/Styles/default_style.png





_static/images/Quick_Tour/LayoutMenu37.png
Apps  Tools Help.
Bundle Edges >
Clear All Edge Bends
Node Layout Tools

Settings...
Apply Preferred Layout 3

Grid Layout
Hierarchical Layout
Circular Layout
Stacked Node Layout

Attribute Circle Layout >
Prefuse Force Directed Layout

Prefuse Force Directed OpenCL Layout

Degree Sorted Circle Layout

Group Attributes Layout >

Edge-weighted Force directed (BioLayout)
Edge-weighted Spring Embedded Layout

Compound Spring Embedder (CoSE)
Inverted Self-Organizing Map Layout

Install yFiles Circular Layout

Install yFiles Hierarchic Layout

Install yFiles Hierarchic Layout Selected Nodes
Install yFiles Organic Layout

Install yFiles Orthogonal Layout

Install yFiles Radial Layout

Install yFiles Tree Layout

Install yFiles Orthogonal Edge Router

Install yFiles Organic Edge Router





_static/images/Styles/colorPt2.png
]





_static/images/Quick_Tour/MultipleNetworkView37.png
LXK )
» BB L

Contral Panel

Style Select Annotation
€D+~ Enter search terms for NDEx.
~ 0 0f 4 Networks selected

v oalfikeredsif

galfiltered.sif

w Statin Pathway - Homo sapiens

Statin Pathway - Homo sapiens
~ Apoptosis - Homo sapiens_1

Apoptosis - Homo sapiens_L
v GNDhuman.sit

aNDhuman.sit

© Portalready in use

Session: New Session

galfiltered.sif

Q

Statin Pathwiay - Homo sapiens

Apoptosis - Homo sapiens_1

BINDhuman sif

Table Panel

00f 4 Views selected

Network Table

@ Memory.





_static/images/Styles/galFilteredSessionDefault.png





_static/images/Quick_Tour/MultipleNetworkView.png
eoe
4, ¥
o BRA ¢
o Sle -
£ default
z
v
2
z Border Paint
A
4.0 Border Width
: @ Fill Color
¥ a0 Height
g Image/Chart 1
2 B Label
2
E J Label Color
& 12 Label Font
g D Shape
H
g Size
<
8 =5 Transparency
700 th
Lock node width and height
8
5
o (L Edge  Network

Session: /Applications/Cytoscape_v3.8.0/Cytoscape.app]../sampleData/sessions/Affinity Purification.cys

=

e

HIV-human PPI

galFiltered:sif

Node Table ~

« BB
shared name

"kRoZ6C

vauz2

vaRz18w

vaLosrw

voRz0aw

(=)

GraphiD

ab

Xrefld

XrefDatasource

Tot4 Views seleced @
Type sGPMLShape Width Height FillColor
&3 Node Table T Edge Table

Color

& Network Table
E ]





_static/images/Styles/edge_types.png





_static/images/Quick_Tour/MultipleNetworks_Grid.png
BINDyeast.sif

5 R e @

TN

/

|“ 0-0 @ 0-0 | '(:)' | BINDyeast.sif

p § | Apoptosis View

B0-0 @0-0 €

p § | Statin Pathway View | 0-0 @ 0-0 p § | galFiltered.sif






_static/images/Styles/ripple_style.png





_static/images/Quick_Tour/MultipleNetworks_Cascade.png
,
CXCX ) Apoptosis View

000 BINDyeast.sif

@00 galFiltered.sif

é’ﬁﬁ'?aa@.@.ée;m@@

< -mmme-






_static/images/Styles/redWhiteBlue.png
ece Continuous Mapping Editor for Node Fill Color

Current Palette: | ColorBrewer HSV Red-Blue
<Y v V)

“2.4260 00000 20580
gallRGexp

Edit Handle Positions and Values

Handle Position: 8 Set Min and Max... Add Delete

Node Fill Color:





_static/images/Quick_Tour/MultipleNetworks_Vertical.png
“h 68 RQAQAQA 2 Bmo e

0% 1000 semen 000 ouassst
=

000 numsutsenstan

e
Ny
e






_static/images/Styles/setPalette.png
L XoK ) Set palette

Built-in Divergent Palettes

TR
| |
THHTNT

show only colorblind-

Reset  (MOKMM)  Cancel

ndly






_static/images/Quick_Tour/MultipleNetworks_SidebySide.png
& Y Y
®-® galFiltered.sif 000 BINDyeast.sif 000 Statin Pathway View

g aaaa ¢ B aQaaQ g B AQAQAQA € 48 QAaQaQa g «






_static/images/Styles/sampleImage.png





_static/images/Quick_Tour/NetworkLoaded.png
eo0e Session: New Session

R Lk QAQaQQ ¢ Do o

Contral Panel B

T svyle | Select
- Enter search terms for NDEx. Q
v A 1 0f 1 Network selected &
v galFiered sif 1
o (@ galfikeredsif 31 362

i
s
oA
o

aafitredsi P Goo @woo &
Table Pl - ox
o D+ @ ™/
& shared name name
viozec vikozec
veti22 veti22
vora1w vora1w
veLoonw veLoonw
voRzoaw voRzoaw
ViRzsow ViRzsow
vesosow vesosow
LWECERELIEN  Edge Table  Network Table
- @ Memory






_static/images/Quick_Tour/MultipleNetworks_VerticalStack.png
[ X X J galFiltered.sif

_J'" - -

w : - — h -

.y -
s - s
X | galFiltered.sif | 0-0 @ 0-0 | (:)'

2 AQAQAQ ¢ Mo ®

X | BINDyeast.sif

2 AQAQAQ ¢ Mo ®

: X | Statin Pathway View
S AQQQ & s @

X | Apoptosis View | ”0—0|®0-0 |'€)-






_static/images/Styles/sizePt2.png
vo@ec






_static/images/Navigation_Layout/spring.png





_static/images/Styles/BarChartIcon.png





_static/images/Styles/BarChartEditor.png
() Graphics

images [MEEEG Gradients
ki F ~» & 0O

© Grouped ~ Stacked ~ Heat Strips  Up-Down

Available Columns: Selected Columns: .~
1. AverageShortestPathLength > [1. BetweennessCentrality

2. Degree 2. ClosenessCentrality

3. Eccentricity » |13, ClusteringCoefficient

4. Neighborhood Connectivity 4. Radiality

5. NumberOfDirectedEdges 5. TopologicalCoefficient

6. NumberOfundirectedEdges <

7. PartnerOfMultiEdgedNodePairs

[

Automatic Range  Min: 0.0 Max: 10

Options

Remove Graphics Cancel Apply
B ————————al






_static/images/Export/export_menu.png
View Select Layout Apps Toc

> B
%0 o e

Open Recent >3 < B

Save fC ) —

Save As... osgs || Select |

import ) slected
Network.

Export as Image. Table...

Export as Web Page... Styles.

Run Script File...
Print Current Network... 8P






_static/images/Navigation_Layout/yFilesHierarchic.png





_static/images/Styles/BarChartPanel_6_2.png
Available Columns: Selected Columns:

1. BetweennessCentrality > | [1. AverageshortestPathLength
2. ClosenessCentrality

3. ClusteringCoefficient >

4. Degree

5. Eccentricity
6. Neighborhood Connectivity

7. NumberOfDirectedEdges W
| 8. NumberOfundirectedEdag






_static/images/Export/WebExportOriginal_v3_3_3.png
Session: New Session
=R Ly & c Do o

Contral Panel

[ style | Select

e —
v A 1 of 1 Network selected -3 Metabolism of amino acids.
ongradaion ot oy Ace
v TCACycle ’ % Fatty Acid Synthasis.
e Cooprosomiet |
o @Tcacyd % 79 S

P
e 3} o) S
TCA Cycle View
Table Panel
# M+ @ = /)
shared name name GraphiD xrefld XrefDatsource  d+ sGPMLShape & Width  d Height Fillalor col
are are besb7 HMDB01Z73 DB 301834671 143710021 #0000t
cop cop fs520 HMDBO1Z01  HWDB 30.9999995.. 143710021 #0000t
coz coz easas HMDBOI%67  HWDB 251504661, 143710021 #0000t
water water d7ss0 HMDB0ZILL  HWDB 41s4l6206.. 143710021 #0000t

[T edge Table | Network Table

@ Memory.






_static/images/Navigation_Layout/yCircular.png





_static/images/Styles/BarChartPanel_6_1.png
() Graphics

images [MEEGEN Gradients
" A B¢

© Grouped ~ Stacked = Heat Strips  Up-Down

Available Columns: Selected Columns: A~
1. BetweennessCentrality > | [1. AverageshortestpathLength
2. ClosenessCentrality
3. ClusteringCoefficient >
4. Degree

5. Eccentricity
6. Neighborhood Connectivity
7. NumberOfDirectedEdges

| 8. NumberOfundirectedda

Network-Wide Axis Range
Automatic Range  Min: 1.0 Max: 16.35887097| &

Options

Remove Graphics Cancel  ([ABBIVAY






_static/images/CyBrowser/WebIcon.png
i
Lt/





_static/images/Navigation_Layout/small.stack_horizontal_bottom.png





_static/images/Quick_Tour/Welcome_36.png
00 Session: New Session

=R LE RAQQQ 2
- < B =~
Control Panel v Ox Welcome to Cytoscape

'!Em’ Style | Select |

(}f)v Enter search terms for NDEXx... Q = ; :
Y A Fo Eak i/ g2
S

Affinity Purification Ivacaftor Coauthor Styles Demo TCGA Colorectal Can... Yeast Genetic Interac... Yeast Perturbation

Tutorials

Table Panel v Ox

\ee28Ele)l=] Edge Table | Network Table \

& (-] @ Memory






_static/images/CyBrowser/RightClick.png
Reload

Close browser





_static/images/Navigation_Layout/small.stack_horizontal_begin.png





_static/images/Quick_Tour/Welcome_33.png
eRA L 2LF5S AQAQQ 2 Do @ a
Contol Panel

Syle Select

Nework Nodes 2dges

) Weicome to Cytoscape

strtNewsession Open facentsesson

*< From Network Fle.

S romtenrkoubue A\ This - prerelssevrsion of ytoscape.
Eb LI Cytoscape v3.2.1 s now aailable @
A O\ Celegans ytoscapeorg! © @ 5
0.melnogaser o.rero LIAbAS)
& jned Sides @ hitp/ it 1y 1FpstOA

W e A rspiens

AboutCuoscape  Dosumentton  Tutorsls

EmedeTn ose

Edge Table  Nevwork Table






_static/images/CytoscapeJs/CS-web_vs_CS-2.png
Node Shape Supported [Edge Line Type Supported |[Edge Arrow Shape (Source or Target) Supported
Diamond O Backward Slash o' Arrow &’
Ellipse ° Contiguous Arrow o' Circle °
Hexagon o Dash o Delta &
Octagon o Dash Dot o' Diamond °
Parallelogram O Dots o Half Bottom &
Rectangle o Equal Dash o' Half Top &
Rounded Rectangle o Forward Slash o' T °
Triangle o Parallel Lines o'
V O Separate Arrow <’

Sinewave =1

Solid [

Vertical Slash =1

Zigzag o'
1 Supported as Dash Key
2 Supported as Triangle Not Supported O

Partially

Supported =

Fully Supported °






_static/images/Navigation_Layout/small.stack_horizontal_top.png





_static/images/Quick_Tour/network_overview_34.png
ﬁﬁaﬂu Edge Table =~ Network Table

@ Memory






_static/images/CytoscapeJs/CS-web_vs_CS-1.png
Node Properties Supported [Edge Properties Supported [Network Properties = Supported
Border Line Type O Bend O Background Paint O
Border Paint ° Color (Selected) = Center X Location O
Border Transparency o Color (Unselected) = Center Y Location O
Border Width o Curved O Edge Selection O
Fill Color o Label o Height O
Height ° Label Color ° Node Selection O
Label o Label Font Face o Scale Factor O
Label Color ° Label Size o Title O
Label Font Face o Label Transparency o Width o
Label Font Size ° Line Type =
Label Position o Paint <
Label Transparency o Source Arrow Selected Paint O
Label Width O Source Arrow Shape =
Nested Network
Image Visible o Source Arrow Unselected Paint °
Selected Paint ° Stroke Color (Selected) = Key
Shape = Stroke Color (Unselected) = Not Supported O
Size ° Target Arrow Selected Paint O Partially Supported =
Tooltip O Target Arrow Shape = Fully Supported °
Transparency o Target Arrow Unselected Paint o
Visible O Tooltip o
Width o Transparency °
X Location o Visible O
Y Location o Width o

=)

Edge Color to Arrows






_static/images/Navigation_Layout/small.stack_horizontal_center.png





_static/images/Quick_Tour/network_overview_30.png





_static/images/CytoscapeJs/sampleExport.png





_static/images/Navigation_Layout/small.stack_vertical_center.png





_static/images/Rendering_Engine/LowLOD.png





_static/images/CytoscapeJs/jsWebSite.png
090 /% croscapess <\

€ & C f [ cytoscape.github.io/cytoscape.js/ b B, 8 ¢ =
Table of contents (W top) .
e Cytoscape.js ...
W About
R Cytoscape.js & Cytoscape A JavaScript graph library for analysis and visualisation (compatible with
N Funding CommonJS/Node js, jQuery 1.4+, and plain JavaScript)
M Downloads © GitHub | & Downloads | % Live code examples | ¥ Twitter | ? Previous
R20 questions | ® Ask a question | ¥ File an issue | £ Future version
M Roadmap milestones
W Notation This is how easy it is to get started with Cytoscape.js (this code creates
(Ao the instance you see on the bottom-right:
M Notation
W Position $(loadCy = function(){
W Elements JSON =
options = {
W Selectors showoverlay: false,
W Notes & caveats minZoom: 