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1. Introduction

This version of Cytoscape builds upon
the 3.x architecture, developer API and set of user controls established. If you’re familiar with former versions of Cytoscape,
this version will feel completely familiar and you’ll be all set to go.
In future releases, we will continue to tweak and improve both the
software and the documentation. This manual will be updated to reflect
all the latest changes.

If you would prefer to learn by doing, consider starting with the Basic Expression Analysis Tutorial [https://cytoscape.org/cytoscape-tutorials/protocols/basic-data-visualization/#/].

This manual describes the installation and use of Cytoscape. For a more
thorough understanding of Cytoscape and its ecosystem, we highly
recommend reading the Welcome Letter accessible on the
http://cytoscape.org website.




          

      

      

    

  

    
      
          
            
   


2. Launching Cytoscape

Cytoscape is a Java application verified to run on the Linux, Windows,
and Mac OS X platforms. Although not officially supported, other UNIX
platforms such as Solaris or FreeBSD may run Cytoscape if Java version 8
is available for the platform.

 


2.1. System Requirements

The system requirements for Cytoscape depend on the size of the networks
you want to load, view and manipulate.

Note that as of Cytoscape v3.2, networks are loaded faster and in less
memory than with previous versions. While this is good news, networks
created on v3.2 on a given memory configuration (e.g., 1GB) may not be
loadable by prior Cytoscape versions on the same memory configuration.


Required Resources
 	                           	Small Network Visualization 	Large Network Analysis/Visualization              

 	Processor     	1GHz               	As fast as possible, with multiple cores 

 	Memory     	512MB           	2GB+                                  

 	Graphics Card 	Integrated video   	High-end graphics card                   

 	Monitor    	XGA (1024X768)  	Wide or Dual Monitor                  



Specific system requirements, limitations, and configuration options
apply to each platform, as described in the Release Notes available
on the http://cytoscape.org website.
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3. Command Line Arguments

Cytoscape recognizes a number of optional command line arguments,
including run-time specification of network files, node and edge data
files, and session files. This is the output generated when Cytoscape is
executed with the -h or –help flag:

usage: cytoscape.{sh|bat} [OPTIONS]
 -h,--help             Print this message.
 -v,--version          Print the version number.
 -s,--session <file>   Load a cytoscape session (.cys) file.
 -N,--network <file>   Load a network file (any format).
 -P,--props <file>     Load cytoscape properties file (Java properties
                       format) or individual property: -P name=value.
 -V,--vizmap <file>    Load vizmap properties file (Cytoscape VizMap
                       format).
 -S,--script <file>    Execute commands from script file.
 -R,--rest <port>      Start a rest service.





Any file specified for an option may be specified as either a path or as
a URL. For example you can specify a network as a file (assuming that
myNet.sif exists in the current working directory):
cytoscape.sh -N myNet.sif.

Note: if there are spaces in the file path, be sure to put quotes around
it:
cytoscape.bat -N "C:\Program Files\Cytoscape\sampleData\galFiltered.sif".

Or you can specify a network as a URL:
cytoscape.sh -N http://example.com/myNet.sif.


Command Line Arguments
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4. Quick Tour of Cytoscape

This chapter describes the basic layout and mechanics of using Cytoscape. If you would prefer to learn by doing, consider starting with the Basic Expression Analysis Tutorial [https://cytoscape.org/cytoscape-tutorials/protocols/basic-data-visualization/#/].

 


4.1. Starter Panel

When you start Cytoscape, you can access basic functions from the
Starter Panel:

[image: _images/Welcome_38.png]

The Starter Panel is designed to give you quick access to a set of sample session files,
as well as tutorials and Cytoscape news. The sample session files include a broad range of networks
to give a sense of the diversity of interaction types, visualization styles and biological applications (see
Network Table properties for more information about each sample session network).
The Starter Panel will also present your own most recent sessions for quick access.

When you load a session file, the Starter Panel will disappear. You can display it at any
time by choosing View → Show Starter Panel.

For
information on user privacy, see the Cytoscape Privacy
Policy.

 



4.2. Basic Features

When a network is loaded, Cytoscape will look similar to the image
below:

[image: _images/NetworkLoaded38.png]

Most functionalities are self-explanatory, but we’ll go through a
concise explanation for clarity. The main window here has several
components:


	The Menu Bar at the top (see below for more information about
each menu).


	The Tool Bar, which contains icons for commonly used functions.
These functions are also available via the menus. Hover the mouse
pointer over an icon and wait momentarily for a description to
appear as a tooltip. Right-clicking on the tool bar allows the
contents to be customized.


	The Network Panel (Network panel of the Control Panel).
At the top of the Network Panel is a Search bar, with direct access
to multiple external resources. The network panel also
contains an optional network overview pane (shown at the
bottom left).


	The main Network View Window, which displays the network. At the bottom
of the network view are a set of network view tools.


	The Table Panel (bottom right panel), which displays columns of
selected nodes and edges and enables you to modify the values of
column data.




The Network Panel and Table Panel are dockable tabbed Panels. You can
undock any of these panels by clicking on the Float Window control
[image: _images/FloatWindow.png]
in the upper-right corner of each panel. This is useful when you want
assign the network panel as much screen space as possible. You will now
have two Cytoscape windows, the main window, and a new window labeled
Table Panel, similar to the one shown below. A popup will be displayed
when you put the mouse pointer on a cell.

To dock the window again, click the Dock Window icon
[image: _images/DockWindow.png].

Clicking the Minimize icon [image: _images/Minimize.png]
will minimize the panel; the panel can be shown again by choosing View → Show
and selecting the relevant panel, or by clicking on one of the tabs in the
minimized panel, for example Network or Node Table, and then clicking
the Dock icon.

[image: _images/TablePanel38.png]

For more information on the panels in Cytoscape, see the Panels
section.

 


Network Editing

Cytoscape also has an edit functionality that enables you to build and
modify networks interactively within the network canvas. To edit a
network, just right-click on the open space of network window, select
the menu item Add → Node, a new node will be added to the canvas. To
add an edge, right click on a node, choose the menu item Edit → Add
Edge. Then select the target node, a new edge will be added between
the two nodes. In a similar way annotation objects can be added;
pictures, shapes or textboxes; much like in MS PowerPoint or similar
software. Detailed information on network editing can be found in the
Editing Networks
section.

[image: _images/AddNodeMenu37.png]

 




4.3. The Menus

 


File

The File menu contains most basic file functionality: File → Open
for opening a Cytoscape session file; File → New Network for creating a new
network, either blank for editing, or from an existing network; File →
Save for saving a session file; File → Import for importing data
such as networks and tables; and File → Export for exporting data.
File → Export Network to Image lets you export the
network in either JPEG, PDF, PNG, PostScript or SVG format.
File → Export Network to Web Page lets you export the entire session or
a single network as a Web page using Cytoscape.js.

File → Open Recent will list recently opened session files for
quick access. File → Print… allows printing.

[image: _images/FileMenu37.png]

 



Edit

The Edit menu contains Cut, Copy and Paste functions, as
well as Undo and Redo functions which undo and redo edits made
in the Table Panel, edits to the network and to layout. The Undo/Redo
functions work on the last 10 tasks performed.

There are also options for creating and destroying views (graphical
representations of a network) and networks (the raw network data - not
yet visualized), as well as an option for deleting selected nodes and
edges from the current network. All deleted nodes and edges can be
restored to the network via Edit → Undo.

Other editing options include; Remove Duplicated Edges will
delete edges that are duplicates (having the same source and target nodes), keeping one edge, Remove
Self-Loops removes edges that have the same source and target node,
and Delete Selected Nodes and Edges… deletes a selected subset of
the network. Rename Network… allows you to rename the currently
selected network.

A set of functions for bringing annotations forward, backward etc, and pushing/pulling
them to the foreground vs background layer are also available in the Edit menu.

Editing preferences for properties and apps are found under Edit →
Preferences → Properties…. More details on how to edit preferences
can be found
here.

[image: _images/EditMenu.png]

 



View

The View menu allows you to display or hide panels, including the Control Panel,
Table Panel, Result Panel, Tool Panel and the Command Panel. In addition, it
also provides a means for viewing the Starter Panel.
It also provides the control of other view-related functionality.

[image: _images/ViewMenu38.png]

 



Select

The Select menu contains different options for selecting nodes and
edges.

[image: _images/SelectMenu.png]

 



Layout

The Layout menu has an array of features for visually organizing the
network. The features in the top portion of the network (Bundle
Edges, Clear Edge Bends, Node Layout Tools) are tools for
manipulating the network visualization. The
bottom section of the menu lists a variety of layout algorithms which
automatically lay a network out.

[image: _images/LayoutMenu37.png]

 



Apps

The Apps menu gives you access to the App Manager (Apps → App
Manager) for managing (install/update/delete) your apps and may have
options added by apps that have been installed. Depending on which apps
are loaded, the apps that you see may be different than what appear
here. The below picture shows a Cytoscape installation without installed
apps.

[image: _images/AppsMenu.png]

Note: A list of available Cytoscape apps with descriptions is available online at: http://apps.cytoscape.org.

In previous versions of Cytoscape, apps were called plugins and served a
similar function.

 



Tools

The Tools menu contains advanced features like cyChart, Analyze Network, Open web page, Merge, Execute Command File…, Job Status Monitor, Run Script File… and Diffuse.

Cytoscape Web Browser allows for viewing any html page directly in Cytoscape. The web browser can be opened in a separate window or can be launched in the Results Panel.

[image: _images/ToolsMenu.png]

 



Help

The Help menu allows you to launch the online help viewer and browse and search this manual.
It also provides direct access to a Tour of Cytoscape, as well as a full listing
of Cytoscape tutorials. Tutorial content opens automatically in the Cytoscape Web Browser.
Video demos are also linked to direclty from the Help menu.

[image: _images/HelpMenu.png]

The Citations option displays the main literature citation for
Cytoscape, as well as a list of literature citations for installed apps.
The list will be different depending on the set of apps you have
installed.

[image: _images/Citations.png]

The Help menu also allows you to connect directly to Cytoscape Help
Desk and the Bug Report interface.

 




4.4. Network Management

Cytoscape allows multiple networks to be loaded at a time, either with
or without a view. A network stores all the nodes and edges that are
loaded by the user and a view displays them.

An example where a number of networks have been loaded is shown below:

[image: _images/MultipleNetworkView.png]

The network manager (in the Control Panel) shows the networks that are
loaded. Clicking on a network here will make that view active in the
main window, if the view exists. Each network has a name and size
(number of nodes and edges), which are shown in the network manager. If
a network is loaded from a file, the network name is the name of the
file.

Some networks are very large (thousands of nodes and edges) and can take
a long time to display. For this reason, a network in Cytoscape may not
contain a view. Networks that have a view are in normal black font and
networks that don’t have a view are highlighted in red. You can create
or destroy a view for a network by right-clicking the network name in
the network manager or by choosing the appropriate option in the
Edit menu. You can also destroy previously loaded networks this way.

Certain operations in Cytoscape will create new networks. If a new
network is created from an old network, for example by selecting a set
of nodes in one network and copying these nodes to a new network (via
the File → New Network option), it will be shown immediately
follows the network that it was derived from.

Network views can also be detached (undocked) from the main Cytoscape window. When detached, a view window can be dragged to another monitor, resized, maximized and minimized by using the normal window controls for your operating system. Notice, however, that closing a view window does not destroy it, but simply reattaches it to the Cytoscape window.

 


Arrange Network Windows

When you have detached network view windows, you can arrange them by selecting one of these options under View → Arrange Detatched Views:

Grid

[image: _images/MultipleNetworks_Grid.png]

Cascade

[image: _images/MultipleNetworks_Cascade.png]

Vertical Stack

[image: _images/MultipleNetworks_VerticalStack.png]

Side by Side

[image: _images/MultipleNetworks_SidebySide.png]

 




4.5. Network View Tools

At the bottom of the Network View Window is a set of network tools:

[image: _images/NetworkTools.png]


	Show Grid will arrange all loaded networks as a grid.


	Show Network will show the currently selected network.


	Detach View detaches the network view window from the main Cytoscape window.


	Export to File… gives you options to export the network or image.


	Always Show Graphics Detail forces the rendering of graphics details. It is turned off by default.


	Toggle Node Selection allows you to turn off/on node selection. It is turned on by default.


	Toggle Edge Selection allows you to turn off/on edge selection. It is turned on by default.


	Toggle Annotation Selection allows you to turn off/on annotation selection. It is turned off by default.


	Toggle Node Label Selection allows you to turn off/on node label selection. It is turned off by default.


	Hide Navigator lets you hide the Navigator (”bird’s eye view”).




The Navigator (or bird’s eye view) shows an overview of the network. It can be used to navigate around a large network view. The blue rectangle indicates the portion of the network currently displayed in the network view window, and it can be dragged with the mouse to view other portions of the network. Zooming in will cause the rectangle to appear smaller and vice versa.

[image: _images/NetworkOverview.png]
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5. Creating Networks

There are 4 different ways of creating networks in Cytoscape:


	Importing pre-existing, fixed-format network files.


	Importing pre-existing, unformatted text or Excel files.


	Importing data from from public databases.


	Creating an empty network and manually adding nodes and edges.




 


5.1. Import Fixed-Format Network Files

Network files can be specified in any of the formats described in the
Supported Network
Formats
section. Networks are imported into Cytoscape via File →
Import. The network file can either be located directly
on the local computer, or found on a remote computer (in which case it
will be referenced with a URL).

 


Load Networks from Local Computer

In order to load a network from a local file you can select File →
Import → Network from File… or click on
[image: _images/Cy3_icon_net_file_import.png]
on the tool bar. Choose the correct file in the file chooser dialog and
press Open. Some sample network files of different types have been
included in the sampleData folder in Cytoscape.

After you choose a network file, another dialog will pop up. Here, you
can choose either to create a new network collection for the new
network, or load the new network into an existing network collection.
When you choose the latter, make sure to choose the right mapping column
to map the new network to the existing network collection.

[image: _images/ImportNetwork.png]

Alternatively, you can simply drag and drop a network file from the desktop
into the Network tab of the Control Panel, rather than selecting the
file from the menu option.

Network files in SIF, GML, and XGMML formats may also be loaded directly
from the command line using the -N option.

 



Load Networks from a Remote Computer (URL import)

To load a network from a remote file, select File → Import →
Network from URL…. In the import network dialog, insert the appropriate
URL, either manually or using URL bookmarks. Bookmarked URLs can be
accessed by clicking on the arrow to the right of the text field (see
the Bookmark Manager in
Preferences
for more details on bookmarks). Also, you can drag and drop links from a
web browser to the URL text box. Once a URL has been specified, click on
the OK button to load the network.

[image: _images/ImportNetworkFromURL.png]

For network files stored in cloud storage, the default URL does not
always work in Cytoscape and requires transformation before it can be used.
Here are examples of transformation of the default URL for some common cloud storage options:


Dropbox


	Default URL: https://www.dropbox.com/s/077w3i4500dxrsm/galFiltered.sif?dl=0


	Cytoscape URL: https://dl.dropboxusercontent.com/s/077w3i4500dxrsm/galFiltered.sif




Instructions: Replace www.dropbox.com with dl.dropboxusercontent.com AND remove ?dl=0



Google Drive

For files smaller than 100K:


	Default: https://drive.google.com/file/d/1hHO4ErMx7HMo-_sRV_PfeoM3lnn6ZDLw/view?usp=sharing


	Cytoscape URL: https://drive.google.com/uc?export=download&id=1hHO4ErMx7HMo-_sRV_PfeoM3lnn6ZDLw




Instructions: Replace file/d/ with uc?export=download&id= AND remove /view?usp=sharing

You may see an intermediate import window, described in the section below, where you may need to change the delimiter and define source, target and interaction.
For this particular example, in Advanced change the Delimiter to Space, unselect Use first line as column names and set the first column as Source, the third column as Target and the second column as Interaction Type.



GitHub


	Default URL: https://github.com/bdemchak/cytoscape-jupyter/blob/main/sanity-test/data/galFiltered.sif


	Cytoscape URL: https://raw.githubusercontent.com/bdemchak/cytoscape-jupyter/main/sanity-test/data/galFiltered.sif




Instructions: Replace github.com with raw.githubusercontent.com AND  remove /blob

Another issue for network import is the presence of firewalls, which can
affect which files are accessible to a computer. To work around this
problem, Cytoscape supports the use of proxy servers. To configure a
proxy server, go to Edit → Preferences → Proxy Settings…. This is
further described in the
Preferences
section.

 





5.2. Import Networks from Unformatted Table Files

Cytoscape supports the import of networks from delimited text files and
Excel workbooks using File → Import → Network from File…. An
interactive GUI allows users to specify parsing options for specified
files. The screen provides a preview that shows how the file will be
parsed given the current configuration. As the configuration changes,
the preview updates automatically. In addition to specifying how the
file will be parsed, the user must also choose the columns that
represent the source and target nodes as well as an optional edge
interaction type. For detailed instructions, see Basic Operations below.

[image: _images/ImportNetworkDialog2.png]

 


Supported File Types

The import function supports delimited text files
and Microsoft Excel Workbooks. For Excel Workbooks with multiple sheets,
one sheet can be selected for import at a time. The following is a
sample table file:


Sample Network in Table
 	source     	target     	interaction  	boolean data  	string data   	floating point data 

 	YJR022W    	YNR053C    	pp           	TRUE          	abcd12371     	1.2344543           

 	YER116C 	YDL013W 	pp       	TRUE      	abcd12372 	1.2344543       

 	YNL307C    	YAL038W    	pp           	FALSE         	abcd12373     	1.2344543           

 	YNL216W 	YCR012W 	pd       	TRUE      	abcd12374 	1.2344543       

 	YNL216W    	YGR254W    	pd           	TRUE          	abcd12375     	1.2344543           



The network table files should contain at least two columns for creating
network with edges. If the file has only one column, the created network
will not contain any edges. The interaction type is optional in this
format. Therefore, a minimal network table looks like the following:


Minimal Network Table
 	source     	target     

 	YJR022W    	YNR053C    

 	YER116C 	YDL013W 

 	YNL307C    	YAL038W    

 	YNL216W 	YCR012W 

 	YNL216W    	YGR254W    



One row in a network table file represents an edge and its edge data
columns. This means that a network file is considered a combination of
network data and edge column data. A table may contain columns that
aren’t meant to be edge data. In this case, you can choose not to import
those columns by clicking on the column header in the preview window.
This function is useful when importing a data table like the following
(1):

[image: _images/sampleTableData1.png]

This data file is a tab-delimited text file and contains network data
(interactions), edge data, and node data. To import network and edge
data from this table, choose Unique ID A as source, Unique ID B as
target, and Interactor types as interaction type. Next, turn off columns
used for node data (Alt ID A, species B, etc.). Other columns
can be imported as edge data.

The network import function cannot import node table columns - only edge
table columns. To import node table columns from this table, please see
the Node and Edge Column
Data
section of this manual.

Note (1): This data was adapted from the A merged human interactome
datasets by Andrew Garrow, Yeyejide Adeleye and Guy Warner (Unilever,
Safety and Environmental Assurance Center, 12 October 2006).
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6. Nested Networks

Cytoscape has the ability to associate a Nested Network with any
node. A nested network is any other network currently defined in
Cytoscape. This capability allows for creation of network hierarchies as
well as circular relationships. For example, various module-finding
plugins make use of nested networks in the overview network that they
generate. There each node representing a module contains a nested
network.

Note that Nested Networks are similar in concept to Groups, but with very different consequences. A Nested Network incorporates an independent network that does not share nodes or attributes with the current network – it can be edited only as a separate network collection or in a separate Cytoscape session. Its nodes cannot be connected to nodes in the current network and cannot be found or filtered using Cytoscape functions or apps. Conversely, nodes in a Group are part of the current network, can have edges to nodes outside of the group, and can be found or filtered using Cytoscape functions or apps.

Most often, Groups are more functional and easier to use.

 


6.1. Creating Nested Networks

There are currently two ways in which a user can create nested networks.


	By importing a Nested Network Format (NNF) file. (See: NNF
Network
Format).


	By manually constructing networks and assigning nested networks to
individual nodes through the right-click node context menu. (See
Nested Network Node Context
Menu).




 



6.2. Visualization of Nested Networks

Nodes containing nested networks that are zoomed in sufficiently display
an image for the nested network. If no current network view exists for
the nested network the image will be a default icon, otherwise it will
be a low-resolution rendering of the nested network’s current layout.

[image: _images/NestedNetwork2.png]
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7. Supported Network File Formats

Cytoscape can read network/pathway files written in the following
formats:


	Simple interaction file (SIF or .sif format)


	Nested network format (NNF or .nnf format)


	Graph Markup Language (GML or .gml format)


	XGMML (extensible graph markup and modelling language).


	SBML


	BioPAX


	GraphML


	Delimited text


	Excel Workbook (.xls, .xlsx)


	Cytoscape.js
JSON [http://cytoscape.github.io/cytoscape.js/#notation/elements-json]


	Cytoscape CX [https://github.com/CyComponent/CyWiki]




The SIF format specifies nodes and interactions only, while other
formats store additional information about network layout and allow
network data exchange with a variety of other network programs and data
sources. Typically, SIF files are used to import interactions when
building a network for the first time, since they are easy to create in
a text editor or spreadsheet. Once the interactions have been loaded and
network layout has been performed, the network may be saved to GML or
XGMML format for interaction with other systems. All file types listed
(except Excel) are text files and you can edit and view them in a
regular text editor.

 


7.1. SIF Format

The simple interaction format is convenient for building a graph from a
list of interactions. It also makes it easy to combine different
interaction sets into a larger network, or add new interactions to an
existing data set. The main disadvantage is that this format does not
include any layout information, forcing Cytoscape to re-compute a new
layout of the network each time it is loaded.

Lines in the SIF file specify a source node, a relationship type (or
edge type), and one or more target nodes:

nodeA <relationship type> nodeB
nodeC <relationship type> nodeA
nodeD <relationship type> nodeE nodeF nodeB
nodeG
...
nodeY <relationship type> nodeZ





A more specific example is:

node1 typeA node2
node2 typeB node3 node4 node5
node0





The first line identifies two nodes, called node1 and node2, and a
single relationship between node1 and node2 of type typeA. The second
line specifies three new nodes, node3, node4, and node5; here “node2”
refers to the same node as in the first line. The second line also
specifies three relationships, all of type typeB and with node2 as the
source, with node3, node4, and node5 as the targets. This second form is
simply shorthand for specifying multiple relationships of the same type
with the same source node. The third line indicates how to specify a
node that has no relationships with other nodes. This form is not needed
for nodes that do have relationships, since the specification of the
relationship implicitly identifies the nodes as well.

Duplicate entries are ignored. Multiple edges between the same nodes
must have different edge types. For example, the following specifies two
edges between the same pair of nodes, one of type xx and one of type yy:

node1 xx node2
node1 xx node2
node1 yy node2





Edges connecting a node to itself (self-edges) are also allowed:

node1 xx node1





Every node and edge in Cytoscape has a name column. For a network
defined in SIF format, node names should be unique, as identically named
nodes will be treated as identical nodes. The name of each node will be
the name in this file by default (unless another string is mapped to
display on the node using styles). This is discussed in the section on
Styles.
The name of each edge will be formed from the name of the source and
target nodes plus the interaction type: for example,
sourceName (edgeType) targetName.

The tag “edgeType” can be any string. Whole words or concatenated
words may be used to define types of relationships, e.g. geneFusion,
cogInference, pullsDown, activates, degrades, inactivates, inhibits,
phosphorylates, upRegulates, etc.

Some common interaction types used in the Systems Biology community are
as follows:

  pp .................. protein - protein interaction
  pd .................. protein -> DNA
  (e.g. transcription factor binding upstream of a regulating gene.)





Some less common interaction types used are:

  pr .................. protein -> reaction
  rc .................. reaction -> compound
  cr .................. compound -> reaction
  gl .................. genetic lethal relationship
  pm .................. protein-metabolite interaction
  mp .................. metabolite-protein interaction





 


Delimiters

Whitespace (space or tab) is used to delimit the names in the simple
interaction file format. However, in some cases spaces are desired in a
node name or edge type. The standard is that, if the file contains any
tab characters, then tabs are used to delimit the fields and spaces are
considered part of the name. If the file contains no tabs, then any
spaces are delimiters that separate names (and names cannot contain
spaces).

If your network unexpectedly contains no edges and node names that look
like edge names, it probably means your file contains a stray tab that’s
fooling the parser. On the other hand, if your network has nodes whose
names are half of a full name, then you probably meant to use tabs to
separate node names with spaces.

Networks in simple interactions format are often stored in files with a
.sif extension, and Cytoscape recognizes this extension when browsing
a directory for files of this type.

 




7.2. NNF

The NNF format is a very simple format that unlike SIF allows the
optional assignment of single nested network per node. No other node
columns can be specified. There are only 2 possible line formats:


	A node node contained in a network:




network node


	2 nodes linked together contained in a network:




network node1 interaction node2

If a network name (first entry on a line) appeared previously as a node
name (in columns 2 or 4), the network will be nested in the node with
the same name. Also, if a name that has been previously defined as a
network (by being listed in the first column), later appears as a node
name (in columns 2 or 4), the previously defined network will be nested
in the node with the same name. In summary: any time a name is used as
both, a network name , and a node name, this implies that the network
will be nested in the node of the same name. Additionally comments may
be included on all lines. Comments start with a hash mark ‘#’ and
continue to the end of a line. Trailing comments (after data lines) and
entirely blank lines anywhere are also permissible. Please note that
if you load multiple NNF files in Cytoscape they will be treated like a
single, long concatenated NNF file! If you need to embed spaces, tabs or
backslashes in a name, you must escape it by preceding it with a
backslash, so that, e.g. an embedded backslash becomes two backslashes,
an embedded space a backslash followed by a space etc.

 


Examples


Example 1

[image: _images/NNFExample1_2.png]
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Example 2

[image: _images/NNFExample2_2.png]
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Example 3
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Example 4

[image: _images/NNFExample4_2.png]
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7.3. GML Format

In contrast to SIF, GML is a rich graph format language supported by
many other network visualization packages. The GML file format
specification is available at:

https://http://www.graphviewer.nl/misc/gmllanguage/gml-technical-report.pdf

It is generally not necessary to modify the content of a GML file
directly. Once a network is built in SIF format and then laid out, the
layout is preserved by saving to and loading from GML. Properties
specified in a GML file will result in a new style named
Filename.style when that GML file is loaded.

 



7.4. XGMML Format

XGMML is the XML evolution of GML and is based on the GML definition. In
addition to network data, XGMML contains node/edge/network column data. More
information on Wikipedia:

https://en.wikipedia.org/wiki/XGMML

XGMML is now preferred to GML because it offers the flexibility
associated with all XML document types. If you’re unsure about which to
use, choose XGMML.

There is a java system property “cytoscape.xgmml.repair.bare.ampersands”
that can be set to “true” if you have experience trouble reading older
files.

This should only be used when an XGMML file or session cannot be read
due improperly encoded ampersands, as it slows down the reading process,
but this is still preferable to attempting to fix such files using
manual editing.

 



7.5. SBML (Systems Biology Markup Language) Format

The Systems Biology Markup Language (SBML) is an XML format to describe
biochemical networks. SBML file format specification is available at:

http://sbml.org/documents/

 



7.6. BioPAX (Biological PAthways eXchange) Format

BioPAX is an OWL (Web Ontology Language) document designed to exchange
biological pathways data. The complete set of documents for this format
is available at:

http://www.biopax.org/

 



7.7. GraphML

GraphML is a comprehensive and easy-to-use file format for graphs. It is
based on XML. The complete set of documents for this format is available
at:

http://graphml.graphdrawing.org/

 



7.8. Delimited Text Table and Excel Workbook

Cytoscape has native support for Microsoft Excel files (.xls, .xlsx) and
delimited text files. The tables in these files can have network data
and edge columns. Users can specify columns containg source nodes,
target nodes, interaction types, and edge columns during file import.
Some of the other network analysis tools, such as igraph
(https://igraph.org/), has feature to export graph
as simple text files. Cytoscape can read these text files and build
networks from them. For more detail, please read the Import Free-Format
Tables section of the Creating
Networks
section.

 



7.9. Cytoscape.js JSON

From Cytoscape 3.1.0 on, Cytoscape supports
Cytoscape.js [http://cytoscape.github.io/cytoscape.js/] JSON files. You
can use this feature to export your network visualizations to web
browsers. Cytoscape.js has two ways to represent network data, and
currently both reader and writer support only the array style graph
notation. For example, this network in Cytoscape:

[image: _images/JSON1.png]

will be exported to this JSON:

{
  "elements" : {
    "nodes" : [ {
      "data" : {
        "id" : "723",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "RPL31A", "RPL34", "S000002233", "ribosomal protein L31A (L34A) (YL28)" ],
        "shared_name" : "YDL075W",
        "SUID" : 723,
        "degree_layout" : 1,
        "name" : "YDL075W"
      },
      "position" : {
        "x" : 693.0518315633137,
        "y" : -49.47506554921466
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "726",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "RP23", "RPL16B", "S000005013", "ribosomal protein L16B (L21B) (rp23) (YL15)" ],
        "shared_name" : "YNL069C",
        "SUID" : 726,
        "degree_layout" : 1,
        "name" : "YNL069C"
      },
      "position" : {
        "x" : 627.3147710164387,
        "y" : -205.99251969655353
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "658",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "RPL11B", "S000003317", "ribosomal protein L11B (L16B) (rp39B) (YL22)" ],
        "shared_name" : "YGR085C",
        "SUID" : 658,
        "degree_layout" : 2,
        "name" : "YGR085C"
      },
      "position" : {
        "x" : 804.3092778523762,
        "y" : -245.6235926946004
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "660",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "KAP108", "S000002803", "SXM1" ],
        "shared_name" : "YDR395W",
        "SUID" : 660,
        "degree_layout" : 8,
        "name" : "YDR395W"
      },
      "position" : {
        "x" : 730.8733342488606,
        "y" : -157.50702317555744
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "579",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "RPL11A", "S000006306", "ribosomal protein L11A (L16A) (rp39A) (YL22)" ],
        "shared_name" : "YPR102C",
        "SUID" : 579,
        "degree_layout" : 2,
        "name" : "YPR102C"
      },
      "position" : {
        "x" : 841.1395696004231,
        "y" : -130.77909119923908
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "578",
        "selected" : false,
        "annotation_Taxon" : "Saccharomyces cerevisiae",
        "alias" : [ "GRC5", "QSR1", "RPL10", "S000004065", "ribosomal protein L10" ],
        "shared_name" : "YLR075W",
        "SUID" : 578,
        "degree_layout" : 2,
        "name" : "YLR075W"
      },
      "position" : {
        "x" : 910.3755162556965,
        "y" : -217.0562556584676
      },
      "selected" : false
    } ],
    "edges" : [ {
      "data" : {
        "id" : "659",
        "source" : "658",
        "target" : "578",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YGR085C (pp) YLR075W",
        "SUID" : 659,
        "name" : "YGR085C (pp) YLR075W"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "661",
        "source" : "658",
        "target" : "660",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YGR085C (pp) YDR395W",
        "SUID" : 661,
        "name" : "YGR085C (pp) YDR395W"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "724",
        "source" : "660",
        "target" : "723",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YDR395W (pp) YDL075W",
        "SUID" : 724,
        "name" : "YDR395W (pp) YDL075W"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "733",
        "source" : "660",
        "target" : "579",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YDR395W (pp) YPR102C",
        "SUID" : 733,
        "name" : "YDR395W (pp) YPR102C"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "727",
        "source" : "660",
        "target" : "726",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YDR395W (pp) YNL069C",
        "SUID" : 727,
        "name" : "YDR395W (pp) YNL069C"
      },
      "selected" : false
    }, {
      "data" : {
        "id" : "580",
        "source" : "578",
        "target" : "579",
        "selected" : false,
        "interaction" : "pp",
        "shared_interaction" : "pp",
        "shared_name" : "YLR075W (pp) YPR102C",
        "SUID" : 580,
        "name" : "YLR075W (pp) YPR102C"
      },
      "selected" : false
    } ]
  }
}





And this is a sample visualization in Cytoscape.js:

[image: _images/JSON2.png]

 


Important Note

Export network and table to Cytoscape.js feature in Cytoscape creates a
JSON file WITHOUT style. This means that you need to export the
style in a separate JSON file if you apply style to your network. Please
read the Style section for more details.

 




7.10. Cytoscape CX

CX is a JSON-based transfer format that enables diverse Cytoscape Cyberinfrastructure (CI) services to exchange networks while preserving all network-related information.
It is designed for flexibility, modularity, and extensibility, and as a message payload in common CI REST protocols. It enables applications to standardize on core aspects of networks, coordinate on more specific or unique standards, and to ignore or omit irrelevant aspects. It is not intended as an optimized format for storage or for specific functionality in applications.

CX is an Aspect-Oriented Network Interchange Format, where the base information is a list of nodes. Independent data structures (called aspects) organize and elaborate on nodes and each other. The core of CX defines five aspects, though a more comprehensive CX document [https://github.com/CyComponent/CyWiki] describes many more aspects.
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8. Node and Edge Column Data

Interaction networks are useful as stand-alone models. However, they are
most powerful for answering scientific questions when integrated with
additional information. Cytoscape allows the user to add arbitrary node,
edge and network information to Cytoscape as node/edge/network data
columns. This could include, for example, annotation data on a gene or
confidence values in a protein-protein interaction. These column data
can then be visualized in a user-defined way by setting up a mapping
from columns to network properties (colors, shapes, and so on). The
section on
Styles
discusses this in greater detail.

 


8.1. Import Data Table Files

Cytoscape offers support for importing data from delimited text and MS
Excel data tables.

Sample Data Table 1


Sample Data
 	Object Key  	Alias        	SGD ID  

 	AAC3    	YBR085W|ANC3       	S000000289    
 
 	AAT2 	YLR027C|ASP5    	S000004017 

 	BIK1    	YCL029C|ARM5|PAC14 	S000000534    



The data table file should contain a primary key column and at least one
data column. The maximum number of data columns is unlimited. The
Alias column is an optional feature, as is using the first row of
data as column names. Alternatively, you can specify each column name
from the File → Import → Table from File… user interface.

 


Basic Operation

[image: _images/ImportColumnsFromTable.png]


	Select File → Import → Table from File…. Alternatively, you can
simply drag and drop the file from the desktop into the Table Panel, or click the Import Table from File… [image: _images/ImportTableButton.png] in the Table Panel interface.


	Select a data file. The file can be either a text or
Excel (.xls/.xlsx) file.


	In the Target Table Data section, choose where to import the
data to. You can choose an existing network collection, a specific
network only, or you can choose to import the data to an
Unassigned Table (described below).


	Depending on what you choose in the Where to import Table Data
drop-down, you will need to select a network collection or
specific network. You will also need to select Import Data as,
that is whether the data is node, edge or network table columns.


	If the table is not properly delimited in the preview panel, change
the delimiter in the Advanced Options panel. The default
delimiter is tab. This step is not necessary for Excel Workbooks.


	By default, the first column is designated as the primary key, as
designated by the key [image: _images/Key.png]
icon. Make sure the column designated as key matches what’s selected
under Key Column for Network (i.e. the key in the network. To set
another column as the key instead, click the arrow at next to the column
title and select the key symbol.


	Similarly, to change the data type of a column, for example from
integer to string, click the arrow next to the column title, and
select the correct data type.




[image: _images/ChangeDataType.png]


	Click OK to import.





Unassigned Table

As of Cytoscape 3.1. it is possible to import data tables without
assigning them to existing networks, meaning the data doesn’t have to
correspond to any nodes/edges currently loaded. If a data table is
imported as unassigned and a network is later imported that maps to the
data in terms of nodes or edges, the data will link automatically. This
is useful when loading a large dataset (for example expression data),
defining a Style for visualizing the data on networks and later
loading individual networks to view the data, for example from an online
database. This feature allows the data to be automatically linked to any
network that is applicable, without having to load the data for each
network.
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9. Column Data Functions and Equations

 


9.1. Column Formulas

 


Introduction

Columns may contain formulas that are evaluated on-demand and result
in a value.



Syntax


Basic Syntax

A formula always starts with an equals sign ‘=’. This signifies that the
value in the table cell is a formula.

Example:  =ABS($otherColumn + LOG(10.2))

The type of the value returned by a formula must match
the column type, or be easily converted to the column type. For example,
if a formula returns a numeric value in a string column, the numeric value
will be converted to a string. However if a formula returns a string value in
a numeric column, the string cannot be automatically converted to a number,
so it will result in an error being shown.

All numeric values will be accepted for a boolean (or logical) column data where
non-zero will be interpreted as true and zero as false.
Floating point values will be converted using the rules
of the Excel(tm) INT function. Parentheses can be used for grouping
and to change evaluation order.



Functions

Cytoscape provides a set of functions that perform specific tasks and calculations.
A function is written as the name of the function, then an opening bracket ‘(’,
then an optional comma-separated list of arguments, then a closing bracket ‘)’.

Example: =MAX(10, 20) 
Example: =IF($otherColumn, “UP”, “DOWN”) 
Example: =NOW() 
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10. Finding and Filtering Nodes and Edges

 


10.1. Search Bar

You can search for nodes and edges by column value directly through
Cytoscape’s tool bar. For example, to select nodes or edges with a
column value that starts with STE, type ste* in the search bar. The
search is case-insensitive. The * is a wildcard character that matches
zero or more characters, while ? matches exactly one character. So
ste? would match STE2 but would not match STE12. Searching for
ste* would match both.

[image: _images/searchbar3.png]

To search a specific column, you can prefix your search term with the
column name followed by a :. For example, to select nodes and edges
that have a COMMON column value that starts with STE, use
common:ste*. If you don’t specify a particular column, all columns
will be searched.

Columns with names that contain spaces, quotes, or characters other than
letters and numbers currently do not work when searching a specific
column. This will be fixed in a future release.

To search for column values that contain special characters you need to
escape those characters using a \. For example, to search for
GO:1232, use the query GO\:1232. The complete list of special
characters is:

+ - & | ! ( ) { } [ ] ^ " ~ * ? : \





Note: Escaping characters only works when searching all columns. It
currently does not work for column-specific searching. This will be
fixed in a future release.

 



10.2. The Select Menu

The Select → Nodes and Select → Edges menus provide several
mechanisms for selecting nodes and edges. Most options are fairly
straightforward and self-explanatory.

A set of keyboard shortcuts for selecting nodes, edges
and annotations are also available. Note that these keyboard shortcuts work
regardless of which Selection Mode for mouse click or drag-selection.
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11. Navigation and Layout

 


11.1. Basic Network Navigation

Cytoscape uses a Zoomable User
Interface [http://en.wikipedia.org/wiki/Zooming_User_Interface] for
navigating and viewing networks. ZUIs use two mechanisms for navigation:
zooming and panning. Zooming increases or decreases the magnification of
a view based on how much or how little a user wants to see. Panning
allows users to move the focus of a screen to different parts of a view.

 


Zoom

Cytoscape provides four mechanisms for zooming: toolbar buttons, menu options, keyboard shortcuts and the scroll wheel.

Use the zooming buttons located on the toolbar to zoom in
and out of the interaction network shown in the current network display.
Zoom icons are detailed below:

[image: _images/zoomicons.png]

From Left to Right:

Zoom In


	Menu option: View → Zoom In


	Keyboard shortcut: Ctrl-Plus (Command-Plus on Mac OS X)




Zoom Out


	Menu option: View → Zoom Out


	Keyboard shortcut: Ctrl-Minus (Command-Minus on Mac OS X)




Fit Content: Zoom level is adjusted to fit the network to the window


	Menu option: View → Fit Content


	Keyboard shortcut: Ctrl-0 (Command-0 on Mac OS X)




Fit Selected: Zoom level is adjusted to zoom on any selected nodes


	Menu option: View → Fit Selected


	Keyboard shortcut: Ctrl-9 (Command-9 on Mac OS X)




Using the scroll wheel, you can zoom in by scrolling up and zoom out by
scrolling downwards. These directions are reversed on Macs with natural
scrolling enabled (the default for Mac OS X Lion and newer versions).

 



Pan

There are two ways to pan the network:


	Left-Click and Drag - You can pan the network view by holding down the left mouse button and moving the mouse.


	Dragging Box on Network
Overview -
You can also pan the view by left-clicking and dragging the blue box in the overview panel in the lower part of the view.




 




11.2. Other Mouse Behaviors

 


Select


	Click the left mouse button on a node, edge or annotation to select that element.


	Hold down the Shift or Ctrl key (Command on Macs) and left-click a node, edge or annotation to add it to the selection. Doing the same on a selected element unselects it.


	Hold down the left mouse button on the canvas background and drag the mouse while holding down the Shift or Ctrl key (Command on Macs) to select groups of nodes/edges/annotations.


	Remember that the selection action (mouse click or drag-selection) only works if the Selection Mode for that element type (i.e. nodes, edges, annotations) is enabled. In order to enable or disable the selection of an element type, just toggle its corresponding button at the bottom of the network view (see image below) or use the options under the menu Select → Mouse Drag Selects.




[image: _images/SelectionModeButtons.png]


	So if you don’t want any nodes to be selected, toggle the button [image: _images/selection-mode-nodes.png] off.


	And if you don’t want any edges to be selected, toggle the button [image: _images/selection-mode-edges.png] off.


	Likewise, if you don’t want any annotations to be selected, toggle the button [image: _images/selection-mode-annotations.png] off.




 



Context

Click the right mouse button (or Ctrl+left mouse button on Macs) on a
node/edge to launch a context-sensitive menu with additional information
about the node/edge.

 



Node Context Menu

This menu can change based on the current context. For nodes, it
typically shows:


	Add


	Diffuse


	Edit


	Select


	Group


	Nested Networks


	Apps


	External Links


	Preferences




Edges usually have the following menu:


	Diffuse


	Edit


	Select


	Apps


	External Links


	Preferences




Apps can contribute their own items into node and edge context menus.
These additions usually appear in the Apps section of the context
menu.

 


Nested Network Node Context Menu


	Add Nested Network: Lets the user select any network in
Cytoscape as the current node’s nested network. If the current node
already has a nested network it will be replaced.


	Remove Nested Network: Removes the currently associated nested
network from a node. The associated network is not deleted. Only the
association between the node and the network is removed.


	Go to Nested Network: The current node’s nested network will be
the current network view and have the focus. Should a network view
for the nested network not exist, it will be created.




More information about nested networks can be found in the Nested
Networks
section.

 





11.3. Manual Layout

The simplest method to manually organize a network is to click on a node
and drag it. All of the selected nodes are moved together.

In addition to the ability to click on a node and drag it to a new
position, Cytoscape now has the ability to move nodes using the arrow
keys on the keyboard. By selecting one or more nodes using the mouse and
clicking one of the arrow keys (←, ↑, →, ↓) the selected nodes will move
one pixel in the chosen direction. If an arrow key is pressed while
holding the Shift key down, the selected nodes will move 15 pixels in the
chosen direction.

 



11.4. Node Layout Tools

The Tool Panel is available via the menu command View → Show Tool Panel, or via Layout → Node Layout Tools.

It contains several Node Layout Tools that can help to automate or fine tune a layout.

 


Scale

Adjust the Scale slider to change the length of edges.  The position of the nodes will be scaled, not the node sizes.
Node size can be adjusted using
Styles.
The images below show selected (yellow) nodes scaled to 50% of the default value.

Before

[image: _images/NodeTools1.png]

After

[image: _images/NodeToolsScaled.png]
 



Rotate

The Rotate function will change the orientation of the entire
network or a selected portion of the network. The images below show a
network with selected nodes rotated 90 degrees.

Before

[image: _images/NodeTools1.png]

After

[image: _images/NodeToolsRotated.png]

 



Align, Distribute and Stack

The Tool Panel contains buttons to set relative postions of nodes.

Align provides
different options for either vertically or horizontally aligning
selected nodes against a line. The differences are in what part of the
node gets aligned, e.g. the center of the node, the top of the node, the
left side of the node. Distribute evenly distributes selected nodes
between the two most distant nodes along either the vertical or
horizontal axis. The differences are again a function what part of the
node is used as a reference point for the distribution. Stack
vertically or horizontally stacks selected nodes with the full
complement of alignment options. The table below provides a description
of what each button does.


Align Options
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12.1. What are Styles?

One of Cytoscape’s strengths in network visualization is the ability to
allow users to encode any table data (name, type, degree, weight,
expression data, etc.) as a property (such as color, size of node,
transparency, or font type) of the network. A set of these encoded or
mapped table data sets is called a Style and can be created or
edited in the Style panel of the Control Panel. In this
interface, the appearance of your network is easily customized. For
example, you can:

Specify a default color and shape for all nodes.

[image: _images/NodeShape.png]

Set node sizes based on the degree of connectivity of the nodes. You
can visually see the hub of a network…

[image: _images/DegreeSize.png]

…or, set the font size of the node labels instead.

[image: _images/DegreeLabelSize.png]

Visualize gene expression data along a color gradient.

[image: _images/ColorGradient.png]

Encode specific physical entities as different node shapes.

[image: _images/NodeShapeMapping.png]

Use specific line types to indicate different types of interactions.

[image: _images/edge_types.png]

Control edge transparency (opacity) using edge weights.

[image: _images/OpacityForEdges.png]

Control multiple edge properties using edge score.

[image: _images/MultipleEdgeMapping.png]

Browse extremely-dense networks by controlling the opacity of nodes.

[image: _images/OpacityForNodesAndEdges.png]

Show highly-connected region by edge bundling and opacity.

[image: _images/Bundling.png]

Add photo/image/graphics on top of nodes.

[image: _images/CustomGraphics1.png]
[image: _images/CustomGraphics4.png]
[image: _images/CustomGraphics5.png]

Cytoscape 3 has several sample styles. Below are a few examples of these
applied to the galFiltered.sif network:

[image: _images/default_style.png]
[image: _images/solid_style.png]
[image: _images/ripple_style.png]
[image: _images/universe_style.png]

 



12.2. Introduction to the Style Interface

The Style interface is located under the Style panel of the
Control Panel.

[image: _images/StylesInterface.png]

This interface allows you to create/delete/view and switch between different
styles using the drop-down and the Options menu. With a specific style selected, the Style panel displays the
details for a given style and is used to edit these details as well.

[image: _images/EditStyles.png]


	At the top of the interface, there is a drop-down for selecting
an pre-defined style.


	The list of available styles is searchable using the search field.


	The Show only Applied Styles button [image: _images/CurrentStyleButton.png] will filter the list to display only the applied style.


	The list of available styles can be edited by clicking the Edit.. [image: _images/EditStylesButton.png]. This will reveal a set of buttons for selecting and deleting styles.


	There is also an Options button [image: _images/OptionsButton.png] with
options to rename, remove, create and copy a Style, and an option to
create a legend for the selected style.


	The main area of the interface is composed of four tabs, for Node,
Edge and Network properties, as well as a Table tab for style options for the Table Panel, for setting mappings on individual columns in the Node and Edge tables. Note that style selections for the Table Panel are not saved as part of the current style.


	Each tab contains a list of properties relevant to the
current style. At the top of the list a Properties drop-down
allows you to add additional properties to the list.


	Each property entry in the list has 3 columns:


	The Default Value shows just that, the default value for
the property. Clicking on the Default Value column for any
property allows you to change the default value.


	Mapping displays the type of mapping currently in use for
the property. Clicking on the Mapping column for any
property expands the property entry to show the interface for
editing the mapping. Details on the mapping types provided
here.


	Bypass displays any style bypass for a selected node
or edge. Note that a node/edge or subset of nodes/edges must be
selected to activate the Bypass column. Clicking on the
Bypass column for selected node(s)/edge(s) allows you to
enter a bypass for that property for selected node(s)/edge(s).
There is no Bypass option for Node Table styles.








The Default Value is used when no mapping is defined for a property,
or for nodes/edges not covered by a mapping for a particular property.
If a Mapping is defined for a property, this defines the style for
all or a subset of nodes/edges, depending on how the mapping is defined.
A Bypass on a specific set of nodes/edges will bypass and override
both the default value and defined mapping.

 



12.3. Introduction to Style

The Cytoscape distribution includes several predefined styles to get you
started. To examine a few styles, try out the following example:

Step 1. Load some sample data


	Load a sample session file: From the main menu, select File
→ Open…, and select the file sampleData/galFiltered.cys.


	The session file includes a network, some annotations, and
sample styles. By default, the style galFiltered Style
is selected. Gene expression values for each node are colored along
a color gradient between blue and yellow (where blue represents a
low expression ratio and yellow represents a high expression ratio,
using thresholds set for the gal1RGexp experiment bundled with
Cytoscape in the sampleData/galExpData.csv file). Also, node size
is mapped to the degree of the node (number of edges connected to
the node) and you can see the hubs of the network as larger nodes.
See the sample screenshot below:




[image: _images/galFilteredSessionDefault.png]

Step 2. Switch between different styles

You can change the style by making a selection from the Current
Style drop-down list, found at the top of the Style panel.

For example, if you select Sample1, a new style will be applied to
your network, and you will see a white background and round blue nodes.
If you zoom in closer, you can see that protein-DNA interactions
(specified with the label pd) are drawn with dashed edges, whereas
protein-protein interactions (specified with the label pp) are drawn
with solid edges (see sample screenshot below).

[image: _images/VizMapperSample1Style26.png]

Finally, if you select Solid, you can see the graphics below:

[image: _images/VizMapperSolidStyle.png]

This style does not have mappings except node/edge labels, but you can
modify the network graphics by editing the Default Value f